HDO6000 High Definition Oscilloscope Operator's Manual

© 2013 Teledyne LeCroy, Inc. All rights reserved.

Unauthorized duplication of Teledyne LeCroy documentation materials other than for internal sales and distribution purposes is strictly prohibited. However, clients are encouraged to distribute and duplicate Teledyne LeCroy documentation for their own internal educational purposes.

HDO6000 and Teledyne LeCroy are registered trademarks of Teledyne LeCroy, Inc. Windows is a registered trademark of Microsoft Corporation. Other product or brand names are trademarks or requested trademarks of their respective holders. Information in this publication supersedes all earlier versions. Specifications are subject to change without notice.

922499 Rev A
May 2013
TABLE OF CONTENTS

Introduction to the HDO Oscilloscopes .............................................................. 1

Setting Up the Oscilloscope ................................................................................. 1
  Checking Shipment ............................................................................................. 1
  Carrying and Placing the Oscilloscope ............................................................. 1
  Positioning the Feet ......................................................................................... 2
  Connecting to Other Devices/Systems .......................................................... 2
  Probes ................................................................................................................ 3
  Powering On ...................................................................................................... 3
  Activating Software Options .......................................................................... 3

Inputs/Outputs ..................................................................................................... 4
  Front Input/Output Panel ................................................................................ 4
  Side Input/Output Panel .................................................................................. 4
  Back Input/Output Panel .................................................................................. 5
  Channel Inputs .................................................................................................. 5

Front Panel .......................................................................................................... 6
  Front Panel Trigger Controls .......................................................................... 7
  Front Panel Horizontal Controls .................................................................... 7
  Front Panel Vertical Controls ........................................................................ 8
  Front Panel Math, Zoom, and Mem(ory) Buttons .......................................... 8
  Front Panel Adjust and Intensity Controls ..................................................... 8
  Miscellaneous Front Panel Controls .............................................................. 9

Touch Screen Display .......................................................................................... 10
  Menu Bar .......................................................................................................... 10
  Signal Display Grid ........................................................................................ 11
  Descriptor Boxes ............................................................................................ 12
  Dialogs .............................................................................................................. 13
  Shortcut Toolbar ............................................................................................... 13

Basic Operations ................................................................................................ 14
  Control Application Window .......................................................................... 14
  Turn on Traces ................................................................................................ 14
  Auto Setup ....................................................................................................... 15
  Enter/Select Data ............................................................................................. 16
  Annotate Traces ............................................................................................... 17
  Print Screen ..................................................................................................... 17

Zoom ..................................................................................................................... 18
  Zooming Traces .............................................................................................. 18
  Zoom Controls ............................................................................................... 20
  Rescale Memory or Math Function Traces ..................................................... 21
  Multi-Zoom ..................................................................................................... 22
HDO6000 High Definition Oscilloscope

Vertical .......................................................................................................................... 23
Vertical Settings ............................................................................................................. 23
Pre-Processing Settings ................................................................................................. 24
Probe Dialog .................................................................................................................... 24
Deskew Channels ........................................................................................................... 25

Timebase ....................................................................................................................... 26
Timebase Settings .......................................................................................................... 26
Sampling Modes ............................................................................................................ 27
Clock Source .................................................................................................................. 32

Triggers ............................................................................................................................ 33
Trigger Modes ................................................................................................................. 33
Trigger Types .................................................................................................................. 34
Trigger Settings .............................................................................................................. 35
Trigger Holdoff .............................................................................................................. 36
Software Assisted Trigger .............................................................................................. 38
TriggerScan .................................................................................................................... 39

Display .............................................................................................................................. 41
Display Setup .................................................................................................................. 41
Moving Traces from Grid to Grid ................................................................................ 41
XY Displays .................................................................................................................... 42
Persistence ....................................................................................................................... 42
Screen Saver .................................................................................................................... 44

Cursors .............................................................................................................................. 45
Cursor Settings ................................................................................................................ 45

Measurement .................................................................................................................... 47
Measure Gate ................................................................................................................. 48
Level and Slope ............................................................................................................... 48
Statistics .......................................................................................................................... 49
View Histicon ................................................................................................................. 49
Help Markers ................................................................................................................. 49
Set Up Measurement Parameter ................................................................................ 51
Qualified Parameters .................................................................................................... 52
Math on Parameters ...................................................................................................... 53
Calculating Measurements ............................................................................................ 55
List of Standard Parameters ......................................................................................... 58

Math .................................................................................................................................. 62
Set Up Math Function .................................................................................................... 63
Common Math Applications ......................................................................................... 65
List of Math Functions .................................................................................................... 73

Analysis ............................................................................................................................. 75
Histogram ........................................................................................................................ 76
Trend and Track .............................................................................................................. 78
WaveScan ....................................................................................................................... 80
History Mode .................................................................................................................. 84
Pass/Fail Parameter Testing Overview ................................................................. 85
Mask Testing .................................................................................................................. 85
Spectrum Analyzer ..................................................................................................... 88
View Configurations ................................................................................................. 94

Utilities .......................................................................................................................... 95
Utilities Settings ......................................................................................................... 95
System Status ................................................................................................................ 95
Add Software Options ............................................................................................... 96
Remote Control Settings ......................................................................................... 96
Print (Hardcopy) Settings ....................................................................................... 97
Auxiliary Output Settings ....................................................................................... 100
Date/Time Settings ................................................................................................... 101
Disk Utilities ............................................................................................................... 102
Preferences Settings ................................................................................................. 103
Calibration Settings .................................................................................................. 104
Acquisition Settings .................................................................................................. 105
Color Settings ........................................................................................................... 105
E-Mail ............................................................................................................................ 106
Miscellaneous Settings .............................................................................................. 106

Save/Recall (File Functions) ...................................................................................... 107
Save/Recall Setups ..................................................................................................... 107
Save/Recall Waveforms ........................................................................................... 108
Save Table Data ......................................................................................................... 111

LabNotebook ................................................................................................................ 112
Create Notebook Entry ............................................................................................. 112
LabNotebook Drawing Toolbar ................................................................................ 113
Print to NoteBook Entry ......................................................................................... 114
Manage Notebook Entries ....................................................................................... 114
Manage Notebooks .................................................................................................... 116
Flashback Recall ........................................................................................................ 117
Configure LabNotebook Preferences ...................................................................... 117

Maintenance .................................................................................................................. 118
Safety Instructions ...................................................................................................... 118
Calibration .................................................................................................................. 120
Touch Screen Calibration ......................................................................................... 120
Oscilloscope Application Software ......................................................................... 121
Technical Support ...................................................................................................... 123
Returning a Product for Service .............................................................................. 123
Teledyne LeCroy Service Centers ........................................................................... 125

Certifications and Licenses ......................................................................................... 127
Certifications ............................................................................................................... 127
Windows License Agreement ................................................................................... 129
Introduction to the HDO Oscilloscopes

Combining Teledyne LeCroy’s HD4096 high-definition technology with long memory, a compact form factor, 12.1” touch screen display, and powerful debug and circuit analysis tools, the HDO6000 Oscilloscopes are ideal for precise measurements and quick debug. Tools such as Spectrum Analyzer, WaveScan® Search and Find, and LabNotebook Report Generator help identify, isolate, and document problems for faster troubleshooting.

HD4096 high-definition technology consists of high sample rate 12-bit ADCs, high signal-to-noise input amplifiers, and a low-noise system architecture. This technology enables HDO™ oscilloscopes to capture and display signals up to 1 GHz with a high sample rate and 16 times more resolution than other oscilloscopes.

Waveforms captured and displayed on the HDO6000 with HD4096 technology are cleaner and crisper. Signal details often lost in the noise are clearly visible and easy to distinguish, and measurements can be performed with unmatched precision for improved debug and analysis.

Detailed oscilloscope specifications are maintained on the product page at teledynelecroy.com.

Setting Up the Oscilloscope

Checking Shipment
Verify that all items on the materials list below have been shipped to you:

- one (1) oscilloscope
- four (4) passive probes (one for each channel)
- one (1) AC line (power) cord rated for country of use
- one (1) protective front cover
- one (1) Getting Started Guide
- one (1) Oscilloscope Security Certificate
- one (1) Oscilloscope Registration Card
- one (1) Calibration Document

Contact your nearest Teledyne LeCroy customer service center or national distributor if anything is missing or damaged. We can only be responsible for replacement if you contact us immediately.

Carrying and Placing the Oscilloscope
The oscilloscope’s case contains a built-in carrying handle. Lift the handle away from the oscilloscope body, grasp firmly and lift the instrument. Always unplug the instrument from the power source before lifting and carrying it.

Place the instrument where it will have a minimum 15 cm (6 inch) clearance from the nearest object. Be sure there are no papers or other debris beneath the oscilloscope or blocking the cooling vents.

⚠️ Do not place the instrument so that it is difficult to reach the power cord in case you need to quickly disconnect from power.
Positioning the Feet
The HDO is equipped with rotating, tilting feet to allow four different viewing positions.
To tilt the body back slightly for bench top viewing, pull the small flaps on the bottom of the feet away from the body of the oscilloscope.
To tilt the body forward, rotate both feet to the back. This position is useful when placing the oscilloscope on a high shelf. Pulling out the flaps in this position increases the angle of the tilt.

Connecting to Other Devices/Systems
Make the desired cable connections. All except for the power connection are optional.
After start up, configure the connection on the oscilloscope using the menu options listed below. More detailed instructions are provided later in this manual.

Power
Connect the line cord rated for your country to the AC power inlet on the back of the instrument, then plug it into a grounded AC power outlet. (See Power and Ground Connections in General Safety Information.)

LAN
Connect a cable from either Ethernet port on the side panel to a network access device. On the oscilloscope, use the standard Windows Network dialog to configure the network connection. Go to Utilities > Preference Setup > Email to configure email settings.

USB Peripherals
Connect the device to a USB port on the front or side of the instrument. Go to Utilities > Utilities Setup > Hardcopy to configure printer settings.

External Monitor
Connect the monitor cable to a video output on the side of the instrument (VGA, DVI, and HDMI are all supported). Go to Display > Display Setup > Open Monitor Control Panel to configure the display settings.

External Controller
Connect a USB-A/B cable from the USBTMC port on the back of the instrument to the controller. Go to Utilities > Preference Setup > Remote to configure remote control.

Other Instrument (for Reference Clock)
Connect a BNC cable from Ref In/Out on the back of the oscilloscope to the other instrument. Go to Timebase > Horizontal Setup > Reference Clock to configure the clock.

Other Auxiliary Device
Connect a BNC cable from Aux Out on the back of the instrument to the other device. Go to Utilities > Utilities Setup > Aux Output to configure the output.
Probes
HDO6000 oscilloscopes are compatible with the included passive probes and all Teledyne LeCroy ProBus active probes that are rated for the oscilloscope’s bandwidth. Probe specifications and documentation are available at teledynelecroy.com/hdo6000.

The passive probes supplied with your oscilloscope are matched to the input impedance of the HDO, but may need further compensation; refer to the probe manual for the procedure. If using other passive probes with your HDO oscilloscope, be sure to perform a low frequency calibration using the Cal signal available from the HDO’s front panel before using them to measure signal.

Follow the directions in the probe instruction manual to compensate the low and/or high frequency response of the probes.

Powering On
The Standby button on the lower, left side of the front of the oscilloscope controls the operational state of the oscilloscope. Press the button to switch on the instrument; press it again to switch “off” (i.e., reduced power).

⚠️ CAUTION. Do not change the instrument’s Windows Power Options from the default Never to System Standby or System Hibernate modes.

Always use the Standby button or the File > Shutdown menu option to execute a proper shut down process and preserve settings. Pressing and holding the Standby button will execute a “hard” shutdown, the same as on a computer, but we do not recommend doing this because it does not allow the Windows operating system to shut down properly.

The Standby button does not disconnect the oscilloscope from the AC power supply; some “housekeeping” circuitry continues to draw power. The only way to fully power down the instrument is to use the Standby button or the File > Shutdown command, then unplug the AC line cord from the outlet. We recommend unplugging the instrument if it will remain unused for a long period of time.

Upon power-up, the oscilloscope loads the instrument application software automatically.

Activating Software Options
The oscilloscope operating software (firmware and standard applications) is active upon delivery.

Free firmware updates are available periodically from the Teledyne LeCroy website at teledynelecroy.com/support/softwaredownload. Registered users can receive an email notification when a new update is released. Follow the instructions on the website to download and install the software.

If after your trial has ended you decide to purchase an option, you will receive a license key via email that activates the optional features on the oscilloscope. See Add a New Software Option.
Inputs/Outputs

Front Input/Output Panel

A. The **Power button** turns on/off the oscilloscope. See [Powering On](#) for more information.

B. **Channel inputs** 1–4 (or 1–2 depending on model) are signal inputs to the oscilloscope; EXT is for connecting an external trigger device.

C. **Ground and calibration output terminals** are used to compensate passive probes.

D. Two (2) **front-mounted host USB ports** can be used for transferring data or connecting peripherals such as a mouse or keyboard.

Side Input/Output Panel

A. Video Output **VGA, DVI, and HDMI** ports connect the oscilloscope to external monitors.

B. **USB Ports** (4) allow you to connect external USB devices, such as storage drives.

C. **Ethernet Ports** (2) connect the oscilloscope to networks.

D. Audio Input/Output **Mic, Speaker, and Line-In** jacks connect the oscilloscope to external audio devices.
Back Input/Output Panel

A. **Aux Out** connector sends device trigger enabled, trigger out, or pass/fail output to another device.

B. **Ref In/Out** connector allows you to input an external Reference Clock, or to output a Reference Clock to another instrument.

C. **USBTMC Port** enables remote control of the oscilloscope.

D. **AC Power Inlet** connects the AC line cord.

See the general set up instructions for more information about configuring connections to other devices.

Channel Inputs

A series of connectors arranged beneath the oscilloscope display are used to input signal on Channels 1-4, or an external trigger pulse on EXT.

The channel inputs power probes and completely integrate them with the oscilloscope:

- Upon connection, the probe type is recognized and some setup information, such as input coupling and attenuation, is performed automatically. This information is displayed on the Channel **Probe Dialog**.

- System (probe plus oscilloscope) gain settings are automatically calculated and displayed based on the probe attenuation.

HDO channel inputs use the ProBus interface and are compatible with any Teledyne LeCroy ProBus type probes rated for the oscilloscope's bandwidth.

The ProBus interface contains a 6-pin power and communication connection and a BNC signal connection to the probe. It offers both 50 Ω/1 MΩ input impedance and provides probe power and control for a wide range of probes such as high impedance passive probes, high impedance active probes, current probes, high voltage probes, and differential probes. ProBus also includes sense rings for detecting passive probes. The ProBus interface may also have a BNC-terminated cable connected directly to it.
Most Front Panel controls duplicate functionality available through the touch screen display and are described on the following pages.

Shortcut buttons arranged across the top of the Front Panel give quick access to commonly used functions. Other shortcut buttons arranged across the bottom open special applications.

All the knobs on the Front Panel function one way if turned and another if pushed like a button. The top label describes the knob’s principal “turn” action, and the bottom label describes its “push” action.

Front panel buttons light up to indicate which traces and functions are active. Actions performed from the Front Panel always apply to the active trace.
Front Panel Trigger Controls

**Level knob** - Changes the trigger threshold level (V). The number is shown on the Trigger descriptor box. Pushing the knob sets the trigger level to the 50% point of the input signal.

**READY and TRIG'D Indicators** - The READY indicator is lit when the trigger is armed. TRIG'D is lit momentarily when a trigger occurs. A fast trigger rate causes the light to stay lit continuously.

**Setup** - Corresponds to the menu selection Trigger → Trigger Setup. Press it once to open the Trigger Setup dialog and again to close the dialog.

**Auto** - Sets Auto trigger mode, which triggers the oscilloscope after a time-out, even if the trigger conditions are not met.

**Normal** - Sets Normal trigger mode, which triggers the oscilloscope each time a signal is present that meets the conditions set for the type of trigger selected.

**Single** - Sets Single trigger mode, which arms the oscilloscope to trigger once (single-shot acquisition) when the input signal meets the trigger conditions set for the type of trigger selected. If the scope is already armed, it will force a trigger.

**Stop** - Prevents the scope from triggering on a signal. If you boot up the instrument with the trigger in Stop mode, a "No trace available" message is shown. Press the Auto button to display a trace.

Front Panel Horizontal Controls

The Horizontal Front Panel group corresponds to the Timebase dialog.

**Delay knob** - Turn to change the Trigger Delay value (S). Push the knob to reset Delay to zero.

**Horizontal Adjust knob** - If the trace source is an input channel, turn this knob to set the Time/division (S) of the oscilloscope acquisition system. The value is shown on the Timebase descriptor box. When using this control, the oscilloscope allocates memory as needed to maintain the highest sample rate possible for the timebase setting. If the trace source is a zoom, memory or math function, turn the knob to change the horizontal scale of the trace, effectively "zooming" in or out. The value is shown on the corresponding descriptor box. Push the knob to change the setting in fine increments; push it again to return to 1, 2, 5, 10 step increments.
Front Panel Vertical Controls

**Channel buttons** - Turn on a channel that is off, or activate a channel that is already on. When the channel is active, pushing its channel button turns it off. A lit button shows the active channel (in this figure, C2 is lit).

**Offset knob** - Adjusts the zero level of the trace (this makes it appear to move up or down relative to the center axis of the grid). The value appears on the trace descriptor box. Push it to reset Offset to zero.

**Gain knob** - Sets Vertical Gain (V/div). The value appears on the trace descriptor box. Push it once to adjust V/div in fine increments; push it again to adjust in 1, 2, 5, 10-step increments.

Front Panel Math, Zoom, and Mem(ory) Buttons

The Zoom button creates a quick zoom for each open channel trace. It's resulting zoom trace(s) will be 1/10 of the channel timebase and centered on the display. Touch the zoom trace descriptor box to display the zoom controls.

The Math and Mem(ory) buttons open the corresponding setup dialogs.

If a Zoom, Math or Memory trace is active, the button illuminates to indicate that the Vertical and Horizontal knobs will now control that trace.

Front Panel Adjust and Intensity Controls

The Adjust knob changes the value in any highlighted data entry field when turned. Pushing the Adjust knob toggles between coarse (large increment) or fine (small increment) adjustments when the knob is turned.

The Intensity button sets the Adjust knob to control the trace intensity. When more data is available than can actually be displayed, the Intensity button helps to visualize significant events by applying an algorithm that dims less frequently occurring samples. This feature can also be accessed from the Display > Display Setup dialog.

*Intensity 40% (left) dims samples that occur ≤ 40% of the time to highlight the more frequent samples, vs. intensity 100% (right) which shows all samples at the same intensity.*
Miscellaneous Front Panel Controls

**Top Row**

- **Auto Setup** - Performs an Auto Setup. After the first press, you will be prompted for a confirmation. Press the button again or use the touch screen to confirm.
- **Default Setup** - Resets the oscilloscope to the factory default configuration. See Save/Recall Settings.
- **Print** - Captures the entire screen and outputs it according to your Hardcopy settings. It can also be configured to output a LabNotebook entry.
- **Touch Screen** - Enables or disables touch screen functionality.
- **Clear Sweeps** - Resets the acquisition counter and any cumulative measurements.

**Bottom Row**

- **Decode** - Opens the Serial Decode dialog if you have serial data decoder options installed.
- **WaveScan** - Opens the WaveScan dialog.
- **Spectrum** - Opens the Spectrum Analyzer dialog if you have that option installed.
- **History** - Opens the History Mode dialog.
Touch Screen Display

The touch screen is the principal viewing and control center of the oscilloscope. The entire display area is active: use your finger or the stylus to touch, double-touch, touch-and-drag, touch-and-hold (right click) or draw a selection box. Many controls that display information also work as “buttons” to access other functions.

If you have a mouse installed, you can click anywhere you can touch to activate a control; in fact, you can alternate between clicking and touching, whichever is convenient for you.

The touch screen is divided into the following major control groups:

Menu Bar

The top of the screen contains a complete menu of oscilloscope functions. Making a selection here changes the dialogs displayed at the bottom of the screen.

Many common oscilloscope operations can also be performed from the Front Panel or launched via the Descriptor Boxes. However, the menu bar is the best way to access dialogs for Save/Recall (File) functions, Display functions, Status, LabNotebook, Pass/Fail setup, and Utilities/Preferences setup.

If an action can be “undone” (such as a zoom/rescale of a trace), a small Undo button appears at the far right of the menu bar. Click this to return to the previous oscilloscope display.
Signal Display Grid
The grid area displays the waveform traces. It is sectioned into 10 Horizontal (Time) divisions and 8 Vertical (Voltage) divisions.

Multiple Grid Display
You can divide the display to simultaneously view multiple traces in different grids. By default, the oscilloscope has Auto Grid enabled. This divides the display into additional grids each time a new trace is opened, up to 16 grids for simultaneous viewing.

There are Display menu options to show all traces on a Single Grid, or to manually divide the display into different grid sizes and formats. When you manually divide the display, zooms and measurement markers appear on the same grid as the source channel, while math and memory traces appear in new grids until none are available.

Manually move traces from grid to grid by activating the trace and touching the Next Grid shortcut button. Of special note, you can also move a trace to another grid by dragging its descriptor box to the desired grid.

Adjusting Grid Brightness
You can adjust the brightness of the grid lines to make either the grid or traces more visible. Go to Display > Display Setup and enter a new Grid Intensity percentage.

Grid Indicators
These indicators appear over the grid to mark important points on the display. They are matched to the color of the trace to which they apply.

- **Trigger Position** - A small triangle along the bottom (horizontal) edge of the grid shows the time the oscilloscope is set to trigger an acquisition. Unless Delay is set, this indicator is at the zero (center) point of the grid. Trigger Delay is shown at the top right of the Timebase descriptor box.
Pre/Post-trigger Delay - A small arrow to the bottom left or right of the grid indicates that a pre- or post-trigger Delay has shifted the Trigger Position indicator to a point in time not displayed on the grid. All trigger Delay values are shown on the Timebase Descriptor Box.

Trigger Level - This small triangle at the right edge of the grid tracks the trigger voltage level. If you change the trigger level when in Stop trigger mode, or in Normal or Single mode without a valid trigger, a hollow triangle of the same color appears at the new trigger level. The trigger level indicator is not shown if the triggering channel is not displayed.

Zero Volts Level - This indicator is located at the left edge of the grid. One appears for each open trace on the grid, sharing the number and color of the trace.

Various Cursor lines appear over the grid to indicate specific voltage and time values on the waveform. Touch-and-drag cursor indicators to quickly reposition them.

Signal Display Grid Pop-Up Menu
Touching/clicking a trace opens a pop-up menu with shortcuts to the appropriate trace setup dialog, or the Math and Measure setup dialogs. You can also use it to turn off the trace or place an annotation label on it.

Descriptor Boxes
Shown just beneath the grid display, these boxes provide a summary of your channel, timebase and trigger settings, and also act as convenient navigation tools.

Trace Descriptor Box
Trace descriptor boxes appear when a trace is turned on. Touch the descriptor box once to activate the corresponding trace. When a trace is active, its corresponding descriptor Box is shown highlighted, and Front Panel controls will work for that trace. Touch the descriptor box a second time to open its corresponding setup dialog.

Channel trace descriptor boxes show Vertical settings and any cursor selection: (clockwise from top left) Trace Number (Cx), Pre-Processing List (summarizes changes from default state), Coupling, Gain Setting, Offset Setting, and Averaging Sweeps Count. Codes are used to indicate pre-processing that has been applied to the input. The codes have a long and short form. When several processes are in effect, the short form is used.

<table>
<thead>
<tr>
<th>Pre-Processing Type</th>
<th>Long Form</th>
<th>Short Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sin X Interpolation</td>
<td>SINX</td>
<td>S</td>
</tr>
<tr>
<td>Averaging</td>
<td>AVG</td>
<td>A</td>
</tr>
<tr>
<td>Inversion</td>
<td>INV</td>
<td>I</td>
</tr>
<tr>
<td>Deskew</td>
<td>DSQ</td>
<td>DQ</td>
</tr>
<tr>
<td>Coupling</td>
<td>DC50, DC1M or AC1M</td>
<td>D50, D1M, or A1</td>
</tr>
<tr>
<td>Ground</td>
<td>GND</td>
<td>G</td>
</tr>
<tr>
<td>Bandwidth Limiting</td>
<td>BWL</td>
<td>B</td>
</tr>
</tbody>
</table>

Similar descriptor boxes appear for zoom (Zx), math (Fx), and memory (Mx) traces. These will also show any Horizontal scaling that differs from the signal Timebase.
**Timebase Descriptor Box**
The TimeBase descriptor box shows: (clockwise from top right) Trigger Delay (position), Time/div, Sample Rate, Number of Samples, and Sampling Mode (blank when in real-time mode).

**Trigger Descriptor Box**
Trigger descriptor box shows: (clockwise from top right) Trigger Source and Coupling, Trigger Level (V), Slope, Trigger Type, Trigger Mode.

Setup information for Horizontal cursors, including the time between cursors and the frequency, is shown beneath the TimeBase and Trigger trace descriptor boxes. See the **Cursors** section for more information.

**Dialogs**
Dialogs appear at the bottom of the display for entering setup data. The top dialog will be the main entry point for the selected setup option. For convenience, related dialogs appear as a series of tabs behind the main dialog. Touch the tab to open the dialog.

Dialogs may also display right-hand dialogs (sub-tabs) or pop-up dialogs. These often change depending on the other selections made on the left-hand dialog.

Many dialog settings can be made using either the touch screen or the Front Panel buttons.

**Shortcut Toolbar**
Several dialogs contain a row of buttons at the bottom of the dialog. These provide a shortcut to common functions without having to leave the underlying setup dialog.

- **Measure** - Opens the Measure pop-up to set measurement parameters on the active trace.
- **Zoom** - Creates a zoom trace of the active trace.
- **Math** - Opens the Math pop-up to apply math functions to the active trace and create a new math trace.
- **Decode** - Opens the main Serial Decode dialog where serial data decoders can be configured and applied.
- **Store** - Loads the active trace into the corresponding memory location (C1 to M1; C2 to M2, etc.).
- **Find Scale** - Automatically performs a vertical scaling that fits the waveform into the grid.
- **Next Grid** - Automatically moves the active trace to the next grid. If you have only one grid displayed, a new grid will be created automatically, and the trace moved.
- **Label** - Opens the Label pop-up to annotate the active trace.
- **Probe Cal** - Cable Deskew - Opens the Probes Cal. dialog where various Gain, Offset, Skew, Source, and Advanced controls are available for probe signal calibration.

**Hist(ogram), Track, and Trend** buttons appear at the bottom of the **Measure** (Px) dialogs. They allow you to create a Math function to draw the corresponding type of plot (Histogram, Trend, or Track) while remaining on the Measure setup dialog.
Basic Operations

Control Application Window
The oscilloscope applications runs on a Windows Embedded Standard 7P Operating System and functions exactly as do other Windows applications. The application software loads automatically when you turn on the oscilloscope using the Power button.

To minimize the application window and show the Windows desktop, touch the minimize button or choose File > Minimize. To restore the window after minimizing, touch the oscilloscope display icon in the lower right corner of the desktop.

To exit the application window, choose File > Exit. When you exit the application, the oscilloscope operating system continues to run. To reload the application after exiting, touch the Start DSO desktop shortcut.

To restart Windows (reboot the oscilloscope), choose File > Shutdown. Wait 10 seconds then press the Power button on the front of the oscilloscope.

Turn on Traces

Channel Trace
Press the Front Panel Channel buttons (1-4), or from the menu bar, choose Vertical > Channel <#>.

A new trace representing that input signal opens on the grid.

NOTE: The default is to display each trace in its own grid automatically. To change how traces are arranged, choose another option from the Display menu.

Other Traces
You can quickly create zoom or math traces without leaving the setup dialogs by touching the Zoom or Math shortcut button at the bottom of the dialog.

You can also use the Front Panel Zoom, Math, or Mem(ory) buttons to quickly create traces. The Zoom control automatically creates zoom trace(s) that are 1/10 of the original waveform(s). The middle of the grid is used as the center of the zoom trace.
A trace descriptor box appears on the display for each open channel, zoom, math, or memory trace. Touch this box at any time to activate the trace and open its setup dialog. A highlighted descriptor box indicates the active trace to which all actions apply.

Active trace descriptor (left), inactive trace descriptor (right).

Although several traces may be open and appear on the grid, only one at a time is active. Whenever you activate a channel, math or memory trace, the dialog at the bottom of the screen automatically switches to the appropriate setup dialog for that trace. The tab at the top of the dialog shows to which trace it applies.

Channel descriptor label matches Channel setup dialog tab.

**Auto Setup**

Auto Setup quickly configures the essential oscilloscope settings based on the first input signal it finds, starting with Channel 1. If nothing is connected to Channel 1, it searches Channel 2 and so forth until it finds a signal.

Vertical Scale (V/div), Offset, Timebase (Time/div), and Trigger are set so that there is an Edge trigger on the first, non-zero-level amplitude, and the entire waveform is visible for at least 10 cycles over the 10 horizontal divisions.

To run Auto Setup, connect your inputs, then:

Press the **Auto Setup** Front Panel button.

**OR**

Choose **Auto Setup** from the **Vertical**, **Timebase**, or **Trigger** menus. All these options perform the same Auto Setup function.

To confirm Auto Setup, press the Auto Setup button again or use the touch screen display.
Enter/Select Data

Touch & Type
Touching once activates a control. In some cases, you’ll immediately see a pop-up menu of options. Touch one to select it.

In other cases, data entry fields appear highlighted on the display. When a data entry field is highlighted, it is active and can be modified by using the Front Panel Adjust knob.

If you have a keyboard installed, you can type your entry in the active field. Or, you can touch again, then select your entry from the pop-up menu or keypad.

When there are long lists of values, the pop-up may contain scroll bars or Up/Down arrow keys. Use these to navigate to the desired value. It may also help to use the stylus to make the selection when values lie close together on the display.

You’ll see a pop-up keypad when you double-touch a numerical data entry field. Touch the soft keys to use it exactly as you would a calculator. When you touch OK, the calculated value is entered in the field.

Touch & Drag

Touch-and-drag waveforms, cursors, and trigger indicators to reposition them on the grid; this is the same as setting the values on the dialog.

Quickly zoom areas of the grid by touching and dragging to draw a selection box around a portion of the trace.
Annotate Traces

The Label function gives you the ability to add custom annotations to traces that are shown on the display. Labels are numbered sequentially in the order they were created. Once placed, labels can be moved to new positions and turned on/off.

Create Label

1. Touch the trace, then choose Set label... from the display grid pop-up menu.

   OR

   Touch the trace descriptor box twice, then touch the Label shortcut button on the setup dialog.

2. On the Trace Annotation dialog, touch Add Label.

3. Enter the Label Text.

4. Optionally, enter the Horizontal Pos. at which to place the label. The default position is 0 ns horizontal.

5. Close the dialog.

Edit/Remove Label

1. Touch the label and choose Set Label from the pop-up menu.

2. Select the Label number. You can use the Up/Down arrow keys to scroll the list.

3. Change the Label Text and/or Horizontal Pos., or touch Remove Label to delete it.

4. Close the dialog.

Turn On/Off Labels

After labels have been placed on a grid, you can turn on/off all labels at once by opening the Trace Annotation dialog and selecting/deselecting the View Label checkbox.

Print Screen

Print captures an image of the display and outputs it according to your Hardcopy settings, which may be to send it to a network printer, e-mail it, save it to a file, or copy it to the clip-board to paste into another application.

There are three ways to print:

- Touch the Front Panel Print button.
- Choose File > Print.
- Choose Utilities > Utilities Setup > Hardcopy tab and touch the Print button to the far right of the dialog.

NOTE: The Front Panel Print button can be configured to capture the screen as a LabNotebook entry. In this case, only the File and Utilities menu print options will function according to your Hardcopy setup.
Zooming Traces
The Zoom function magnifies a selected region of a trace. On HDO6000 model oscilloscopes, you can display up to eight zoom traces (Z1 - Z8) taken from any channel, math, or memory trace.

Create Zoom
To create a zoom, touch -and-drag to draw a selection box around any part of the source waveform.

The zoom will resize the selected portion to fit the full width of the grid. The degree of vertical and horizontal magnification, therefore, depends on the size of the rectangle that you draw.

Usually the zoom opens in a new grid, or the next empty grid, with the zoomed portion of the source trace highlighted. If there are no more available grids, zooms will open in the same grid as the source trace.
New zooms are turned on and visible by default. However, you can turn off a particular zoom if the display becomes too crowded, and the zoom settings are saved in its location, ready to be turned on again when desired.

The zoom's voltage level and time per division will differ from the source trace, as seen from a comparison of the trace descriptor boxes. The zoom descriptor shows its Horizontal and Vertical Scale, rather than Vertical Gain and Offset of the source.

![Channel descriptor box and its Zoom descriptor box.](image)

You can further adjust these settings using the Front Panel knobs, or by changing the settings on the Zoom dialog. Touch the zoom descriptor box to activate it, then touch it again to display the Zx tab:

Because it is a calculated and not a sampled trace, you can adjust the zoom’s Horizontal Scale without changing the oscilloscope's Timebase (a characteristic shared with math and memory traces).

**Turn off Zoom**

Turn off a zoom trace the same as you would any other trace:

- Deselect the Trace On checkbox on the Zoom dialog.
- Touch-and-hold (right-click) the descriptor box until the pop-up menu opens, then choose Off.

**Quick Zoom**

Use the Front Panel Zoom button to quickly create one zoom trace for each displayed channel trace.

**NOTE:** Quick zooms are created at the same vertical scale as the source trace and 10x horizontal magnification.

To turn off the quick zooms, press the Zoom button again.

**Multi-Zoom**

The Multi-Zoom feature creates time-locked zoom traces for only the waveforms that you choose to include. The zooms are of the same X-axis section of each waveform. As you scroll through a waveform, all included zooms scroll in unison.
**Zoom Controls**

Once the zoom trace has been created, adjust its Vertical and Horizontal Scale to further "zoom" in or out. You can do this by activating the zoom trace and using the Front Panel Vertical and Horizontal knobs, or by modifying settings on the **Zoom dialog**.

To access it the Zoom dialog, double-touch any zoom trace descriptor box, or choose **Math > Zoom Setup** from the menu bar.

**Main Zoom Dialog**

The main Zoom dialog contains selection boxes for turning on/off zoom traces, plus options to:

- **Reset All** - returns all zooms to x1 magnification.
- **Quick Zoom** - creates a corresponding zoom trace for each open channel trace, same as the Front Panel Zoom button.

**MultiZoom**

Behind the main dialog is a tab for each potential zoom trace (Z1-Z8). It reflects the current settings for any zooms that are created, even if that trace is not displayed on the grid (i.e., Trace On is deselected).

**Trace Controls**

- **Trace On** - displays the zoom trace. Select/deselect this box to show/hide the zoom.
- **Source** - lets you change the source for this zoom to any channel, math, or memory trace while maintaining all other settings.

**Segment Controls**

These controls are used in **Sequence Sampling Mode**.
**Rescale Controls**

These controls on the Zx dialogs are the same used to rescale any trace, and you will see them throughout the oscilloscope software. They work the same wherever they appear.

- **In/Out buttons** - increase or decrease the magnification of the zoom, and consequently change the Horizontal and Vertical Scale settings. Continue to touch either button until you've achieved the desired level of zoom.
- **Var. checkbox** - enables variable zooming in increments finer than the default 1, 2, 5, 10 step increments. When checked, each touch of the zoom control buttons changes the degree of magnification by a single increment.

**Horizontal Scale/div** - sets the amount of time represented by each horizontal division of the grid. It is the equivalent of Time/div, only unlike the Timebase setting, it may be set differently for each zoom, math function, or memory trace.

**Vertical Scale/div** - sets the voltage level represented by each vertical division of the grid; it's the equivalent of V/div used for channel settings.

**Horizontal/Vertical Center** - sets the voltage or time that is to be at the center of the screen on the zoom trace. The horizontal center is the same for all zoom traces.

**Reset Zoom** - returns the zoom to x1 magnification.

**Rescale Memory or Math Function Traces**

Unlike channel traces, memory (M1 - M4) or math function (F1 - F8) traces can be rescaled directly without having to create a separate zoom trace. The same set of controls used to rescale zoom traces appear on the Zoom right-hand dialog, or on one of the setup dialog tabs. This applies to any trace that is created as a math function (Fx) trace, including those that are generated through analysis options.

You can, however, create a separate zoom trace from a memory or function trace by drawing a selection box around a portion of the waveform. In this case, you choose one of the zoom locations in which to draw the trace, Z1-Z8, but the source trace remains at the original scale.
Multi-Zoom
Multi-Zoom creates time-locked zoom traces for only the waveforms that you choose to include. The zooms are of the same X-axis section of each waveform. As you scroll through a waveform, all included zooms scroll in unison.

**Set Up Multi-Zoom**
1. Choose **Math → Zoom Setup...** to open the Zoom dialog, then touch the **Multi-Zoom tab** or **Multi-Zoom Setup...** button.
2. On the Multi-Zoom dialog, turn **Multi-Zoom On** and select all the traces that are **In** the Multi-Zoom group.

**Scroll Waveforms**
The Auto-Scroll controls appear at the right of the Multi-Zoom dialog. They work similarly to A/V controls to allow you to continuously scroll all the selected zoom traces together in time-locked steps from the beginning to the end of the acquisition.

In the image above, they are from left to right, top to bottom row:

- **Scroll Left Fast** - back in time
- **Scroll Left Slow** - back in time
- **Pause** - stop scrolling
- **Scroll Right Slow** - forward in time
- **Scroll Right Fast** - forward in time
- **Jump to Start** - go to beginning of acquisition
- **Jump to End** - go to end of acquisition
- **In/Out** - increase or decrease magnification level of zooms
- **Var** - zoom In/Out in finer increments than the default 1, 2, 5, 10 steps
- **Reset Zoom** - return all zooms to same scale as the source trace.

**Turn Off Multi-Zoom**
1. From the menu bar, touch **Math → Zoom Setup....**
2. On the main Zoom dialog, **deselect the MultiZoom checkbox**.
Vertical
Vertical--also called Channel--settings relate to voltage level and control the trace along the Y axis.

The amount of voltage displayed by one vertical division of the grid, or Vertical Scale (V/div), is most quickly adjusted by using the Front Panel **Vertical knob**. The Channel descriptor box (Cx) always shows the current Vertical Scale setting.

More extensive Vertical settings are made on the Channel dialog, which will be labeled Cx after the corresponding channel. To access the Channel dialog, do any of the following:

- From the menu bar, choose **Vertical > Channel <#> Setup**.
- Touch the **Channel descriptor box**.

The Channel dialog contains these control groups:

- **Vertical Controls** for vertical scale, offset, coupling, bandwidth, and probe settings.
- **Shortcut Buttons** to perform certain actions on the channel trace, such as measurement setup, without having to leave the underlying Channel dialog.
- **Pre-Processing Controls** to set up pre-acquisition processes that will affect the waveform, such as noise filtering and interpolation.

If a probe is connected to the channel, the Channel dialog also contains a tab for the **Probe dialog**.

Vertical Settings

Vertical Scale - Set the vertical scale or sensitivity and choose whether to use fixed or variable gain adjustment.

Vertical Offset - Select between zero vertical offset or to set the offset to a specific value.

Coupling - Select from DC 50 Ω, DC1M, AC1M and GROUND.

**CAUTION.** The maximum input voltage depends on the input used. Values are displayed on the front of the oscilloscope. Whenever the voltage exceeds this limit, the coupling mode automatically switches to GROUND. You then have to manually reset the coupling to its previous state. While the unit does provide this protection, damage can still occur if extreme voltages are applied.

Bandwidth - Bandwidth filters are available at a variety of fixed bandwidth settings. The exact settings vary by model.

Probe Attenuation - Enables you to set probe attenuation manually if using a third-party probe. The oscilloscope's inputs automatically sense Teledyne LeCroy probes and sets probe attenuation and Vertical units for you.

Vertical Unit Override - Allows the units of the selected channel to be changed from Volts (V) to Amperes (A). This is useful when using a third party current probe that is not auto-detected or when probing across a current sense resistor.
Pre-Processing Settings

**Averaging** - performs continuous averaging or the repeated addition, with unequal weight, of successive source waveforms. It is particularly useful for reducing noise on signals drifting very slowly in time or amplitude. The most recently acquired waveform has more weight than all the previously acquired ones: the continuous average is dominated by the statistical fluctuations of the most recently acquired waveform. The weight of old waveforms in the continuous average gradually tends to zero (following an exponential rule) at a rate that decreases as the weight increases.

**Deskew** - adjusts the horizontal time offset by the amount entered in order to compensate for propagation delays caused by different probes or cable lengths. The valid range is dependent on the current timebase setting. The Pre-processing deskew and the Math deskew functions perform the same activity. See Deskew Channels.

**Invert** - Inverts the waveform for the selected channel.

**Interpolation** - Linear interpolation, which inserts a straight line between sample points, is best used to reconstruct straight-edged signals such as square waves. \((\sin x)/x\) interpolation, on the other hand, is suitable for reconstructing curved or irregular wave shapes, especially when the sample rate is 3 to 5 times the system bandwidth.

**Noise Filter (ERes)** - Enhanced Resolution (ERes) filtering increases vertical resolution, allowing you to distinguish closely spaced voltage levels. The tradeoff is reduced bandwidth. The functioning of the instrument's ERes is similar to smoothing the signal with a simple, moving-average filter. Use ERes on single-shot waveforms, or where the data record is slowly repetitive (when you cannot use averaging). Use it to reduce noise when your signal is noticeably noisy, but you do not need to perform noise measurements. It also may be used when performing high-precision voltage measurements: zooming with high vertical gain, for example. For more information, see Enhanced Resolution.

Probe Dialog

The Probe Dialog displays probe attributes and (depending on the probe type) allows you to AutoZero or DeGauss Teledyne LeCroy probes from the oscilloscope touch screen.

When a probe is not connected, the Channel dialog shows only the C1 tab for vertical setup where you can select input coupling and probe attenuation.

After a Teledyne LeCroy probe is connected, it is recognized by the oscilloscope.

- For passive probes, attenuation is automatically set, and these fields are disabled on the Channel setup dialog.
- For active voltage and current probes, an additional tab with the probe model name is displayed to the right of the C1 tab. Click on the tab to display the probe dialog.

![Channel dialog with tab for connected probe. Shows probe Attenuation and Deskew (if any).](image-url)
This additional tab contains specific information on the connected probe. Default values for the probes coupling and attenuation are automatically downloaded from the probe, and these settings along with other attributes are shown on the dialog.

![Probe dialog showing the connected probe’s control attributes. Other options will be available depending on the type of probe/signal input device.](image)

When using third-party probes, the Probe Attenuation and Deskew values may be entered manually on the Channel setup dialog.

**Deskew Channels**

The signal input channels are deskewed at the factory prior to shipment and should not require any further action.

Follow this generic deskew procedure to compensate for propagation delays due to different lengths of cables, probes, or anything else that might cause timing mismatches between signals.

1. Connect all probes to the desired channels, then probe a common signal with each probe.
2. Turn on two channels, one of which will be the reference channel for the entire deskew procedure.
3. Set an Edge trigger on the reference channel.
4. Switch to Display > Single Grid so both traces appear on the same grid.
5. Turn the Front Panel Horizontal knob to adjust Time/div so that you can clearly see the edges of each trace.
6. Touch the channel descriptor box for the second channel twice to open the setup dialog.
7. Touch the Deskew field to activate it.
8. Turn the Front Panel Adjust knob until the trace aligns with the reference waveform.
9. Repeat Steps 2 through 8 for each input, using the same channel as the reference and same trigger each time.
Timebase

Timebase, also known as Horizontal, settings control the trace along the X axis. These settings are shared by all channel traces.

The time represented by each horizontal division of the grid, or Time/Division, is most easily adjusted using the Front Panel Horizontal knob. Full timebase set up, including sampling mode and clock source selection, is done on the Timebase dialog, which can be accessed by either:

- Choosing Timebase → Horizontal Setup... from the menu bar.
- Touching the Timebase descriptor box.

The main Timebase dialog contains settings for Sampling Mode, Timebase Mode, and Real Time Memory. Related tabs open dialogs to set up Sequence Mode and Clock Source.

Timebase Settings

**Sampling Mode**

**Real Time Mode** - A series of digitized voltage values sampled on the input signal at a uniform rate. See [Real Time Sampling Mode](#).

**Sequence Sampling Mode** - Samples upon many trigger events stored as segments into the oscilloscope’s memory. See [Sequence Sampling Mode](#). If you choose this sampling mode, also complete the Sequence tab settings.

**Roll Mode** - Displays data points as they are acquired, rather than waiting for an entire acquisition to be complete. The waveform appears to build across the grid from right to left and is continuously updated as new data is acquired. This mode can be invoked for slow acquisitions where the time per division is 100 ms/div or slower. Roll mode samples at ≤ 2.5 MS/s by default and faster depending on memory selection. See [Roll Sampling Mode](#).

**RIS Mode** - Random Interleaved Sampling is an acquisition technique that allows effective sampling rates higher than the maximum single-shot sampling rate. It is used on repetitive waveforms with a stable trigger.

**Timebase Mode**

**Time/Division** - the time represented by one horizontal division of the grid. Touch the Up/Down Arrow buttons on the Timebase dialog or turn the Front Panel Horizontal knob to adjust this value.

**Delay** - The time relative to the trigger event to display on the grid. In Real Time sampling mode, the trigger event is placed at time zero on the grid. Delay may be time pre-trigger, entered as a negative value, or post-trigger, entered as a positive value. Raising/lowering the Delay value has the effect of shifting the trace to the right/left, enabling you to focus on the relevant portion of longer acquisitions.

**Set to Zero** - returns Delay to zero.
Real Time Memory
These controls set how the oscilloscope samples when in Real Time mode.

Sampling Rate - the number of samples taken per time division when using a Fixed Sampling Rate. It changes to Max. Sampling Points, the number of samples taken per acquisition, if you choose to Set Maximum Memory.

Set Maximum Memory - automatically adjusts the sampling rate to take the maximum number of samples possible given the amount of pre- or post-trigger delay and the Time/div, up to the oscilloscope's maximum record length. This is a quick way to optimize the sample rate for fast timebases when in Real Time mode.

Fixed Sampling Rate - activates the Sampling Rate field for you to set your own rate. Lowering the rate can extend the acquisition to accommodate slower timebases or longer delays.

Sampling Modes

Real Time Sampling Mode
Real Time sampling mode is a series of digitized voltage values sampled on the input signal at a uniform rate. These samples are displayed as a series of measured data values associated with a single trigger event. By default, the waveform is horizontally positioned so that the trigger event is time zero on the grid.

The relationship between sample rate, memory, and time can be expressed as:

\[
\text{Capture Interval} = \frac{1}{\text{Sample Rate}} \times \text{Memory}
\]

\[
\frac{\text{Capture Interval}}{10} = \text{Time Per Division}
\]

In Real Time sampling mode, the acquisition can be displayed for a specific period of time (or number of samples) either before or after the trigger event occurs, known as trigger delay. This allows you to isolate and display a time/event of interest that occurs before or after the trigger event.

- **Pre-trigger delay** displays the time prior to the trigger event. This can be set from a time well before the trigger event to the moment the event occurs, up to the oscilloscope's maximum sample record length. How much actual time this represents depends on your timebase setting. When set to the maximum allowed pre-trigger delay, the trigger position (and zero point) is off the grid (indicated by the trigger delay arrow at the lower right corner), and everything you see represents pre-trigger time.

- **Post-trigger delay** displays time following the trigger event. Post-trigger delay can cover a much greater lapse of time than pre-trigger delay, up to the equivalent of 10,000 time divisions after the trigger event occurred. When set to the maximum allowed post-trigger delay, the trigger point may actually be off the grid far to the left of the time displayed.

Usually, on fast timebase settings, the maximum sample rate is used when in Real Time mode. For slower timebase settings, the sample rate is decreased so that the maximum number of data samples is maintained over time.

Roll Mode
Roll mode displays, in real time, incoming points in single-shot acquisitions that have a sufficiently low data rate. The oscilloscope rolls the incoming data continuously across the screen until a trigger event is detected and the acquisition is complete. The parameters or math functions connected to each channel
are updated every time the roll mode buffer is updated, as if new data is available. This resets statistics on every step of Roll mode that is valid because of new data.

**NOTE:** If the processing time is greater than the acquire time, the data in memory is overwritten. In this case, the instrument issues a **Channel data is not continuous in ROLL mode!!!** warning and rolling starts over again.

**RIS Sampling Mode**

RIS (Random Interleaved Sampling) is an acquisition technique that allows effective sampling rates higher than the maximum single-shot sampling rate. It is used on repetitive waveforms with a stable trigger. The maximum effective RIS sampling rate is achieved by making multiple single-shot acquisitions at maximum real-time sample rate. The bins thus acquired are positioned approximately 8 ps (125 GS/s) apart. The process of acquiring these bins and satisfying the time constraint is a random one. The relative time between ADC sampling instants and the event trigger provides the necessary variation.

The instrument requires multiple triggers to complete an acquisition. The number depends on the sample rate: the higher the sample rate, the more triggers are required. It then interleaves these segments (in the following graphic) to provide a waveform covering a time interval that is a multiple of the maximum single-shot sampling rate. However, the real-time interval over which the instrument collects the waveform data is much longer, and depends on the trigger rate and the amount of interleaving required.

![Interleaving of sample in RIS sampling mode.](image)

**NOTE:** RIS mode is not available when the oscilloscope is operating in fixed sample rate modes.

**Sequence Sampling Mode**

In Sequence Mode, the complete waveform consists of a number of fixed-size segments (see the instrument specifications at teledynelcroxy.com for the limits). The oscilloscope uses the sequence timebase setting to determine the capture duration of each segment as 10 x time/div. With this setting, the oscilloscope uses the desired number of segments, maximum segment length, and total available memory to determine the actual number of samples or segments, and time or points.

Sequence Mode is ideal when capturing many fast pulses in quick succession or when capturing few events separated by long time periods. The instrument can capture complicated sequences of events over large time intervals in fine detail, while ignoring the uninteresting periods between the events. You can also make time measurements between events on selected segments using the full precision of the acquisition timebase.
Sequence mode offers a number of unique capabilities:

- Acquire up to four channels simultaneously
- Minimize dead time between trigger events for consecutive segments
- View time stamps for acquisitions
- Zoom individual segments or use them as inputs to math functions
- Combine Sequence Mode with an advanced trigger to isolate a rare event, capture all instances over hours or days, and view/analyze each afterwards
- Use Sequence Mode in remote operation to take full advantage of the instrument’s high data-transfer capability

![Capturing segments in Sequence sampling mode.](image)

**SEQUENCE DISPLAY MODES**
The instrument gives you a choice of five ways to display your segments:

- **Adjacent**

![Adjacent display](image)

- **Waterfall (cascaded)**

![Waterfall display](image)

- **Mosaic (tiled)**

![Mosaic display](image)
NOTE: some display modes have limitations on the number of segments that can be shown at one time.

SET UP SEQUENCE MODE
When setting up Sequence Mode, you define the number of fixed-size segments acquired in single-shot mode (see the instrument specifications for the limits). The oscilloscope uses the sequence timebase setting to determine the capture duration of each segment. Along with this setting, the oscilloscope uses the number of segments, maximum segment length, and total available memory to determine the actual number of samples or segments, and time or points.

1. From the menu bar, choose Timebase → Horizontal Setup....
2. Choose Sequence Sampling Mode.
3. On the Sequence tab under Acquisition Settings, touch Number of Segments and enter a value.
   NOTE: The number of segments displayed can be less than the total number of segments acquired.
4. To stop acquisition in case no valid trigger event occurs within a certain timeframe:
   - Check the Enable Timeout box.
   - Touch Timeout and provide a timeout value.
   NOTE: While optional, Timeout ensures that the acquisition will complete in a reasonable amount of time and control of the oscilloscope will return to the operator/controller without having to manually stop the acquisition.
5. Under Display Settings, touch Display mode and select a sequence display mode from the pop-up menu.
6. Touch the one of the Front Panel Trigger buttons to begin acquisition.
   NOTE: Once acquisition has started, you can interrupt it at any time by pressing the Stop Front Panel button. In this case, the segments already acquired will be retained in memory.
**VIEW SEGMENTS IN SEQUENCE MODE**

When in Segment Mode, you can view individual segments easily using the Zoom dialog. The Zoom trace defaults to Segment 1. You can move to later segments by changing the values in First segment to display and Num(ber) of segments to display at once.

**Tip:** By activating the Num field and changing the value to 1, you can use the Front Panel Adjust knob to scroll through each segment in order.

Channel descriptor boxes indicate the total number of segments acquired. Zoom descriptor boxes show the number of first segment displayed and total number of segments displayed ([#] #). As with all other Zoom traces, the zoomed segments are highlighted on the source trace.

**Example:** You may have acquired 1000 segments. You chose to display segments number 4-6. The Channel descriptor box will read 1000. The Zoom descriptor box will read [4]3.

Use the Zoom controls to change the scale factors of the trace.

**VIEW SEGMENT AS MATH FUNCTION**

Besides using the Zoom feature, you can also create a Math (Fx) trace to display individual segments.

1. From the menu bar, choose Math → Math Setup...
2. Touch a Function (Fx) tab to display its corresponding dialog.
3. On the dialog, touch Operator1 and select the Segment button from the pop-up menu.
4. Touch the Select right-hand dialog tab.
5. Touch First Selected and choose the first segment to display.
6. Touch Number of Selected and enter the number of segments to display at once.

**VIEW SEGMENT TIME STAMPS**

To view time stamps for each segment:

1. From the menu bar, choose Timebase → Acquisition Status or Vertical → Channel Status.
2. Touch the Trigger Time tab.
3. Under Show Status For, choose Time.
4. In Select Segment, enter the segment number of interest.

   You can also touch the Up/Down Arrow buttons to scroll through segment times.
**Clock Source**

Sample Clock

These settings determine the clock that controls when the oscilloscope's digitizers sample the input waveforms.

The default setting is to use the oscilloscope's **Internal** clock.

To use an external sample clock:

1. Connect the clock source to the **Ext** input on the front of the oscilloscope using a BNC cable.
2. Go to **Timebase > Horizontal Setup** and choose **Real-time Sampling Mode**.
3. On the **Clock Source tab** under **Sample Clock** choose from:
   - 0V -
   - ECL -
   - TTL -
4. Choose an **External Coupling** of 50 Ohms, Ground, or 1 M Ohm.

Reference Clock

These settings control the Timebase reference used to synchronize acquisition across all channels.

The default setting is to use the oscilloscope's **Internal** 10 MHz clock.

To use an external reference clock:

1. Connect the clock source to the **Ref In/Out 10 MHz** input on the back of the oscilloscope using a BNC cable.
2. Go to **Timebase > Horizontal Setup** and choose **Real-Time Sampling Mode**.
3. On the **Clock Source tab** under **Reference Clock** choose **External**.

**External Reference Clock vs. External Sample Clock**

An external reference clock is used to synchronize the oscilloscope's internal timebase to an external frequency source. This allows multiple instruments to lock their timebases to a common source.

An external sampling clock, applied via the Ext input, replaces the oscilloscope's internal timebase as the sampling clock. This means that the external sampling clock controls when the oscilloscope's digitizers sample the input waveforms.

Since the external sampling clock uses the Ext input, an external trigger cannot be used when the external sampling clock is in use.
Triggers

While the oscilloscope is continuously sampling signal when it is turned on, it can only display up to its maximum memory in data samples. Triggers select an exact event/time in the waveform to display on the oscilloscope screen so that memory is not wasted on insignificant periods of the signal.

All trigger types allow for pre-trigger or post-trigger delay, the display time relative to the trigger event (although the trigger itself may not be visible), or let you set the time between sweeps, how often the display is refreshed. Unless modified by a pre- or post-trigger delay, the trigger event occurs at point zero at the center of the grid, and an equal period of time before and after this point is shown to the left and right of it.

HDO6000 trigger capabilities include:

- **Simple Triggers** - activated by basic waveform features such as an edge with a positive or negative slope or width.
- **Pattern Triggers** - trigger the oscilloscope when a pattern condition, from false to true, occurs on selected input channel and external input.
- **SMART Triggers** - sophisticated triggers that enable you to use basic or complex conditions for triggering. Use SMART Triggers for signals with rare features, like glitches, dropouts, runts, signals leaving a window region, or specific slew rates.
- **Measurement Trigger** - triggers that allow you to leverage parameter measurements as waveform trigger conditions. A measurement trigger is either the only trigger or the final trigger in a chain of trigger events including hardware triggers.
- **MultiStage Triggers** - varied forms of triggers including Cascaded, QualFirst, and Qualified allowing varied combinations of triggers and trigger stages.
- **Serial Triggers** - provide triggers specific to a wide variety of serial data protocols.
- **TV Triggers** - provide the ability to trigger on multiple types of video signal.

In addition to the type, the trigger mode determines how the oscilloscope behaves in the presence or absence of a trigger event.

Trigger Modes

The trigger mode determines how the oscilloscope sweeps, or refreshes, the display. This can be set from the Trigger menu, or from the Front Panel Trigger control group.

**Auto** mode causes the oscilloscope to sweep without a set trigger. An internal timer triggers the sweep after a preset timeout period so that the display refreshes continuously. Otherwise, Auto functions the same as Normal when a trigger condition is found.

In **Normal** mode, the oscilloscope sweeps only if the input signal reaches the set trigger point. Otherwise it continues to display the last acquired waveform.

In **Single** mode, one sweep occurs each time you choose Trigger > Single or press the Front Panel **Single** button.

**Stop** pauses sweeps until you select one of the other three modes.
Trigger Types

These are the trigger types available for selection. If the trigger is part of a subgroup (e.g., Smart), first choose the subgroup from among the basic types to display all the trigger options.

**Basic Trigger Types**

**Edge** triggers upon a achieving a certain voltage level in the positive or negative slope of the wave.

**Width** triggers upon finding a positive- or negative-going pulse width when measured at the specified voltage level.

**Pattern** triggers on a logical combination of five inputs: CH1, CH2, CH3, CH4, and EXT. You have a choice of four Boolean operators (AND, NAND, OR, NOR) and can stipulate the high or low voltage logic level for each input independently.

**Measurement** triggers when a certain parameter measurement is found. A measurement trigger is either the only trigger or the final trigger in a chain of trigger events including hardware triggers.

**TV** triggers on standard or custom composite video signals. Use it on PAL, SECAM, NTSC, or HDTV systems.

**Smart Subgroup**

**Window** triggers when a signal enters or exits a window defined by voltage thresholds.

**Interval** triggers upon finding a specific interval, the time (period) between two consecutive edges of the same polarity: positive to positive or negative to negative. Use the interval trigger to capture intervals that fall short of, or exceed, a specified range.

**Glitch** triggers upon finding a fixed pulse-width time or time range.

**Dropout** triggers when a signal loss is detected. The trigger is generated at the end of the timeout period following the last trigger source transition. It is used primarily in single-shot applications with a pre-trigger delay.

**Runt** triggers when a pulse crosses a first threshold, but fails to cross a second threshold before re-crossing the first. Other defining conditions for this trigger are the edge (triggers on the slope opposite to that selected) and runt width.

**SlewRate** triggers when the rising or falling edge of a pulse crosses two threshold levels: an upper level and a lower level. The pulse edge must cross the thresholds faster or slower than a selected period of time.
MultiStage Triggers
A type of MultiStage trigger, Cascaded triggers when a succession of criteria in Stages A-D are met. Each stage can result in different trigger actions, such as arm only, trigger only, or trigger and rearm.

QualFirst arms the oscilloscope on the A event, then triggers on all subsequent B events.

**NOTE:** This button is enabled when using the sequence sampling mode. It is commonly used in sequence mode for disk drive applications with the index pulse defined as the A qualifier signal and the servo gate signal as the B triggering events.

Qualified arms the oscilloscope on the A event, then triggers on the B event. In Normal trigger mode, it automatically resets after the B event. A (arm) can be Edge, Pattern, State, or PatState events; B (trigger) can be Edge or Pattern events.

Only available as a sub-type of Qualified triggers, PatState triggers when the qualifying signal goes above or below a specified voltage level. You can specify the number of these events that must occur to trigger.

Serial Triggers
Protocol-enabled serial triggers are available as options on some oscilloscope models. This trigger type will be available only if you have such an option installed.

Trigger Settings
To access the Trigger setup dialogs:

Choose **Trigger > Trigger Setup** from the menu bar.

**OR**

Press the **Front Panel Trigger Setup** button.

The dialogs you see and the options on them will vary depending on your trigger type selection. The main Trigger dialog contains settings that are required for most trigger types.

**Type** - see [Trigger Types](#) for details. This selection drives the remainder of the trigger setup. The default selection is Edge.

**Source** - the channel signal upon which to base the trigger. If a trigger is designed to work with multiple inputs, like a Pattern trigger, you do not have to choose a single source, but will be given controls for setting the conditions on each source.
**HDO6000 High Definition Oscilloscope**

**Coupling** - the type of signal coupling at the input. Choices are:

- **DC** - All the signal's frequency components are coupled to the trigger circuit for high frequency bursts or where the use of AC coupling would shift the effective trigger level.
- **AC** - The signal is capacitively coupled. DC levels are rejected, and frequencies below 50 Hz are attenuated.
- **LFREJ** - The signal is coupled through a capacitive high-pass filter network, DC is rejected and signal frequencies below 50 kHz are attenuated. For stable triggering on medium to high frequency signals.
- **HFREJ** - Signals are DC coupled to the trigger circuit, and a low-pass filter network attenuates frequencies above 50 kHz (used for triggering on low frequencies).

**Level** - the source Voltage level or levels that mark the threshold for the trigger to fire. Trigger levels specified in Volts normally remain unchanged when the vertical gain or offset is modified.

**Find Level** - where available, this button sets the Level to the signal mean.

The trigger setup is summarized in a preview window at the far right of the Trigger dialog.

**Trigger Holdoff**

Holdoff is an additional condition that may be set for Edge and Pattern triggers. It can be expressed either as a period of time or an event count. Holdoff disables the trigger temporarily, even if the trigger conditions are met, until the holdoff conditions are also met. The trigger fires when the holdoff has elapsed.

Use holdoff to obtain a stable trigger for repetitive, composite waveforms. For example, if the number or duration of sub-signals is known, you can disable them by choosing an appropriate holdoff value. Qualified triggers operate using conditions similar to holdoff.

**Hold Off by Time**

This is a period of time to wait to fire the trigger, either since the beginning of the acquisition or since the trigger conditions were met.

Sometimes you can achieve a stable display of complex, repetitive waveforms by placing a holdoff condition on the time between each successive Edge trigger event. This time would otherwise be limited only by the input signal, the coupling, and the instrument's bandwidth. Select a positive or negative slope, and a minimum time between triggers.

In the figure below, the bold edges on the trigger source indicate that a positive slope has been selected. The broken upward-pointing arrows indicate potential triggers, which would occur if other conditions are met. The bold arrows indicate where the triggers actually occur when the holdoff time has been exceeded.
**Edge trigger with holdoff by time.**

**Hold Off by Events**

For purposes of Hold Off, Events refers to the number of times the trigger conditions have been met, counted either from the beginning of the acquisition or since the last trigger. For example, if the hold-off number of Events is 2 counted from the beginning of the acquisition, the trigger fires on the third event.

In the figure below, the bold edges on the trigger source indicate that a positive slope has been selected. The broken, upward-pointing arrows indicate potential triggers, while the bold ones show where triggers actually occur after the holdoff expires.

**Edge trigger with holdoff by events.**
Holdoff Settings
To access the Trigger Holdoff dialog, choose Triggers > Trigger Setup from the menu bar or press the Front Panel Trigger Setup button, then touch the Holdoff tab.

Holdoff by - type of holdoff to use with trigger: None, Time (clock), or Event.

Time - if using Holdoff by Time, the time in s to wait before triggering.

Events - if using Holdoff by Events, the number of events to count before triggering.

Starts Holdoff Counter On - whether to count holdoff time/events from Acquisition Start or Last Trigger Time before triggering again.

Software Assisted Trigger
Software Assisted Trigger is used to find the trigger-level crossing point closest to the hardware trigger point. It then adjusts the time offset of the waveform so that it is aligned with the specified trigger level and slope. Software Assisted Trigger provides a quick way to create eye diagrams.

NOTE: This feature can only be used with an Edge trigger type in Normal trigger mode.

1. From the menu, choose Triggers > Trigger Setup, then touch the Software Assisted Trigger tab.

2. Touch Enable.

3. Create a trigger window by entering a Hysteresis value. This value sets a boundary above and below the main trigger level to exclude noise.

4. Choose Auto or Normal; this determine the trigger behavior when trigger crossings are not found in the trigger source waveform.
   - Auto mode allows all waveforms through the channel.
   - Normal mode allows waveforms only with a trigger crossing within the horizontal gate region through the channel.

5. Set Start and Stop time values on the Horizontal Gate part of the Software Assisted Trigger tab. These values control where in the waveform the software-assisted trigger processing searches for trigger crossings.
TriggerScan

TriggerScan is a debugging tool (available for any trigger type) that helps you quickly find rare waveform glitches and anomalies. With TriggerScan, you build a list of triggers and automatically fire them in sequence. TriggerScan can use any type of trigger setup available including Smart Triggers (such as, glitch and runt triggers). TriggerScan automates two key processes in triggering rare events:

- **Trains** the system by looking at normal acquired waveforms. During the training, the oscilloscope analyzes the waveforms to determine what waveforms normally look like. Using this information, it generates a list of smart trigger setups to trigger on abnormal situations.

- **Loads** the smart trigger setups from the Trainer and cycles through them. As trigger events occur, they are recorded on the screen. All acquisition settings are preserved and you can use all the functions of the oscilloscope to find the root cause of these anomalies including, WaveScan, Histograms, and advanced analysis.

### Training TriggerScan

The TriggerScan Trainer inspects the current acquisition and automatically builds a list of trigger setups that could potentially be used to find events of interest.

**NOTE:** Run the Trainer if you want to change the trigger types or if you change the channel or signal. You must acquire and display at least 3 cycles of a signal before running the Trainer.

1. Touch **Trigger → Trigger Setup...** from the menu bar, then touch the **TriggerScan** tab.
2. Touch the **Trainer** button.
3. Choose the **Source** channel on which to train, and select all the **trigger types** you want to set up.
4. Touch the **Start Training** button.

The training begins. When it is complete, a list of smart trigger setups is displayed in the Trigger List.

### Modify Trigger List

The Trigger List displays a list of the triggers created by the Trainer. Follow these steps to add or remove triggers, or update their individual setups. Once you have made any changes to the Trigger List, you are ready to start scanning.

1. Choose **Trigger → Trigger Setup...** from the menu bar, then touch the **TriggerScan** tab.
2. Make any of the following modifications to the Trigger List:

   - To add a new trigger setup to the list, touch the **Trigger** tab and set up the new trigger as desired on the **Trigger** dialog. Then, back on the **TriggerScan** dialog, touch the **Add New** button to append the new trigger to the **Trigger List**.
   
   - To replace a Trigger List setup with the setup on the Trigger dialog, highlight the setup in the **Trigger List setup**, highlight the setup in the **Trigger List** and touch the **Update Selected** button.
   
   - To use a trigger from the Trigger List, highlight its corresponding row on the list, and then touch the **Load Selected** button.
To delete a trigger setup, highlight the setup in the Trigger List and touch the **Delete Selected** button.

All trigger setups can be deleted regardless of selections on the Trigger List with one step by touching the **Delete All** button.

3. Once you have made the desired changes to the Trigger List, touch the **Trainer button** and restart the scan by touching the **Start Training** button on the Trigger Scan Trainer pop-up.

The oscilloscope automatically fires the triggers in sequence.

**NOTE:**

You can tune the dwell time that the oscilloscope waits before loading the next trigger setup using the **Dwell Time** data entry control.

If you have Persistence display mode enabled, all trigger events (within the specified time/number of sweeps) are recorded on the display.

If you want TriggerScan to stop when the oscilloscope next triggers, check the **Stop On Trigger** checkbox. You can use this to isolate specific trigger setups.

---

**Saving TriggerScan Setups**

You should save TriggerScan setups once you have made any modifications to the Trigger List. The current Trigger List is not be preserved after exiting the application unless you save it.

1. On the **TriggerScan** dialog, touch inside the **Setup File Name** data entry control and providing a file name using your preferred input control method.

   **OR**

   Touch the **Browse** button and select a location and file name.

2. Touch the **Save Setup...** button.

   **TIP:** You can load previously saved TriggerScan setups by touching the **Browse** button, locating the file, and then touching **Load Setup...**
Display

Display Setup
This procedure explains how to adjust how traces appear on the touch screen display.

1. From the menu bar, choose Display → Display Setup.
2. Touch the Grid button, then select one of the grid types (the arrangement on the icon shows what will result).
3. Touch Grid Intensity and provide a value from 0 to 100. This dims or brightens the background grid lines.
4. Optionally, check Grid on top if you want to superimpose the grid over the waveform.
   NOTE: Depending on the grid intensity, some of your waveforms may be hidden from view when the grid is placed on top. To undo, simply uncheck Grid on top.
5. Optionally, check Axis labels to display the values of the top and bottom grid lines (calculated from volts/div) and the extreme left and right grid lines (calculated from the timebase).
6. Choose a line style for your traces, solid Line or series of sample Points.
7. Touch Intensity and enter a value from 0 to 100. For more information, see Adjust and Intensity.
8. If you selected to display an XY grid, select the source channels to Input X and Input Y.
9. If you have an external monitor installed, touch Open Monitor Control Panel and set up the external display.

Moving Traces from Grid to Grid
You can move traces from grid to grid in several ways.

Next Grid Shortcut Button
Open the Channel setup dialog for the trace you want to move, then touch the Next Grid shortcut button at the bottom of the dialog.

NOTE: If you have only one grid open, a second grid opens automatically when you select Next Grid.

Drag-and-Drop Descriptor Box
You can also move a trace from one grid to another by dragging its descriptor box to the desired grid. This is a convenient way to quickly re-arrange traces on the display.
XY Displays
XY displays plot the phase shift between otherwise identical signals. They can be used to display either voltage or frequency on both axes, each axis now corresponding to a different signal input, rather than a different parameter. The shape of the resulting pattern reveals information about phase difference and frequency ratio.

The sources must have the same X-axis scale.

1. Set up the desired source traces.
2. Go to Display > Display Setup and choose:
   - XY to display only the XY plot.
   - XYSingle to display the XY plot next to a single grid containing both source traces.
   - XYDual to display the XY plot next to two grids, each containing one of the source traces.
3. Touch Input X and Input Y and select your sources from the pop-up menu.

   NOTE: The inputs can be any combination of channels, math functions, or memories.

Persistence
The Persistence feature displays waveforms in a manner that helps reveal idiosyncrasies or anomalies in a repetitive signal. Use Persistence to accumulate on-screen points from many acquisitions to see how the signal has changed over time. The instrument persistence modes show the most frequent signal path in three-dimensional intensities of the same color, or graded in a spectrum of colors.

You can show persistence for up to eight inputs for any channel, math function, or memory location (M1 to M4).

Persistence Modes
The Persistence display is generated by repeated sampling of the amplitudes of events over time, and the accumulation of the sampled data into persistence maps. These maps create an analog-style display. Statistical integrity is preserved because the duration (decay) is proportional to the persistence population for each amplitude or time combination in the data.

ANALOG MODE
When you select Analog mode, each trace is assigned a different color.

As a persistence data map develops, different intensities of that color are assigned to the range between a minimum and a maximum population. The maximum population automatically gets the highest intensity, the minimum population gets the lowest intensity, and intermediate populations get intensities in between these extremes.

The information in the lower populations (for example, down at the noise level) could be of greater interest to you than the rest. The Analog persistence view highlights the distribution of data so that you can examine it in detail.

COLOR MODE
Color mode persistence works on the same principle as Analog persistence, but instead uses the entire color spectrum to map signal intensity: violet for minimum population, red for maximum population. In this mode, all traces use all colors, which is helpful for comparing amplitudes by seeking like colors among the traces.
3D MODE
3d persistence creates a topographical view of your waveform from a selection of shadings, textures, and hues.

The advantage of the topographical view is that areas of highest and lowest intensity are shown as peaks and valleys, in addition to color or brightness. The shape of the peaks (pointed or flat) can reveal further information about the frequency of occurrences in your waveform.

In this mode, you can also turn the X and Y axes of the waveform through 180° of rotation from -90° to +90°.

Here is an example of a 3-dimensional view of a square wave using the solid view of color-graded persistence. Saturation is set at 50%, with red areas indicating highest intensity. The X-axis has been rotated 60%; the Y-axis has been rotated 15%.

Here is a monochrome (analog) view of the same waveform. The lightest areas indicate highest intensity, corresponding to the red areas in the solid view.

Here is a shaded (projected light) view of the same waveform. This view emphasizes the shape of the pulses.

Here is a wire frame view of the same waveform in which lines of equal intensity are used to construct the persistence map.

Saturation Level
Besides the different modes, you can select a saturation level as a percentage of the maximum population. All populations above the saturation population are then assigned the highest color intensity: that is, they are saturated. At the same time, all populations below the saturation level are assigned the remaining intensities. Data populations are dynamically updated as data from new acquisitions is accumulated.

A saturation level of 100% spreads the intensity variation across the entire distribution; at lower saturation levels the intensity will saturate (become brighter) at the percentage value specified. Lowering this percentage causes the pixels to be saturated at a lower population and makes visible those events rarely seen at higher saturation levels.

Persistence Time
Persistence time is, quite simply, the duration of time (in seconds) after which persistence data is erased from the display.
**Persistence Setup**
This procedure explains how to set up the persistence display on traces. Persistence can be quickly added to all traces or applied individually.

**TURN ON PERSISTENCE**

1. Access the Persistence dialog by choosing **Display → Persistence Setup**...and touching the **Persistence tab**.
2. Check **Persistence On**.
3. To set up all traces together, touch **All Locked**.
   To set up traces individually, touch **Per Trace**.
4. Select the persistence mode: **None**, **Color**, **Analog**, or **3d**
   If you're doing individual setup, repeat the mode selection for each channel, then go to that channel's tab and make the remaining settings.
5. If using Analog or Color mode, optionally check **Show last trace** to superimpose the channel trace over the persistence display.
   If using 3d mode, complete **setup for 3-D persistence**.
6. Optionally, also change **Saturation** level and **Persistence Time**, and enable/disable **Dot Joined**.

**SET UP 3-D PERSISTENCE**

1. Touch the **3d** button and, if necessary, open the channel tab.
2. Under **3D settings**, touch **Quality** and choose **wire frame**, **solid**, or **shaded**.
3. Check **MonoChrome** if you prefer a single-color representation. In this case, intensity will be used instead of color to indicate more frequently occurring events.
4. Optionally, change the angle of display by entering new **Axis X Rotation** and **Axis Y Rotation** values from -90° to +90°.
   **TIP:** A quick way to rotate the display is to grab a corner and drag it in the desired direction.

**TURN OFF PERSISTENCE**
To turn off the persistence display, access the Persistence dialog and choose **Reset All**, or select an individual channel's **None** (left-most) persistence mode button.

**Screen Saver**
The screen saver is activated the same as on any Windows PC. Minimize the instrument display by choosing **File → Minimize** from the menu bar. Then, open the Windows Control Panel and change Appearance and Personalization settings.

Touch the oscilloscope icon at the bottom right of the desktop to restore the instrument display.
Cursors

Cursors are markers—lines, cross-hairs, or arrows—that identify specific voltage and time values on the waveform. Use cursors to make fast, accurate measurements of specific points in the waveform.

**Horizontal (Time)** cursors place vertical lines through a desired point along the horizontal axis to read the signal's amplitude at the selected time. Two related types of cursor are:

- **Horizontal (Frequency)** cursors, the same as Horizontal (Time) cursors except that they are placed on waveforms that have frequency on the x-axis, such as FFTs.
- **Horizontal (Event)** cursors, which are placed on Trend waveforms.

**Vertical (Amplitude)** cursors place horizontal lines through a point on the vertical axis to read the amplitude of the signal at that point.

An option exists to place Horizontal (Time) and Vertical (Amplitude) types at once.

The cursor measurement values can be read on the descriptor box for the trace. The Show buttons let you change which set of values are shown on the descriptor: Absolute, Delta, Abs+Delta, or Slope values. The available selections depend on the type of cursor.

The easiest way to position cursors is to touch and drag them to the desired locations. Use the Position data entry controls at the right side of the Standard Cursors dialog to place the cursors precisely.

Cursors can be placed on a math function whose X-axis has a dimension other than time, such as an FFT. When there is at least one math trace open, the Standard Cursors dialog contains an X-Axis control where you can choose the units measured by the horizontal cursors. The options will be appropriate to the types of function traces open; for example, if there is an FFT trace, there is an option for Hz. The cursor lines are placed on the traces that normally display X-axis values in the selected units.

**Cursor Settings**

**Display Cursors**

Use either of the following methods to quickly turn on/off cursors:

- On the display, touch **Cursors** then select the desired cursor type button.
- On the Front Panel, press the **Cursor Type** button repeatedly to scroll through all the cursor types. Stop when the desired type is displayed

**Position Cursors**

With the cursor on, turn the Front Panel **Cursors** knob. If there is more than one cursor line, push the Cursor knob until the correct one is selected, then turn the knob to move it.

**OR**

Touch and drag the cursor line to a new position.
**Standard Cursors Dialog**

These controls can be used in lieu of the Front Panel controls to set cursors. Access the dialog by choosing **Cursors > Cursors Setup**.

**Cursors On** displays or hide cursor lines. When first checked, the last selected cursor type is displayed.

**Cursor Type** buttons determine the type of cursor displayed on the grid.

- **Horizontal Abs** - displays a single, dashed, vertical line. The readout shows the absolute value at the cursor location.
- **Horizontal Rel** - displays two, dashed, vertical lines. The readout depends on the Show option selected.
- **Vertical Abs** - displays a single dashed, horizontal line. The readout shows the absolute value at the cursor location.
- **Vertical Rel** - displays two dashed, horizontal lines. The readout depends on the Show option selected.
- **Both Rel** - displays both Horizontal and Vertical Relative cursor lines.

The **Show** controls determine which values appear on the trace descriptor box readout, particularly when using relative cursors:

- **Absolute** - shows *specific voltages* for the two cursor locations.
- **Delta** - shows the *difference between the specific voltages* at the cursor locations.
- **Abs+Delta** - shows both the *specific voltages* and the *difference between the specific voltages* at the cursor locations.
- **Slope** - shows the *slope* of the waveform between the cursor locations.

The **Position** controls at the right-side of the Standard Cursors dialog display the current cursor location and can be used to set a new location. The options available depend on the Cursor Type and Show settings.

- **X 1/2** - positive or negative time from the zero point.
- **Y 1/2** - number of positive or negative divisions from the zero level. May be a fraction of a division.
- **Track** - locks both cursor lines so that they move together, maintaining their same relative distance from each other.
Measurement

Measurement parameters are tools that give you access to a wide range of waveform properties. Use them to analyze many attributes of your waveform like rise-time, rms voltage, and peak-to-peak voltage, for example.

The oscilloscope offers a selection of:

- Standard parameters for measuring amplitude and time
- Custom parameters you configure
- Specialized parameters for applications such as pass/fail testing or serial data decode (if you have those options installed)

You can configure and display up to eight measurement parameters at once. From the menu bar, choose:

- **Measure > Standard Horizontal** for a full set of common time parameters: freq, period, width, rise, fall, delay, duty, num points.
- **Measure > Standard Horizontal** for a full set of common voltage parameters: mean, sdev, max., min., ampl, pkpk, top, base.
- **Measure > My Measure** and check **On** to enable each parameter you want to display. If the parameter you want is not available for selection, follow steps to **Set Up Measurement Parameter**.

Mark the **Show Table** checkbox to display the parameter readout table below the grid.

*Table of measurements open beneath grid. Far left cell opens the Measure dialog.*

To quickly access the Measure Setup dialog if it is closed, touch the far left cell of the readout table labeled Measure.
Measure Gate

By using gates, you can narrow the span of the waveform on which to perform parameter measurements, allowing you to focus on the area of greatest interest. For example, if you "gate" five rising edges of the waveform, the parameter calculations for rise time are performed only on the five pulses bounded by the gate posts.

The default starting positions of the gate posts are 0 div and 10 div, which coincide with the left and right ends of the grid. The gate, therefore, initially encloses the entire waveform. The quickest way to set a gate is by dragging the gate posts located at the far left and right of the grid to the desired positions.

You can refine this setting by specifying a position down to hundredths of a division in the Gate Start and Stop fields on the Gate right-hand dialog.

For Standard Horizontal or Standard Vertical parameters, drag the gate posts to the desired positions or enter a Gate Start and Stop position on the Measure dialog. All parameters share the same gate.

For custom (My Measure) parameters, set gates on individual parameters:

1. Touch Measure > Measure Setup.
2. Touch the Px tab for the parameter you wish to gate.
3. Touch the Gate right-hand dialog tab.
4. Enter the Start division, or simply touch the leftmost gate post and drag it to position.
5. Enter the Stop division, or simply touch the rightmost gate post and drag it to position.

Touch the Default button to return gates to the width of the trace.

Level and Slope

For several time-based measurements, you can choose to begin the measurement on positive, negative, or both slopes. For two-input parameters, such as Dtime@level, you can specify the slope for each input, as well as the level and type (percent or absolute).

Make Level selection on the right-hand Level dialog when it appears.
Statistics
You can add the statistical measures value(last), mean, min., max., sdev, and num(ber of measurements computed) to the measurement parameter readout table.

To turn on statistics, access the Measure dialog and check Statistics On. Clear the checkbox to remove statistics from the readout.

The num statistic is the number of measurements computed. For any parameter that computes on an entire waveform (like amplitude, mean, minimum, maximum, etc.) the value displayed represents the number of sweeps.

For any parameter that computes on every event, the value displayed is equal to the number of events per acquired waveform. If \( x \) waveforms were acquired, the value represents \( x \) times the number of cycles per waveform. The value(last) statistic is equal to the measurement of the last cycle on the last acquisition.

To reset the statistics counter, touch Clear Sweeps.

View Histicon
Histicons are miniature histograms of measurement parameters that appear on the measurement table. These thumbnail histograms let you see at a glance the statistical distribution of each parameter.

1. Choose Measure > Measure Setup from the menu bar to access the Measure dialog.
2. Select Show Table.
3. Check On to enable the parameters you wish to display.

NOTE: You can quickly display a full histogram by touching the histicon you want to enlarge. The enlarged histogram appears superimposed over its source trace.

Help Markers
Help Markers clarify measurements by displaying cursor lines and labels marking the points being measured. For at-level parameters, markers make it easier to see where your waveform intersects the chosen level. This feature also displays any hysteresis band that you have set about that level.

You can choose to use Simple markers, which are only the lines, or Detailed markers, which include the measurement point labels.

NOTE: Unlike regular cursors, which are white and can be moved, help markers are blue and only augment the display; they cannot be moved, and they do not reset the measurement points. Some optional analysis software packages include markers designed specially for that domain of reference, which are documented in the option manual.

You also have the option, by means of the Always On checkbox, to leave the Help Markers displayed over traces after you have closed the Measure dialogs or readout table. If you change the set of parameters displayed, the markers will change, as well.
Turn On Markers

1. From the menu bar, choose Measure > Measure Setup.
2. Select a Measure Mode: Std Vertical, Std Horizontal, or My Measure.
3. Touch the Show All button to display Help Markers for each enabled parameter. The type of markers last selected appear on the display.

   NOTE: If you choose My Measure but have not yet set up or enabled any parameters, you will not see any markers, either.

4. To change the marker type, open any parameter (Px) dialog and in Markers select either:
   - Simple - produces cursors and gate posts. The gate posts are independently placeable for each parameter.
   - Detailed - produces cursors, gate posts, a label identifying the parameter being measured, and a level indicator and hysteresis band for "at level" parameters.

   NOTE: The Markers setting is applied to all parameters at the same time. If you choose Simple markers on any parameter dialog, all parameters are then displayed in this mode.

5. Select the Always On checkbox if you wish to continue to display Help Markers on open traces.

Turn Off Markers

From the Measure setup dialog, choose Help Markers Clear All.

From any Px dialog, choose Markers Off.
Set Up Measurement Parameter

To configure custom measurement parameters to add to the table of parameter readouts:

1. From the menu bar, choose **Measure > Measure Setup**.
2. Choose Measure Mode **My Measure**.
3. Touch the **Pxtab or button** of an unused location (or one that you want to change).

4. Select a **Type**:
   - **Measure On Waveforms** - measures directly on the waveform selected as Source1.
   - **Math On Parameters** - performs math (addition, subtraction, multiplication, division) on the parameters selected as Source1 and Source2. These must be two other custom parameters you have or will configure and saved to those slots.
   - **Advanced Web Edit** - uses Teledyne LeCroy's Processing Web for measurement setup. This feature, available with the XWEB option, allows you to chain practically unlimited math functions for operation on your waveform measurements.

5. Touch **Source1** and select the channel, math trace, memory trace, or other waveform to be measured.
   
   If using Math on Parameters, choose the parameters, rather than the source trace, in Source1 and Source2.

6. If you selected **Measure On Waveforms**, touch the **Measure** field and select the parameter from the pop-up menu.

7. Optionally, make any further selections on the right-hand dialogs that appear after your Measure selection. These are explained on the dialog.

8. Check **On** to enable the parameter and add it to the measurement readout table.

9. Check **Show Table** to display the readout on screen.
Qualified Parameters
Some Teledyne LeCroy software packages give you the ability to constrain parameter measurements to a vertically or horizontally limited range, or to occurrences gated by a second waveform. Furthermore, both constraints can operate together. This capability enables you to exclude unwanted characteristics from your measurements. It is much more restrictive than See "Measure Gate" on page 48 which is used only to narrow the span of analysis along the horizontal axis.

**NOTE:** Since this feature operates on only a subset of the data, possible alerts or status indicators concerning the measurement (such as Data range too low) are not displayed.

**Range Limited Parameters**
1. From the menu bar, choose Measure → Measure Setup....
2. Touch a 
Px tab to open its corresponding dialog.
3. Now, on the dialog, touch inside the Source control and select a source from the pop-up.
4. Touch inside the Measure control and select a parameter from the pop-up menu.
5. Touch the Accept tab of the dialog on the right, then touch the Values In Range checkbox.
   
   **NOTE:** Depending on whether you select a vertical or horizontal parameter, the correct units will be automatically displayed (V, s, Hz, dB) in the Between and And controls. Or, if you select a simple ratio parameter (such as power factor) that yields a dimensionless number, no units will be displayed.

6. Touch the Find Range button to quickly display the most recent value of the parameter measurement.

**Waveform Gated Parameters**
1. From the menu bar, choose Measure → Measure Setup.
2. Touch any 
Px tab to open the setup dialog.
3. Touch Source and select a source from the pop-up menu.
4. Touch Measure and select a parameter from the pop-up menu.
5. Touch the Accept right-hand dialog tab, then check the Values Based on Waveform State box.
6. Touch When Wform and select the gating source.
7. Touch State Is and select High or Low from the pop-up menu. Parameter measurements on the subject waveform will only be taken when the gating waveform is in the selected state.
8. Touch Level Type and select Absolute or Percent from the pop-up menu.
9. Touch Level and enter the crossing level value at which you want measurements to begin.
    
    You can instead touch the Find Level button to automatically select the 50% level of your gating waveform.
Math on Parameters

Besides reading parameter measurements, you can set up a custom parameter that performs arithmetic operations (addition, subtraction, multiplication, division) on two other parameter measurements. Alternatively, you can apply mathematical functions (for example, invert) to a single parameter measurement.

The setup for Math on Parameters is much like other custom parameter setup. The only significant difference is the choice of Math on Parameters instead of Measure on Waveforms and the selection of source parameters instead of source traces. There is added functionality for using custom scripts to calculate the results.

Math on Parameters differs from Math in that the input and the output are still numerical values, as are all parameter measurements. Math functions, on the other hand, input and output waveform traces. Math on Parameters results display in the parameter readout table.

Exclusions

Logarithmic Parameters

The parameter math feature prevents multiplication and division of parameters that return logarithmic values. These parameters include:

- auto-correlation signal-to-noise ratio (ACSN)
- narrow-band power (NBPW)
- media signal-to-noise ratio (MSNR)
- residual signal-to-noise ratio (RSNR)
- top-to-base ratio when the units are in dB (TBR)

Other Excluded Parameters

Parameters that are already the result of parameter math operations are excluded. If they are included in a remote control setup command, an error message is generated and the setup canceled.

- delta clock-to-data near (DC2D)
- delta clock-to-data next (DC2DPOS)
- delta clock-to-data previous (DC2DNEG)
- delta delay (DDLY)
- delta time at level (DTLEV)
- phase (PHASE)
- resolution (RES)
- mTnTmT shift (BEES)
- mTnTmT shift sigma (BEESS)
- mTnTmT shift sigma – list (BEESS)
**Set Up Math on Parameters**

1. Touch **Measure → Measure Setup...** on the menu bar.
2. Choose Measure Mode **My Measure**.
3. Touch output **Px tab or button** to display the parameter setup dialog.
4. Touch the **Math on Parameters** button.
5. Touch **Math Operator** and select a math operation from the **Select Measurement** menu.
   - If you select an operation that requires two input parameters, the **Source1** field will expand to two fields.
6. Touch **Source1** and **Source2** and select two input parameters (P1 to P8) other than the parameter you are now setting up.
   - To apply math to a single parameter (for example, Invert), just select it in **Source1**.
7. Check **On** to enable the new output parameter and add it to the display.

**Using Scripts**

In addition to the arithmetic operations, you can write your own VBScript or JavaScript to apply to one or two measurement parameters. When setting up the output parameter, choose the Math Operator **P Script**.

Scripting can be done in the **Script Editor** window directly on the instrument, or you can import an existing script.

**PARAM SCRIPT VS. P SCRIPT**

Param Script is a VBScript or JavaScript that operates on one or two waveforms and outputs a parameter measurement, as shown in the figure below. P Script, on the other hand, is another VBScript or JavaScript that takes as input one or two parameters and performs a math operation on them to produce another parameter output.

The inputs to Param Script can also be math (Fx) or memory (Mx) traces. The inputs to P Script can be the results of any parameter measurement, not necessarily Param Script.

**SET UP Math ON Parameters USING SCRIPT**

1. Touch **Measure → My Measure...** on the menu bar.
2. Touch the output **Px tab or button** to display the parameter setup dialog.
3. Touch the **Math on Parameters** button.
4. Touch **Source1** and **Source2** and select the input parameters (P1 to P8).
   - If you are applying math to a single parameter (for example, Invert), just select it in **Source1**.
5. Touch **Math Operator** and choose **P Script** from the **Select Measurement** menu.
6. In the right-hand **Script Math** dialog, touch **Script Language** and choose either **VBScript** or **JScript**.
7. Touch the **Edit Code** button.
   - The **Script Editor** window opens.
8. Enter code in the script editor, or call up an existing script from a file storage location.
   - If you create your script in this window, you can export it to a new file.
Calculating Measurements

**Determining Top and Base Lines**
Proper determination of the top and base reference lines is fundamental for ensuring correct parameter calculations. The analysis begins by computing a histogram of the waveform data over the time interval spanned by the left and right measurement gates. For example, the histogram of a waveform transitioning in two states will contain two peaks (see figure). The analysis will attempt to identify the two clusters that contain the largest data density. Then the most probable state (centroids) associated with these two clusters will be computed to determine the top and base reference levels: the top line corresponds to the top and the base line to the bottom centroid.

![Histogram of Waveform](image)

**Determining Rise and Fall Times**
Once top and base are estimated, calculation of the rise and fall times is easily done (see figure). The appropriate threshold levels are automatically determined by the instrument, using the amplitude (ampl) parameter.

Threshold levels for rise or fall time can also be selected using absolute or relative settings (r@level, f@level) if these parameters are included in your oscilloscope. If absolute settings are chosen, the rise or fall time is measured as the time interval separating the two crossing points on a rising or falling edge. But when relative settings are chosen, the vertical interval spanned between the base and top lines is subdivided into a percentile scale (base = 0 %, top = 100 %) to determine the vertical position of the crossing points.

The time interval separating the points on the rising or falling edges is then estimated to yield the rise or fall time. These results are averaged over the number of transition edges that occur within the observation window.
### Determining Time Parameters

Time parameter measurements such as width, period and delay are carried out with respect to the mesial reference level, located halfway (50%) between the top and base reference lines or with respect to the specified level for @level parameters.

Time-parameter estimation depends on the number of cycles included within the observation window. If the number of cycles is not an integer, parameter measurements such as rms or mean will be biased. However, only the last value is actually displayed, the mean being available when statistics are enabled. To avoid these bias effects, cyclic parameters can be chosen, including crms and cmean, that restrict the calculation to an integer number of cycles.
**Determining Differential Time Measurements**

The instrument enables accurate differential time measurements between two traces: for example, propagation, setup and hold delays (see figure).

If included in your oscilloscope, parameters such as Delta c2d± require the transition polarity of the clock and data signals to be specified.

Moreover, a hysteresis range may be specified to ignore any spurious transition that does not exceed the boundaries of the hysteresis interval. In the figure, Delta c2d- (1, 2) measures the time interval separating the rising edge of the clock (trigger) from the first negative transition of the data signal. Similarly, Delta c2d+ (1, 2) measures the time interval between the trigger and the next transition of the data signal.
### List of Standard Parameters

Standard measurement parameters are listed below alphabetically.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Amplitude</strong></td>
<td>Measures the difference between upper and lower levels in two-level signals.</td>
</tr>
<tr>
<td><strong>(ampl)</strong></td>
<td>Differs from pkpk in that noise, overshoot, undershoot, and ringing do not affect the measurement. Amplitude is calculated by using the formula Top – Base. On signals not having two major levels (such as triangle or saw-tooth waves), the amplitude parameter returns the same value as peak-to-peak.</td>
</tr>
<tr>
<td><strong>Area</strong></td>
<td>Integral of data: Computes area of the waveform relative to zero level.</td>
</tr>
<tr>
<td><strong>Base</strong></td>
<td>Lower of two most probable states (higher is top). Measures lower level in two-level signals.</td>
</tr>
<tr>
<td><strong>Cycles</strong></td>
<td>Determines number of cycles of a periodic waveform lying between cursors.</td>
</tr>
<tr>
<td><strong>(cycles)</strong></td>
<td>First cycle begins at first transition after the left cursor. Transition may be positive- or negative-going.</td>
</tr>
<tr>
<td><strong>Delay</strong></td>
<td>Time from trigger to transition: Measures time between trigger and first 50% crossing of signal.</td>
</tr>
<tr>
<td><strong>Delta Delay</strong></td>
<td>Computes time between 50% level of two sources.</td>
</tr>
<tr>
<td><strong>Dperiod@level</strong></td>
<td>Adjacent cycle deviation (cycle-to-cycle jitter) of the period measurement for each cycle in a waveform. The reference level for this measurement can be specified.</td>
</tr>
<tr>
<td><strong>Dtime@level</strong></td>
<td>Computes the time between transitions of the selected sources at the specified levels. Only positive going transitions are counted.</td>
</tr>
<tr>
<td><strong>Dtrig Time</strong></td>
<td>Time from last trigger to this trigger.</td>
</tr>
<tr>
<td><strong>Duration</strong></td>
<td>For single sweep waveforms, dur is 0; for sequence waveforms: time from first to last segment's trigger; for single segments of sequence waveforms: time from previous segment's to current segment's trigger; for waveforms produced by a history function: time from first to last accumulated waveform's trigger.</td>
</tr>
<tr>
<td><strong>Duty Cycle</strong></td>
<td>Percent of period for which data are above or below the 50% level of the signal.</td>
</tr>
<tr>
<td><strong>Duty@level</strong></td>
<td>Percent of period for which data are above or below a specified level.</td>
</tr>
<tr>
<td><strong>Edge@level</strong></td>
<td>Number of positive edges in waveform that cross the specified threshold level.</td>
</tr>
<tr>
<td><strong>Fall 80-20%</strong></td>
<td>Duration of pulse waveform's falling transition from 80% to 20% of the amplitude averaged for all falling transitions between the measurement gates. On signals not having two major levels (triangle or saw-tooth waves, for example), top and base can default to maximum and minimum, giving less predictable results.</td>
</tr>
<tr>
<td><strong>Fall time</strong></td>
<td>Duration of pulse waveform's falling transition from 90% to 10% of the amplitude averaged for all falling transitions between the measurement gates. On signals not having two major levels (triangle or saw-tooth waves, for example), top and base can default to maximum and minimum, giving less predictable results.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Fall@level (fall@lv)</td>
<td>Fall at level: Duration of pulse waveform's falling edges between user-specified transition levels.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Table" /></td>
</tr>
<tr>
<td></td>
<td>Threshold arguments specify two vertical values on each edge used to compute fall time. Formulas for upper and lower values: lower = lower thresh. x amp/100 + base upper = upper thresh. x amp/100 + base</td>
</tr>
<tr>
<td>First</td>
<td>Indicates value of horizontal axis at left cursor.</td>
</tr>
<tr>
<td>Frequency (freq)</td>
<td>Period of cyclic signal measured as time between every other pair of 50% crossings. Starting with first transition after left measurement gate. The period is measured for each transition pair. The reciprocal of each period measurement is calculated as the frequency.</td>
</tr>
<tr>
<td>Freq@level (freq@lv)</td>
<td>Period of cyclic signal measured as time between every other pair at the specified level. Starting with first transition after left measurement gate. The period is measured for each transition pair. The reciprocal of each period measurement is calculated as the frequency.</td>
</tr>
<tr>
<td>FWxx</td>
<td>Measures the width of the largest area histogram peak at xx% of the population of the highest peak.</td>
</tr>
<tr>
<td>Half Period (hper)</td>
<td>Half period of a waveform.</td>
</tr>
<tr>
<td>Hist Ampl (hampl)</td>
<td>Difference in value between the two most populated peaks in a histogram.</td>
</tr>
<tr>
<td>Last</td>
<td>Time from trigger to last (rightmost) cursor.</td>
</tr>
<tr>
<td>Level@X (lvl@x)</td>
<td>Gives the vertical value at the specified x position. If the x position is between two points, it gives the interpolated value. When the <strong>Nearest point</strong> checkbox is checked, it gives the vertical value of the nearest data point.</td>
</tr>
<tr>
<td>MATLAB</td>
<td>Produces a parameter using a user-specified MATLAB function.</td>
</tr>
<tr>
<td>Maximum (max)</td>
<td>Measures highest point in waveform. Unlike top, does not assume waveform has two levels.</td>
</tr>
<tr>
<td>Mean</td>
<td>Average of data for time domain waveform. Computed as centroid of distribution for a histogram of the data values.</td>
</tr>
<tr>
<td>Median</td>
<td>The average of base and top values.</td>
</tr>
<tr>
<td>Minimum (min)</td>
<td>Measures the lowest point in a waveform. Unlike base, does not assume waveform has two levels.</td>
</tr>
<tr>
<td>N-cycle Jitter</td>
<td>Peak-to-peak jitter between edges spaced n UI apart.</td>
</tr>
<tr>
<td>None</td>
<td>Disables parameter calculation</td>
</tr>
<tr>
<td>Num Points (npoints)</td>
<td>Number of points in the waveform between the measurement gates.</td>
</tr>
<tr>
<td>Overshoot-</td>
<td>Amount of overshoot following a falling edge. This is represented as percentage of amplitude. Overshoot- is calculated using the formula (base - min.)/ampl x 100. On signals not having two major levels (triangle or saw-tooth waves, for example), may not give predictable results.</td>
</tr>
<tr>
<td>Overshoot+</td>
<td>Amount of overshoot following a rising edge specified. This is represented as a percentage of amplitude. Overshoot+ is calculated using the formula (max. - top)/ampl x 100. On signals not having two major levels (triangle or saw-tooth waves, for example), may not give predictable results.</td>
</tr>
<tr>
<td>Peaks</td>
<td>Number of peaks in a histogram.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Peak to Peak (pkpk)</td>
<td>Difference between highest and lowest points in waveform. Unlike ampl, does not assume the waveform has two levels. Peak to peak is calculated using the formula $\text{maximum} - \text{minimum}$.</td>
</tr>
<tr>
<td>Percentile (pctl)</td>
<td>Horizontal data value that divides a histogram so the population to the left is xx% of the total.</td>
</tr>
<tr>
<td>Period</td>
<td>The time between every other pair of 50% crossings. Starting with first transition after left measurement gate, period is measured for each transition pair, with values averaged to give final result.</td>
</tr>
<tr>
<td>Period@level (per@lv)</td>
<td>The time between every other pair of at the level specified. Starting with first transition after left measurement gate, period is measured for each transition pair, with values averaged to give final result.</td>
</tr>
<tr>
<td>Phase</td>
<td>Phase difference between signal analyzed and signal used as reference. Both signals are measured from the 50% point of their rising edges.</td>
</tr>
<tr>
<td>Rise</td>
<td>Duration of pulse waveform’s rising transition from 10% to 90% of the amplitude averaged for all rising transitions between the measurement gates. On signals not having two major levels, top and base can default to maximum and minimum, giving less predictable results.</td>
</tr>
<tr>
<td>Rise 20-80% (rise2080)</td>
<td>Duration of pulse waveform’s rising transition from 20% to 80% of the amplitude averaged for all rising transitions between the measurement gates. On signals not having two major levels, top and base can default to maximum and minimum, giving less predictable results.</td>
</tr>
<tr>
<td>Rise@level (rise@lv)</td>
<td>Rise at level: Duration of pulse waveform’s rising edges between user-defined transition levels.</td>
</tr>
<tr>
<td>Threshold arguments</td>
<td>Specify two vertical values on each edge used to compute rise time.</td>
</tr>
<tr>
<td>RMS</td>
<td>Root Mean Square of data between the measure gates, calculated as: $\sqrt{\frac{1}{N} \sum_{i=1}^{N} (v_i)^2}$</td>
</tr>
<tr>
<td>Setup</td>
<td>Time from the data edge to the clock edge.</td>
</tr>
<tr>
<td>Skew</td>
<td>Time of clock1 edge minus time of nearest clock2 edge. Both signals are measured from the 50% point of their rising edges.</td>
</tr>
<tr>
<td>Slew Rate (slew)</td>
<td>Slew rate or local dV/dt in a transition zone</td>
</tr>
<tr>
<td>Std Dev (sdev)</td>
<td>Standard deviation of the data between the measure gates using the formula: $\sqrt{\frac{1}{N} \sum_{i=1}^{N} (v_i - \text{mean})^2}$</td>
</tr>
</tbody>
</table>

Where: $v_i$ denotes measured sample values, and $N =$ number of data points within the periods found up to maximum of 100 periods. This is equivalent to the rms for a zero-mean waveform. Also referred to as AC RMS.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TIE@level</td>
<td>Difference between the measured times of crossing a given slope and level and the ideal expected time. For Slope you can choose positive, negative, or both. For output units you can choose time or unit interval (UI). A unit interval equals one clock period. The Virtual Clock setup gives you a choice of Standard (1.544 MHz) or Custom reference clocks. You can also use a mathematically derived Golden PLL to filter low frequency jitter. The cutoff frequency is user selectable.</td>
</tr>
<tr>
<td>Time@level</td>
<td>Time from trigger (t=0) to crossing at a specified level.</td>
</tr>
<tr>
<td>Top</td>
<td>Higher of two most probable states (base is lower). Measures higher level in two-level signals. Differs from max in that noise, overshoot, undershoot, and ringing do not affect measurement. On signals not having two major levels (such as triangle or saw-tooth waves), the amplitude parameter returns the same value as minimum.</td>
</tr>
<tr>
<td>Total Pop</td>
<td>Total population of a histogram.</td>
</tr>
<tr>
<td>Width</td>
<td>Width of cyclic signal determined by examining 50% crossings in data input. If first transition after left cursor is a rising edge, waveform is considered to consist of positive pulses and width the time between adjacent rising and falling edges. Conversely, if falling edge, pulses are considered negative and width the time between adjacent falling and rising edges. For both cases, widths of all waveform pulses are averaged for the final result.</td>
</tr>
<tr>
<td>Width@level</td>
<td>Width measured at a user-specified level.</td>
</tr>
<tr>
<td>WidthN</td>
<td>Time of cyclic signal determined by examining 50% crossings in data input. The widthN is measured from falling edge to rising edge.</td>
</tr>
<tr>
<td>X@max</td>
<td>Determines the horizontal axis location of the maximum value between the measure gate.</td>
</tr>
<tr>
<td>X@min</td>
<td>Determines the horizontal axis location of the minimum value between the measure gate.</td>
</tr>
</tbody>
</table>
Math

Teledyne LeCroy offers a deep and always growing toolset of math functions.

Math functions can be applied to any channel (Cx), zoom (Zx), memory (Mx), measurement parameter (Px), or even other math traces (Fx), allowing you to chain operations. For example, trace F2 can show the average of C1, while trace F3 provides the integral of F2.

In addition to the extensive math capabilities that are standard with every oscilloscope, enhanced math analysis tools customized for various industries and applications are offered through optional software packages. To learn about math tools available in each optional package, see the datasheets on the Teledyne LeCroy website at teledynelecroy.com. If you have installed software options, these capabilities are accessed through the oscilloscope Analysis menu, rather than the Math menu, although special measure parameters and math functions will be available when using Measure and Math dialogs.

**Single vs. Dual Operation Functions**

Single functions perform one operation on one or two input sources.

Dual functions chain two operations to arrive at a single result. This saves you the effort of having to chain two separate math functions together.

As with single functions, the number of sources required will vary based on the operation. You may need only one source for Operator1, but two for Operator2 (the result of the first operation counts as one source):

**Graphing**

The **Graph button** on the Math Function (Fx) dialogs allows you to create math functions that plot the results of an applied measurement parameter: histogram, track, or trend. Choose the source, the measurement parameter, and the type of plot to draw. The plots are the same as those you would create using the shortcut buttons on the Measure Parameter (Px) dialog. See [About Histograms](#) and [Track vs. Trend](#).

As with other math functions, any configurable settings will appear on right-hand dialogs, after the plot type is selected.
Set Up Math Function
This procedure explains how to set up single or dual operator math function (Fx) traces. Function traces take as input one or more channel, zoom, memory or math traces and output a new math trace.

For more information about creating math traces that plot the results of applied measurements, see View Trend, View Track, and View Histogram.

Also see Set Up Function Using Web Edit.

**Set Up Math Function**
1. From the menu bar, choose Math > Math Setup.
   - **TIP:** If you know which function location you'll be using, you can select Fx Setup right from the Math menu.
2. Choose a location by touching one of the Fx tabs (F1-F8).
3. On the Fx dialog, choose a single f(x) or dual g(f(x) operator function.
4. Choose math Operator1 to perform.
5. The choice of operator drives the number of Source fields you will see displayed. Make a selection in each field.
   - A Summary of the function you are building appears on the dialog. Refer to this to be sure your sources are in the proper order to yield the function you want (e.g., C1-C2 vs. C2-C1).
6. If the operator you've selected has any other configurable settings, you'll see a right-hand dialog of the same name as the operator. Touch the tab to open the dialog and make any further settings. These are explained on the dialog.
7. If you're creating a dual function, repeat Steps 4 through 6 for the second operation.

There will also be a Zoom dialog where you can optionally rescale the math trace. This does not affect the scale of any other traces.
8. Check Trace On to display the new math trace.

**Enable/Disable Math Function**
Once a math function has been created and saved in one of the Fx locations, just use the main Math dialog to quickly enable/disable it.

Touch the Front Panel Math button, or from the menu bar, choose Math > Math Setup, then check the On box next to each function you wish to display.

Clear the On box to disable the function and close the trace.
Common Math Applications

Rescaling and Assigning Units

This feature allows you to apply a multiplication factor \( a \) and additive constant \( b \) to your waveform: \( aX + b \). You can do it in the unit of your choice, depending on the type of application.

SET UP RESCALING

1. Follow the usual steps to set up a math function, selecting Rescale from the Functions submenu.
2. Touch the Rescale right-hand dialog tab.
3. To apply a multiplication factor:
   - Check the First multiply by: box and enter a value for \( a \), the multiplication factor.
   - Touch then add: and enter a value for \( b \), the additive constant.
4. To change the output unit of measure from that of the source waveform:
   - Check Override units.
   - In Output enter the abbreviation for the unit the measure you wish to use.

ABBREVIATED UNITS OF MEASURE

Abbreviations to be entered for units of measure are:


You can also enter combinations of the above units following these rules:

- For the quotient of two units, use the character "/:"
- For the product of two units, use the character "."
- Represent exponents by a digit appended to the unit without a space: M/S² for Meters per second squared.

In some cases, the units entered may be converted to simple units. For example entering V.A will display W (watts).
Averaging Waveforms

**SUMMED AVERAGING**

Summed Averaging is the repeated addition, with equal weight, of successive source waveform records. If a stable trigger is available, the resulting average has a random noise component lower than that of a single-shot record. Whenever the maximum number of sweeps is reached, the averaging process stops. In Summed averaging, you specify the number of acquisitions to be averaged. The averaged data is updated at regular intervals and presented on the screen.

An even larger number of records can be accumulated simply by changing the number in the dialog. However, the other parameters must be left unchanged or a new averaging calculation will be started. You can pause the averaging by changing the trigger mode from NORM/AUTO to STOP. The instrument resumes averaging when you change the trigger mode back to NORM/AUTO.

You can reset the accumulated average by pushing the CLEAR SWEEPS button or by changing an acquisition parameter such as input gain, offset, coupling, trigger condition, timebase, or bandwidth limit. The number of current averaged waveforms of the function, or its zoom, is shown in the acquisition status dialog. When summed averaging is performed, the display is updated at a reduced rate to increase the averaging speed (points and events per second).

**CONTINUOUS AVERAGING**

*NONE*: Continuous Averaging may be set up from either the Channel dialog under Pre-Processing, or as a Math function.

Continuous Averaging, the default setting, is the repeated addition, with unequal weight, of successive source waveforms. It is particularly useful for reducing noise on signals that drift very slowly in time or amplitude. The most recently acquired waveform has more weight than all the previously acquired ones: the continuous average is dominated by the statistical fluctuations of the most recently acquired waveform. The weight of ‘old’ waveforms in the continuous average gradually tends to zero (following an exponential rule) at a rate that decreases as the weight increases.

You determine the importance of new data vs. old data by assigning a weighting factor. Continuous averaging allows you to make adjustments to a system under test and to see the results immediately.

The formula for continuous averaging is:

\[
\text{new average} = \frac{\text{new data} + \text{weight} \times \text{old average}}{\text{weight} + 1}
\]

This is also the formula used to compute summed averaging. But by setting a "sweeps" value, you establish a fixed weight that is assigned to the old average once the number of "sweeps" is reached. For example, for a sweeps (weight) value of 4:

1st sweep (no old average): new average = (new data + 0 \times \text{old average})/(0 + 1) = new data only
2nd sweep: new average = (new data + 1 \times \text{old average})/(1 + 1) = 1/2 new data +1/2 old average
3rd sweep: new average = (new data + 2 \times \text{old average})/(2 + 1) = 1/3 new data + 2/3 old average
4th sweep: new average = (new data + 3 \times \text{old average})/(3 + 1) = 1/4 new data + 3/4 old average
5th sweep: new average = (new data + 4 \times \text{old average})/(4 + 1) = 1/5 new data + 4/5 old average
6th sweep: new average = (new data + 4 \times \text{old average})/(4 + 1) = 1/5 new data + 4/5 old average
7th sweep: new average = (new data + 4 \times \text{old average})/(4 + 1) = 1/5 new data + 4/5 old average

In this way, for sweeps > 4 the importance of the old average begins to decrease exponentially.

*NONE*: The number of sweeps used to compute the average will be displayed in the bottom line of the trace descriptor label:
SET UP AVERAGING
From the Channel Dialog
To quickly set up Continuous Averaging (only), access the Channel setup dialog and enter the number of sweeps to average in Averaging. The valid range is 1 to 1,000,000 sweeps.

From the Math Dialog
1. Follow the usual steps to set up a math function, selecting Average from the Basic Math submenu.
2. On the Average right-hand dialog, choose Summed or Continuous.
3. Touch Sweeps and provide a value. The valid range is 1 to 1,000,000 sweeps.

Enhanced Resolution
ERes (Enhanced Resolution) filtering increases vertical resolution, allowing you to distinguish closely spaced voltage levels. The instrument's ERes function is similar to smoothing the signal with a simple, moving-average filter. However, it is more efficient concerning bandwidth and pass-band filtering. See the end of this topic for more information about how the instrument enhances resolution.

Use ERes:
- On single-shot acquisitions, or where the data record is slowly repetitive (cases where you cannot use averaging).
- To reduce noise on noticeably noisy signals when you do not need to perform noise measurements.
- When performing high-precision voltage measurements (e.g., zooming with high vertical gain).

ERes can be applied as a form of Pre-Processing, or as a Math function.

SET UP ENHANCED RESOLUTION (ERes)
From the Channel Dialog
To quickly set up ERes, open the Channel setup dialog and in the Pre-Processing section select a Noise Filter (ERes) bit size.

From the Math Dialog
To apply ERes as a Math function:
1. Follow the usual steps to set up a math function, selecting ERes from the Filter submenu.
2. Touch the Trace On checkbox.
3. Touch the ERes right-hand dialog tab, then touch bits and make a selection from the pop-up menu.

HOW THE INSTRUMENT ENHANCES RESOLUTION
The instrument's enhanced resolution feature improves vertical resolution by a fixed amount for each filter. This real increase in resolution occurs whether or not the signal is noisy, or your signal is single-shot or repetitive. The signal-to-noise ratio (SNR) improvement you gain is dependent on the form of the noise in the original signal. The enhanced resolution filtering decreases the bandwidth of the signal, filtering out some of the noise.

The instrument's constant phase finite impulse response (FIR) filters provide fast computation, excellent step response in 0.5 bit steps, and minimum bandwidth reduction for resolution improvements of between 0.5 and 3 bits. Each step corresponds to a bandwidth reduction factor of two, allowing easy control of the bandwidth resolution trade-off. The parameters of the six filters are given in the following table.
With low-pass filters, the actual SNR increase obtained in any particular situation depends on the power spectral density of the noise on the signal.

The improvement in SNR corresponds to the improvement in resolution if the noise in the signal is white (evenly distributed across the frequency spectrum).

If the noise power is biased towards high frequencies, the SNR improvement will be better than the resolution improvement.

The opposite may be true if the noise is mostly at lower frequencies. SNR improvement due to the removal of coherent noise signals - feed-through of clock signals, for example - is determined by the fall of the dominant frequency components of the signal in the passband. This is easily ascertained using spectral analysis. The filters have a precisely constant zero-phase response. This has two benefits. First, the filters do not distort the relative position of different events in the waveform, even if the events’ frequency content is different. Second, because the waveforms are stored, the delay normally associated with filtering (between the input and output waveforms) can be exactly compensated during the computation of the filtered waveform.

The filters have been given exact unity gain at low frequency. Enhanced resolution should therefore not cause overflow if the source data is not overflowed. If part of the source trace were to overflow, filtering would be allowed, but the results in the vicinity of the overflowed data -- the filter impulse response length - would be incorrect. This is because in some circumstances an overflow may be a spike of only one or two samples, and the energy in this spike may not be enough to significantly affect the results. It would then be undesirable to disallow the whole trace.
The following examples illustrate how you might use the instrument's enhanced resolution function.

<table>
<thead>
<tr>
<th>Graph</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Graph" /></td>
<td><strong>In low-pass filtering:</strong> The spectrum of a square signal before (left top) and after (left bottom) enhanced resolution processing. The result clearly illustrates how the filter rejects high-frequency components from the signal. The higher the bit enhancement, the lower the resulting bandwidth.</td>
</tr>
<tr>
<td><img src="image2" alt="Graph" /></td>
<td><strong>To increase vertical resolution:</strong> In the example at left, the lower (inner) trace has been significantly enhanced by a three-bit enhanced resolution function.</td>
</tr>
<tr>
<td><img src="image3" alt="Graph" /></td>
<td><strong>To reduce noise:</strong> The example at left shows enhanced resolution of a noisy signal. The original trace (left top) has been processed by a 2-bit enhanced resolution filter. The result (left bottom) shows a smooth trace, where most of the noise has been eliminated.</td>
</tr>
</tbody>
</table>

**NOTE:** While enhanced resolution can only improve the resolution of a trace, it cannot improve the accuracy or linearity of the original quantization. The pass-band causes signal attenuation for signals near the cut-off frequency. The highest frequencies passed may be slightly attenuated. Perform the filtering on finite record lengths. Data is lost at the start and end of the waveform and the trace ends up slightly shorter after filtering. The number of samples lost is exactly equal to the length of the impulse response of the filter used: between 2 and 117 samples. Normally this loss (just 0.2 % of a 50,000 point trace) is not noticed. However, you might filter a record so short that no data is output. In that case, however, the instrument would not allow you to use the ERes feature.
FFT
For a large class of signals, you can gain greater insight by looking at spectral representation rather than
time description. Signals encountered in the frequency response of amplifiers, oscillator phase noise and
those in mechanical vibration analysis, for example, are easier to observe in the frequency domain.

If sampling is done at a rate fast enough to faithfully approximate the original waveform (usually five
times the highest frequency component in the signal), the resulting discrete data series will uniquely
describe the analog signal. This is of particular value when dealing with transient signals because, unlike
FFT, conventional swept spectrum analyzers cannot handle them.

Because of its versatility, FFT analysis has become a popular analysis tool. However, some care must be
taken with it. In most instances, incorrect positioning of the signal within the display grid will
significantly alter the spectrum, producing effects such as leakage and aliasing that distort the spectrum.
An effective way to reduce these effects is to maximize the acquisition record length. Record length
directly conditions the effective sampling rate of the oscilloscope and therefore determines the
frequency resolution and span at which spectral analysis can be carried out.

SET UP FFT
1. Follow the usual steps to set up a math function, selecting FFT from the Frequency Analysis
submenu.

2. Open the FFT right-hand dialog. Choose to either:

   - **trunc(ate)** - When the FFT transform size does not match the record length, truncate the
     record and perform an FFT on the shorter record. This option increases the resolution
     bandwidth.

   - **zero-fill** - When the source data for the FFT comes from a math operation that shortens the
     record (as is commonly encountered in filtering operations like ERes), replace the missing
     data points with data values whose amplitudes are interpolated to fit between the last data
     point and the first data point in the record. This guarantees that there is not a first-order
     discontinuity in the filled data. Since the data at the end of the record is filled data, it is
     advisable to select a weighting window other than rectangular to minimize the effect of the
     fill on the resulting spectrum.

3. Check the **Suppress DC** box to make the DC bin go to zero. Otherwise, leave it unchecked.

4. Choose an **Output type**.

5. Optionally, choose a weighting **Window**. See the section below for more information about FFT
   weighting windows.
6. Touch Algorithm and choose either:
   - **Least Prime** (default) - a least primes algorithm that computes FFTs on transform sizes having lengths that can be expressed as factors of $2^N\cdot5^K$. This is very compatible with the record lengths encountered in the oscilloscope, which are often multiples of 1, 2, 4, 5, or 10.
   - **Power of 2** - a power of 2 algorithm where the record lengths are in the form of $2^N$. The power of 2 algorithm generally runs faster than the least primes algorithm. The price that is paid is a record length that is not the same as the acquired signal. The power of 2 FFT truncates to the nearest power of 2 less than record length (if truncate is chosen) or fill data to nearest power of 2 greater than the record length (if zero fill is selected).

7. Depending on your **Output Type** selection, you may also make selections for:
   - **Group Delay Shift**
   - **Line Impedence** - by default, the FFT function assumes that the oscilloscope is terminated in 50 Ohms. If an external terminator is being used, this setting can be changed to properly calculate the FFT based on the new termination value.

**CHOOSING A WINDOW**

The choice of a spectral window is dictated by the signal's characteristics. Weighting functions control the filter response shape, and affect noise bandwidth as well as side lobe levels. Ideally, the main lobe should be as narrow and flat as possible to effectively discriminate all spectral components, while all side lobes should be infinitely attenuated. The window type defines the bandwidth and shape of the equivalent filter to be used in the FFT processing.

Rectangular windows provide the highest frequency resolution and are thus useful for estimating the type of harmonics present in the signal. Because the rectangular window decays as a $(\sin x)/x$ function in the spectral domain, slight attenuation will be induced. Alternative functions with less attenuation (Flat Top and Blackman-Harris) provide maximum amplitude at the expense of frequency resolution. Hamming and Von Hann are good for general purpose use with continuous waveforms.

<table>
<thead>
<tr>
<th>Window Type</th>
<th>Applications and Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular</td>
<td>Normally used when the signal is transient (completely contained in the time-domain window) or known to have a fundamental frequency component that is an integer multiple of the fundamental frequency of the window. Signals other than these will show varying amounts of spectral leakage and scallop loss, which can be corrected by selecting another type of window.</td>
</tr>
<tr>
<td>Hanning (Von Hann)</td>
<td>Reduces leakage and improves amplitude accuracy, but frequency resolution is also reduced.</td>
</tr>
<tr>
<td>Hamming</td>
<td>Reduces leakage and improves amplitude accuracy, but frequency resolution is also reduced.</td>
</tr>
<tr>
<td>Flat Top</td>
<td>Provides excellent amplitude accuracy with moderate reduction of leakage, but with reduced frequency resolution.</td>
</tr>
<tr>
<td>Blackman-Harris</td>
<td>Reduces leakage to a minimum, but with reduced frequency resolution.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Window Type</th>
<th>Highest Side Lobe (dB)</th>
<th>Scallop Loss (dB)</th>
<th>ENBW (bins)</th>
<th>Coherent Gain (dB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular</td>
<td>-13</td>
<td>3.92</td>
<td>1.0</td>
<td>0.0</td>
</tr>
<tr>
<td>Von Hann</td>
<td>-32</td>
<td>1.42</td>
<td>1.5</td>
<td>-6.02</td>
</tr>
<tr>
<td>Hamming</td>
<td>-43</td>
<td>1.78</td>
<td>1.37</td>
<td>-5.35</td>
</tr>
<tr>
<td>Flat Top</td>
<td>-44</td>
<td>0.01</td>
<td>2.96</td>
<td>-11.05</td>
</tr>
<tr>
<td>Blackman-Harris</td>
<td>-67</td>
<td>1.13</td>
<td>1.71</td>
<td>-7.53</td>
</tr>
</tbody>
</table>
**Sparse Function**
The Sparse math function allows you to thin out an incoming waveform by skipping points at regular intervals, and by starting acquisition at a particular offset (point). The **Sparsening factor** specifies the number of sample points to reduce the input waveform by. A sparsing factor of 4, for example, tells the oscilloscope to retain only one out of every 4 samples. A **Sparsening offset** of 3, on the other hand, tells the oscilloscope to begin on the third sample, then skip the number of samples specified by the sparsing factor (4). In this way, the sample rate is effectively reduced.

For the sparsing factor (interval), you can set a value from 1 to 1,000,000 points. For the sparsing offset you can set a value from 0 to 999,999.

**Note:** The maximum sparsening offset that can be entered for any sparsing factor equals Sparsening Factor 1.

1. Follow the usual steps to **set up a math function**, selecting **Sparse** from the Misc submenu.
2. Touch the **Sparsening factor** control and provide a Bandwidth Limit value.
3. Touch the **Sparsening offset** control and provide a value.

**Copy Function**
The **Copy** math function saves a copy of your present waveform in its unprocessed state to the first available memory location. While processing may continue on the original waveform, the copy enables faster throughput in some cases by preserving the original data. That is, no calculations need to be undone on the copy before additional math can be calculated.

This benefit of faster throughput, however, comes at the expense of memory usage.

Follow the usual steps to **set up a math function**, selecting **Copy** from the Misc submenu.

On the Wform Copy right-hand dialog, you can optionally **Reset Count** or **Change BatchSize**.

**Interpolation**
Linear interpolation, which inserts a straight line between sample points, is best used to reconstruct straight-edged signals such as square waves. \((\text{Sinx})/x\) interpolation, on the other hand, is suitable for reconstructing curved or irregular waveshapes, especially when the sampling rate is 3 to 5 times the system bandwidth. The instrument also gives you a choice of Cubic interpolation. For each method, you can select a factor from 2 to 50 points by which to interpolate (upsample).

1. Follow the usual steps to **set up a math function**, selecting **Interpolate** from the Filter submenu.
2. Touch the **Interpolate** tab in the mini setup dialog to the right of the main dialog.
3. Touch inside the **Algorithm** control and select an interpolation type.
4. Touch inside the **Upsample by** control (Upsampling is the factor by which sampling is increased) and enter a value.
## List of Math Functions

Standard math functions are listed below alphabetically.

<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute</td>
<td>For every point in the waveform the distance away from zero is calculated. For values greater than zero this is the same as the value. For values less than zero, returns the magnitude of a waveform without regard to the sign.</td>
</tr>
<tr>
<td>Average</td>
<td>Calculates either a summed or continuous average of a selected number of sweeps. See <a href="#">Averaging Waveforms</a>. The maximum number of sweeps is determined by the oscilloscope model and memory. See the specifications at teledynelecroy.com.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies waveform in its unprocessed state to the first available memory location.</td>
</tr>
<tr>
<td>Correlation</td>
<td>Calculates a measure of similarity of two waveforms, or a waveform against itself, as a function of a time-lag applied to one of them.</td>
</tr>
<tr>
<td>Derivative</td>
<td>Calculates the derivative of adjacent samples using the formula: ((\text{next sample value} - \text{current sample value}) / (\text{horizontal sample interval})).</td>
</tr>
<tr>
<td>Deskew</td>
<td>Shifts trace in time the amount of the deskew factor.</td>
</tr>
<tr>
<td>Difference</td>
<td>For every point in the waveform, the value of Source2 is subtracted from the value of Source1. Source1 and Source2 must have the same horizontal units and scale and the same vertical units.</td>
</tr>
<tr>
<td>Envelope</td>
<td>Calculates highest and lowest vertical values of a waveform at each horizontal value for a specified number of sweeps.</td>
</tr>
<tr>
<td>ERes</td>
<td>Applies a noise reduction and smoothing filter by adding a specified number of bits. See Enhanced Resolution.</td>
</tr>
<tr>
<td>Exp</td>
<td>Calculates the antilog to the base (e) of the source; that is, (e) raised to the power equal to the source.</td>
</tr>
<tr>
<td>Exp10</td>
<td>Same as Exp, using base 10.</td>
</tr>
<tr>
<td>FFT</td>
<td>Computes a frequency spectrum with optional Rectangular, Von Hann, Flat Topp, Hamming, Blackman-Harris, and Hanning windows. Also allows FFT Averaging through use of a second math operator. See FFT.</td>
</tr>
<tr>
<td>Floor</td>
<td>Calculates the lowest vertical values of a waveform at each horizontal value for a specified number of sweeps.</td>
</tr>
<tr>
<td>Histogram</td>
<td>Plots the number of data points that fall into statistically significant intervals or bins. Bar height relates to the frequency at which data points fall into each interval/bin.</td>
</tr>
<tr>
<td>Integral</td>
<td>Calculates the linearly rescaled integral (with multiplier and adder) of a waveform input starting from the left edge of the screen using the formula: [(\text{current sample value} + \text{next sample value}) * (\text{horizontal sample interval})]. Each calculated area is summed with the previous sum of areas. The multiplier and adder are applied before the integration function.</td>
</tr>
<tr>
<td>Interpolate</td>
<td>Inserts points between sampled points (upsamples) according to one of three algorithms: Linear (straight line), Sinx/x (curved), and Cubic (spine). Interpolation factor of 2 to 50 determines number of points in the upsample.</td>
</tr>
<tr>
<td>Invert</td>
<td>For every point in the waveform, the inverse of that point is calculated.</td>
</tr>
<tr>
<td>Ln</td>
<td>Performs a natural log of a waveform. Values less than or equal to zero are set to underflow.</td>
</tr>
<tr>
<td>Log10</td>
<td>Performs a log base 10 of a waveform. Values less than or equal to zero are set to underflow.</td>
</tr>
<tr>
<td>MatLab math</td>
<td>Applies a pre-programmed MatLab math function to the source waveform. Requires XDEV option to edit functions through the oscilloscope GUI using MatLab Script.</td>
</tr>
<tr>
<td>phistogram</td>
<td>Creates a histogram based on the displayed pixels of a waveform falling within a user defined vertical or horizontal box (slice).</td>
</tr>
<tr>
<td>Product</td>
<td>For every point in the waveform, the value of Source1 is multiplied by the value of Source 2. Source1 and Source2 must have the same horizontal units and scale.</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ptrace mean</td>
<td>Plots the mean value of each sample point in a persistence map.</td>
</tr>
<tr>
<td>ptrace range</td>
<td>Generates a waveform with a width derived from the population range of a persistence map.</td>
</tr>
<tr>
<td>ptrace sigma</td>
<td>Generates a waveform with a width derived from the sigma (sum) of a persistence map.</td>
</tr>
<tr>
<td>Ratio</td>
<td>For every point in the waveform, the value of Source1 is divided by the value of Source2. Source1 and Source2 must have the same horizontal units and scale.</td>
</tr>
<tr>
<td>Reciprocal</td>
<td>For every point in the waveform the inverse is calculated using the formula: $1 / (sample \ value)$</td>
</tr>
<tr>
<td>Rescale</td>
<td>For every point in the waveform the sample value is multiplied by the specified multiplicative constant, and then the specified additive constant is added. See Rescaling and Assigning Units.</td>
</tr>
<tr>
<td>Roof</td>
<td>Calculates the highest vertical values of a waveform at each horizontal value for a specified number of sweeps.</td>
</tr>
<tr>
<td>Segment</td>
<td>Selects one segment from a source waveform to place in a sequence waveform. Used in Sequence sampling mode.</td>
</tr>
<tr>
<td>Sinx/x</td>
<td>Performs 10-to-1 interpolation using a Sin(x)/x filter.</td>
</tr>
<tr>
<td>Sparse</td>
<td>“Thins,” or decimates, an incoming acquisition by dropping sample points at regular intervals. Sparsing factor specifies the number of points to drop between retained samples (e.g., factor of 4 retains 1 then drops 4). Sparsing offset specifies the point at which to begin applying the sparsing factor (e.g., offset of 3 begins count on the third sample (3), then drops the number of samples specified by the sparsing factor (4).</td>
</tr>
<tr>
<td>Square</td>
<td>For every point in the waveform, the square of the sample value is calculated.</td>
</tr>
<tr>
<td>Square Root</td>
<td>For every point in the waveform, the square root of the sample value is calculated.</td>
</tr>
<tr>
<td>Sum</td>
<td>For every point in the waveform, the value of Source1 is added to the value of Source 2. Source1 and Source2 must have the same horizontal units and scale and the same vertical units.</td>
</tr>
<tr>
<td>Track</td>
<td>Generates a waveform composed of parameter measurements that is time synchronous with the source waveform. The vertical units are those of the source parameter value and the horizontal units are seconds. Parameter values are posted at the sampling rate.</td>
</tr>
<tr>
<td>Trk</td>
<td>Same as Track, with alternate transition types.</td>
</tr>
<tr>
<td>Trend</td>
<td>Produces a waveform composed of a series of parameter measurements in the order the measurements were taken. The vertical units are those of the source parameter, the horizontal unit is measurement number. The trend contains a single value for each measurement. See View Trend.</td>
</tr>
<tr>
<td>Zoom</td>
<td>Produces a magnified trace of a selected portion of the input waveform. See Zooming Traces.</td>
</tr>
</tbody>
</table>
Analysis

Most Teledyne LeCroy oscilloscopes calculate measurements for all instances in the acquisition, enabling you to rapidly and thoroughly analyze a long memory acquisition of thousands or millions of parameter values to find anomalous measurements, or to apply a variety of mathematical functions to the waveform trace.

These measurements and manipulations of the original input signal can be viewed in several graphical formats to facilitate your analysis.

**Histograms** display the distribution of measured values for a given parameter as a bar chart. See About Histograms.

**Tracks** provide a time-correlated view of a measurement parameter compared to other acquired channels or calculated math traces. A common usage for track is to observe the modulation of a signal, such as amplitude, frequency, or pulse width modulation. See View Track.

**Trends** provide a view of a measurement parameter over an extended period of time and over multiple acquisitions. See View Trend on page 79 and Track vs. Trend to better understand what a Trend provides compared to a Track.

There are also conditional tests that can be applied to the data to find particular events:

- **Pass/Fail Testing**, including Mask Testing, finds normal/abnormal measurements as indicated by whether or not they meet a set of defined criteria.

- **WaveScan** searches a single acquisition for events that meet specific criteria, enabling you to zoom in on anomalies in the waveform, or scans multiple acquisitions with allowable trigger actions when conditions are met. It can also be used to filter measurements. A variety of views help you understand the behavior of waveforms.

Optional software packages may be purchases that simplify specialized analysis, such as various Serial Data Decode options. These all add new methods to those available on the oscilloscope Analysis menu.
Histogram

Histograms are graphical representations of data which divide it into intervals or bins. These intervals/bins are plotted on a bar chart such that the bar height relates to the number of data points inside each interval/bin.

You can set up histograms to visualize the results of measurement parameters or math functions on the corresponding Measure or Math dialogs. You can also create a histogram of a persistence display.

Regardless of where you create it, the histogram is created as a math (Fx) trace. The number of sweeps (k#) comprising the histogram is shown on the function trace descriptor box.

The range of a histogram is limited to the portion of the source trace that is visible on screen. If you zoom in on a trace, the histogram does not contain data for the no longer visible parts of the original trace.

Thumbnail versions of measurement parameter histograms are called Histicons. They are available as a checkbox option on the Measure dialog. Histicons appear on the measurement parameter table, rather than as a new math trace.
**View Histogram**

1. If you are not already on the Measure or Math dialog, choose **Measure → Measure Setup...** or **Math → Math Setup...** from the menu bar.
2. Touch the tab for the measurement parameter or math function you wish to histogram and check **Trace On**.
3. If you’re already on the Fx dialog, touch the **graph button** and skip to Step 5.
   
   OR

   Touch the **Histogram** button at the bottom of the Px dialog and choose the math trace (F1-F12) in which to display the histogram.

   The histogram opens in a new grid along with its function descriptor box.

4. Touch the new **Fx descriptor box** to display the Fx dialog.
5. Touch the **Histogram tab** at the right to display the Histogram right-hand dialog.
6. Enter the maximum **#Values** in one bin of the histogram. This determines the number of samples that are represented by the bar at full height.
7. Touch **#Bins** and enter the number of bins that comprise the histogram. This determines how many bars appear in the histogram.
8. To let the oscilloscope determine the range of values represented by each bin/bar, check **Enable Auto Find**, then touch the **Find Center and Width button**.
   
   OR

   To set your own range, enter **Center** and **Width** values.

**View Persistence Histogram**

This feature creates a histogram of a persistence display, which draws the usual histogram bar chart of statistically significant sample values in a horizontal or vertical “slice” of a persistence map (rather than a single source waveform).

**NOTE:** This math operation is different than the Histogram math operation and is not affected by Center and Width settings made on any existing Histograms.

1. Choose **Math → Math Setup...** from the menu bar to access the Math dialog.
2. Touch an open **Fx button** and select **Phistogram** from the pop-up menu.
3. Touch the **Fx tab** to open the Function dialog, then touch **Source1** and select a source trace from the pop-up.
4. Touch the **Phistogram tab** at the right to open the Phistogram dialog.
5. Touch **Slice Direction** and select **Horizontal** or **Vertical** slice from the pop-up menu.
6. Touch **Slice Center** and use the pop-up keypad to enter a value.
7. Touch **Slice Width** and use the pop-up keypad to enter a value.
Trend and Track
Both Track and Trend are tools that can be used to plot measurement data and observe variations with respect to time. Differences between Track and Trend are summarized in the following table:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Track</th>
<th>Trend</th>
</tr>
</thead>
<tbody>
<tr>
<td>Representation</td>
<td>Parameter value vs. time</td>
<td>Parameter value vs. event</td>
</tr>
<tr>
<td>Behavior</td>
<td>Non-cumulative (resets after every acquisition). Unlimited number of events</td>
<td>Cumulative over several acquisitions up to 1 million events</td>
</tr>
<tr>
<td>Time Correlation to Other Data</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Monitors an Evolution in the Frequency Domain</td>
<td>Yes</td>
<td>No. Trend points are not evenly spaced in time and therefore cannot be used for an FFT.</td>
</tr>
<tr>
<td>Monitors the Evolution of a Measurement Parameter over Several Acquisitions</td>
<td>No. Track resets after every acquisition.</td>
<td>Yes</td>
</tr>
<tr>
<td>Ensures No Lost Measurement Data</td>
<td>Yes. Maximum time period that can be captured is limited by acquisition memory and sampling rate.</td>
<td>No. Since data can be accumulated over many acquisitions, and since the oscilloscope takes time to calculate measurement values and to display data before the trigger is re-armed, data can be missed.</td>
</tr>
</tbody>
</table>

In general, Track is the tool to use if you want to capture a continuous stream of data spaced closely together. To understand the change in a parameter with time, Trend can be used if your data is spaced widely apart and longer than the dead-time of the oscilloscope between acquisitions. Think of Trend as a strip chart recorder for your oscilloscope.

View Track
This procedure explains how to view the Track of a measurement parameter applied to a waveform. A track is a waveform composed of parameter measurements that is time synchronous with the source waveform. The vertical units are those of the source parameter and the horizontal units are seconds. In order to maintain time synchronism, the parameter values are posted at the sampling rate. Track values are redundant in that the same value is repeated every sample period until the measurement changes.

Although a Track plots measurement parameter values, it is created as a function and controlled on the Math dialog.

1. If not already on the Measurement dialog, choose Measure → Measure Setup....
2. Touch the Px tab for the parameter you wish to plot.
3. Touch the Track button at the bottom of the Px dialog and select a math function (Fx) in which to draw the Track.

The Track is displayed on a new grid, along with its function descriptor box.
To rescale the Track plot:

- Touch the **Track function descriptor box** to open the Fx dialog, then touch the **Track tab**.
- On the Track right-hand dialog, uncheck **Auto Find Scale** and enter a new **Center** and **Height/div**.

---

**View Trend**

This procedure explains how to view the trend of a measurement parameter. A trend is a waveform composed of a series of parameter measurements in the order the measurements were taken. The vertical units are those of the source parameter, the horizontal unit is measurement number. The trend contains a single value for each measurement.

Although the trend plots measurement values, the plot is drawn as a math function and controlled through the Math dialog.

1. If you’re not already on the Measure dialog, choose **Measure → Measure Setup**.
2. Touch the **Px tab** for the parameter you wish to plot.
3. Touch the **Trend button** at the bottom of the dialog and choose a math function **Fx** in which to draw the Trend.

   The Trend is displayed in a new grid, along with its function descriptor box.

4. To rescale the Trend plot:

   - Touch the **Trend function descriptor box** to open the Math dialog, then touch the **Trend tab** at the far right of the dialog.
   - On the Trend right-hand dialog, uncheck **Auto Find Scale** and enter the new **Center** and **Height** values.
WaveScan
The WaveScan® Search and Find tool enables you to search for unusual events in a single capture, or to scan for a particular event in many acquisitions over a long period of time. Each Scan Mode is optimized to find a different type of event. The results are time stamped, tabulated, and can be selected for individual viewing.

There are two principal approaches to using WaveScan.

**Capture & Search** -- Make a single acquisition, then use Measurement Mode to search for parameter measurements that fit your filter criteria.

**Scan** -- Set up the scan mode, then scan for matching events across multiple acquisitions.

Customize the presentation by choosing different WaveScan display features, or Scan Views. Optionally, set Actions to occur automatically when unusual events are found, such as stopping the acquisition or sounding an alarm.

![WaveScan Interface](image)

**NOTE**: Whenever WaveScan is enabled, the instrument reverts to Real-time sampling mode.

**Scan Modes**
The scan mode determines the type of search to be performed. Select the Mode along with the Source trace to be searched on the main WaveScan dialog.

For each mode, different controls appear on the WaveScan dialog, providing additional inputs to the search criteria. Make the appropriate entries in these fields before starting the search.

**EDGE MODE**
Edge Mode is used for detecting the occurrence of edges. Events that meet the threshold level are captured and tabulated. When the acquisition is stopped, scan filters set up with the Measurement Mode can be applied to the edges to find specific characteristics.
Additional settings for Edge Mode are:

**Slope** -- choose Pos, Neg, or Both.

**Level** is -- choose Percent or Absolute.

**Percent/Absolute Level** -- Enter a threshold value as a percentage of Top to Base or voltage level. A marker displayed over the source trace indicates the level.

**NON-MONOTONIC MODE**

**Non-monotonic Mode** looks for edges that cross a threshold more than once between high and low levels. All events that meet the criteria of slope, hysteresis, and level are presented in a table and highlighted in the source trace. The value displayed in the table is the difference of the max. and min. of the non-monotonicity. This can be confirmed with cursors. The hysteresis value is used to eliminate noise. A non-monotonicity is detected only when its amplitude is greater than the hysteresis. Therefore, when setting a hysteresis level, set a value that is greater than the amplitude of the noise.

Additional settings for Non-monotonic Mode are:

**Slope** -- choose Pos, Neg, or Both.

**Hysteresis** is -- choose Division, Percent, Absolute.

**Division/Percent/Absolute** -- enter the hysterisis level in the units you selected.

**Levels are** -- choose Percent, Absolute, or Pk-Pk%.

**High Level** and **Low Level** -- Enter the top and bottom thresholds in the units you selected.

**RUNT MODE**

**Runt Mode** looks for pulses that fail to cross a specified threshold. You can search for positive-going or negative-going runts, or both. An adjustable hysteresis band is provided to eliminate noise.

In the case of negative-going runt pulses, the value displayed in the table is the difference (delta) of the high level of the signal and the runt amplitude (i.e., where the runt bottoms out). This can be confirmed by placing cursors on the runt pulse and reading the delta Y value in the trace labels. In the case of positive-going runt pulses, the value displayed in the table is the absolute value of the amplitude of the runt pulse.

Additional settings for Runt Mode are:

**Runt Type** -- choose Both, Pos, or Neg.

**Hysteresis** -- enter the hysteresis level as a percentage or voltage.

**Low Threshold** and **High Threshold** -- enter the levels as a percentage or voltage.

**Absolute Levels** -- check this box if you want to enter levels as absolute voltage instead of percentage.

**MEASUREMENT MODE**

**Measurement Mode** is used for applying filters to measurements to find those that meet your defined criteria, helping to isolate particular events within many samples. Markers appear over the source trace to indicate the location of measurement, while the table displays values for the selected parameter that meet the criteria.

Additional Settings for Measurement Mode are:

**Measurement** -- choose the measurement parameter you wish to search.
**Filter Method** -- choose the operator that indicates the desired relationship to the Filter Limit. Only measurements that meet this criteria are returned.

**Filter Limit** -- enter the value that completes the filter criteria.

Alternatively, you can use the Filter Wizard to create the filter criteria.

**Serial Pattern Mode**

Serial Pattern Mode is used for finding 2- to 64-bit patterns in digital sequences; ideal for bursted patterns where a PLL cannot lock.

Additional settings for Serial Pattern Mode are:

**Viewing** -- choose to enter the pattern as Binary or Hex.

**Binary/Hex** -- enter the pattern.

**Num. Patterns to detect** -- enter a whole number.

**Scan Views**

Scan Views are different ways to view your WaveScan results. You can choose to display views simultaneously or visit them sequentially. Just check the boxes at the bottom of the WaveScan dialog for those views you wish to display. Uncheck the box to turn off the view.

**NOTE**: The number of grids displayed varies from one to three grids depending on which views are enabled. WaveScan handles this function automatically, and there is no option to move traces from one grid to another, as would be the case under normal operation.

You'll find additional controls for manipulating views like Scan Overlay and Zoom on their respective dialogs. If you turn on these traces from their dialogs, you must turn them off from there, too.

**Source Trace**

By default, the source trace is displayed in the top grid, with markers indicating points in the trace that meet the search criteria.

**Table and Times**

Table view displays a table of measurements relevant to your chosen Search Mode next to the source trace. Times adds columns to the table showing Start and Stop Times for each event.

**Scan Overlay**

Scan Overlay view plots the location of captured events in a new trace.

**To apply monochromatic persistence to the scan overlay:**

1. Check **Persistence On**.
2. Enter a **Saturation** value. This controls...
3. Choose a **Persistence Time**. The higher the time, the more static the persistence display.

**To rescale the scan overlay to effectively "zoom" in or out:**

Touch the **In/Out buttons**, or touch **Scale** and **Delay** and enter new values. Check **Var.** to adjust values in finer steps than the default 1, 2, 5, 10.
Scan Histogram provides a statistical view of edges that meet your search criteria.

ZOOM
Zoom view works exactly as it does elsewhere in the oscilloscope software, opening a close-up of the source trace in a new grid that you can rescale vertically and horizontally. A Zx tab appears by default when you launch WaveScan; see Zoom Controls for an explanation of the remainder of the controls found on this dialog.

One unique feature of the WaveScan Zoom is that you can automatically zoom the events captured from the source trace by touching the Prev/Next buttons on the Zx dialog. You can also select the event from the Table display, and you are automatically relocated to that event on the zoom trace.

Set Up WaveScan
This procedure explains how to set up WaveScan to search an acquisition for events of interest. Set up your source channel and triggers before setting up the scan.

1. Press the Front Panel Stop button to stop acquisition.
2. Choose Analysis > WaveScan.
3. Check Enable.
4. Choose the Source waveform.
5. Choose the Scan Mode and enter values for any additional settings that appear at the right of the dialog based on your selection.
6. If you're using Measurement Mode, set up the filter in one of the following ways:
   - Touch Filter and choose an operator, then enter the Filter Limit.
   - Touch Filter Wizard and choose one of the pre-set filters. The Filter and Filter Limit are automatically set based on your selection.
7. Select each Scan View in which you wish to display results by checking the box at the bottom of the dialog. Each view selected is displayed simultaneously.
8. If you’re using Scan Overlay view, on the Scan Overlay dialog Clear Sweeps. If desired, set up the Persistence display.
9. Optionally, choose an Action to trigger when an event that meets your scan criteria is found.
10. Restart acquisition.
History Mode

History Mode allows you to review any acquisition saved in the oscilloscope's history buffer, which automatically stores all acquisition records until full. Not only can individual acquisitions be restored to the grid, you can "scroll" backward and forward through the history at varying speeds to capture individual details or changes in the waveforms over time.

Each record is indexed and time-stamped, and you can choose to view the absolute time of acquisition or the time relative to when you entered History Mode. In the latter case, the last acquisition is time zero, and all others are stamped with a negative time. The maximum number of records stored depends on your acquisition settings and the size of the oscilloscope memory.

To view history:

1. Press the Front Panel History Mode button, or choose Timebase > History Mode.
2. Select View History to enable the history display, and View Table to display the index of records. Optionally, select to view Relative Times on the table.
3. Choose a single acquisition to view by entering its Index number on the dialog or selecting it from the table of acquisitions, or use the Navigation buttons to "scroll" the history of acquisitions.
   - The top row of buttons scrolls continuously and are (left to right): Fast Backward, Slow Backward, Pause, Slow Forward, Fast Forward.
   - The bottom row of buttons steps one record at a time and are (left to right): Back to Start, Back One, Go to Index (#), Forward One, Forward to End.

You can also use the slider bar at the bottom of the dialog to scroll the history.

Entering History Mode automatically stops new acquisitions. To leave History Mode, press the Front Panel History Mode button again or clear the View History checkbox on the History dialog. Restart acquisition by pressing one of the Front Panel Trigger Mode buttons.
Pass/Fail Parameter Testing Overview

Access the main Pass/Fail dialog by selecting Analysis → Pass/Fail Setup... from the menu bar. The main Pass/Fail dialog is shown.

Access the respective Qx dialogs either by touching a Qx button on this main Pass/Fail dialog, or touching a Qx tab as described in Displays Containing Masks.

When you have each of the Qx dialogs configured and enabled as desired, you can then begin your testing and turn them all on or off using the Testing checkbox on the main Pass/Fail dialog. You can also specify Actions for all or some of your conditions using the Actions dialog.

Mask Testing

Mask testing is a type of Pass/Fail testing that is particularly useful for comparing newly acquired signals to a previously acquired "golden standard" waveform.

A mask defines an area of the grid against which a source Channel, Zoom, or Math trace is compared. Test conditions are associated with the mask, defining how the waveform is to be compared to the masked area (e.g., some/all values fall within, some/all values fall outside), and a Pass/Fail result is returned indicating the condition was found to be true or false.

Mask testing can be done using a pre-defined mask or a mask created from your actual waveform, with vertical and horizontal tolerances that you define. Some industry standard masks used for compliance testing are included with the oscilloscope software. The mask test can be confined to just a portion of the trace by the use of a measure gate.

Access Mask Test Dialogs

1. Choose Analysis → Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qx button or tab where you want to set up the mask.

   The source waveform will be tested against this mask whenever Qx is enabled on the Pass/Fail dialog.

3. From the pop-up menu, select Pass/Fail Condition and Mask test..

   The Qx dialog opens with the Mask test condition selected and the Test, Load Mask, Make Mask, and Gate right-hand dialogs displayed. On these dialogs, you manage, make, and apply gates to your mask.
**Make Mask**
Use this procedure to create a new mask based on a source waveform. The mask will cover the area of the waveform, plus the boundary values you enter.

1. Touch the **Make Mask tab** to display the dialog.

![Make Mask dialog](image)

2. If desired, enter a new **Destination File Name** and path, or touch Browse and select a previous file to overwrite. The file name should end with the `.msk` extension.

3. Touch the **Ver Delta** and **Hor Delta** fields and enter boundary values using the pop-up numeric keypad or the Front Panel Adjust knob.

4. Touch **Make from Trace**.

**Load Mask**
Use this procedure in lieu of Make Mask if you have a pre-defined mask file, or wish to recall a mask you previously created and saved.

1. Touch the **Load Mask tab** to display the dialog.

![Load Mask dialog](image)

2. To use a saved `.msk` file, touch **File** and select the mask.

   **OR**

   To use an industry standard mask, touch **Standard** and select the mask from the pop-up.

3. Check **View Mask** to display the mask over the trace.
**Set Gates**
Optionally, set gates to limit the portion of the waveform that is compared to the mask.

1. Touch the **Gates tab** to display the dialog.

2. Enter the **Start** and **Stop** timebase divisions that mark the segment of the waveform to be tested with this mask. This can be a whole division of a fraction of a division. Divisions are numbered 1-n left to right.

   **TIP:** A quick way to position the gate is to touch the gate posts, which initially are placed at the extreme left and right ends of the grid, and drag them to the desired points.

**Define Test**

1. Touch the **Test tab** to display the dialog.

2. Select one of the conditions that, when True (yes), result in a Pass.

3. Optionally, turn **Off/On** markers. Markers visually indicate where on the waveform mask violations have occurred.

**Removing a Mask from the Display**

1. Access the **Qx** dialog where the mask is set.

2. On the **Load Mask** right-hand dialog, click the **Delete** button.
**Spectrum Analyzer**
Spectrum Analyzer adds two dialogs for frequency analysis to your oscilloscope Analysis menu options:

**Spectrum Analyzer** – the principal setup dialog, with controls similar to a traditional RF spectrum analyzer. This is also where you control the spectrogram.

**Peaks/Markers** – where you control the Peaks and Markers features.

Set up your spectrum trace on the Spectrum Analyzer dialog by choosing your inputs (one or more channel, zoom, math, or memory traces) and the frequency range of interest, just as with an RF analyzer. Then, choose various analysis features, such as Show Peaks or Spectrogram, to optimize your display.

**Set Up Spectrum Trace**
This procedure explains how to use the Spectrum Analyzer software option to display a spectrum trace, an FFT of your input trace.

1. Choose **Analysis > Spectrum Analyzer**; the Spectrum Analyzer dialog appears. Be sure **Enabled** is checked so the spectrum trace is displayed.

2. To use **1 Input** or a differential probe connected to a single channel (the default), touch **Input1** and choose any channel, zoom, math, or memory source.

   OR

   To input the difference between two sources, select **Input 1-Input 2**, then touch **Input1** and choose the first source. Repeat for **Input2**.

   **Example**: You can input the difference between two probes connected to two different channels. This option eliminates the need to first set up a math trace to calculate the difference.
3. Position the spectrum trace in either of the following ways:

Select **Center Span**, then enter the **Center Freq.** and the **Freq. Span**, the total range of frequencies that appear on the grid. Use the Up/Down Arrow buttons to quickly step through the frequency span.

**TIP:** To change the frequency span in finer increments than the default 1, 2, 5 steps, check Variable.

Select **Start Stop**, then enter the absolute **Start Freq.** and **Stop Freq.** of the frequency span.

**TIP:** Start by viewing a large range of Start Stop frequencies to see where frequencies of interest occur in the spectrum trace. Then, Center Span around a frequency for a smaller span.

**NOTE:** The spectrum Analyzer always sets the sample rate equal to or higher than twice the frequency span selected.

The remainder of the steps are optional.

4. Adjust the resolution by unchecking Auto (the default) and entering a new **Resolution BW**.

**Note:** Changing Resolution Bandwidth is equivalent to changing the Timebase to increase or decrease memory in FFT mode. Reducing the bandwidth will increase the available memory, enabling a faster update rate, but will decrease the resolution of the trace.

5. Change the operating **Mode** of the trace:

- **Normal** (default) – displays the power spectrum of the source trace. You can enable or disable Persistence in this mode.

- **Persistence** – in Normal mode with Persistence on, you will see a history of multiple spectra similar to the display on an RF spectrum analyzer.

- **Average** – choose a number of spectra to average. This effectively reduces noise and displays more of the harmonic carrier detail.

- **Max Hold** – is useful for swept frequency measurements. It shows the history of peak values across the frequency axis.

6. Choose a weighting **Window** to be used for the FFT.

7. Change **Scale** to alter the spectrum trace based on your reference signal. Enter new values for any of the following:

**Output** units of measure:
- dBm
- dBV
- dBmV
- dBµV
- V rms
- Arms
**Reference Level** – Lowering/raising this value moves the trace up/down on the grid.

**Scale** – Amplitude/div. Lowering/raising this value has the effect of “zooming” in/out on the trace. (This alters the appearance of the spectrum trace; it does not open a separate zoom trace.)

**TIP:** An easy way to rescale the trace is to touch-and-drag: a) the trace or the Center Frequency indicator left or right, which changes the Center Frequency setting; b) the Zero Point indicator up or down, which changes the Reference Level setting.

8. Select to display additional traces:

   **Show Source** displays the pre-transform source trace.

   **Show Zoom** displays a zoom of the source trace.

   Each trace opens in a separate grid from the spectrum trace, and a new descriptor box appears on screen. Touch the descriptor box to open the trace setup dialog and make further adjustments.

**Show Peaks**
This procedure explains how to use the Show Peaks feature. Show Peaks marks a desired number of peak amplitudes in the spectrum trace and displays their values in tabular form.

Show Peaks is an automatic and continuous identification of peaks. As the range of frequencies measured changes, peak values are recalculated and markers are moved. The values tabulated are always absolute values for the marked peak.

1. Set up the spectrum trace.

2. Touch the **Peaks/Markers tab**; the Peaks/Markers dialog opens.
3. Select **Peaks**.

4. Enter a **Max.** (number of) **Peaks** up to 100.

Circular markers appear over the trace, representing the x peak amplitude measurements.

5. Choose to **Sort By** amplitude or frequency on the measurements table.

   The table is reordered to show the marker with highest amplitude or frequency value on top. The marker number assignment does not change.

6. Optionally, reposition the trace by choosing a peak to **Set Center Freq.** to. Select the desired marker from the table or enter the marker number in **Peak #**. Touch **Apply**.

   The trace shifts, and the new x peak amplitudes in that span of frequencies are marked and tabulated.

   **TIP:** If you do not want the peaks to be renumbered after changing the center frequency, use the Markers feature instead and choose to Set Markers on Peaks.

7. To maximize the grid area, uncheck **Show Table**. To remove the frequency readout from the markers, uncheck **Show Freq**.

**Apply Markers**

This procedure explains how to apply up-to-20 markers to frequencies of interest. Unlike peak markers, these markers remain in place unless you manually re-assign them to a different frequency. However, you can associate different measurements with the markers, and values are automatically calculated and added to the tabular display.

1. Set up the spectrum trace.

2. Touch the **Peaks/Markers tab**; the Peaks/Markers dialog opens.

3. Select **Markers**.

4. Choose which set of markers to **View**:

   - **Set 5 Default Markers** marks five frequencies spread evenly over the spectrum.
   - **Set Markers on Peaks** marks the peak amplitudes in the spectrum.
   - **Set Markers on Harmonics** marks the fundamental frequency and its harmonic content.
Blue, triangular markers appear over the trace. Marker 1 is always the Reference Marker, also indicated by a thick, white cursor line. The default measurement is absolute amplitude and frequency.

The remainder of the steps are optional.

5. Use the Marker Controls to re-assign a marker to a new frequency:
   - Select the marker from the table or from the Marker popup menu. This is now the Active Marker, indicated by a thin, dashed cursor line, and all Marker Controls apply to this marker.
   - To move it to the Next Peak in either direction, touch the Left/Right Arrow button.
   - To move it to the peak with the Next (highest or lowest) Amplitude, touch the Up/Down Arrow buttons.
   - To move it to a specific Frequency, enter the new value.
   - To remove it from the display, deselect Show Marker.

   **TIP:** A quick way to re-assign any marker is to touch-and-drag the cursor line or the blue triangle to a new frequency. The tabular values are recalculated as the marker moves.

6. To Set Center Freq. to Marker or Set Ref. Level to Marker, activate the desired marker then touch the button.

   Those settings now take the value of the Active Marker, and the trace is shifted accordingly, although the marker itself remains on the same frequency.

7. Change the Marker Measurements by selecting or deselecting options.
Note: The Track All Markers to Ref. Marker option locks all markers at their current delta from the Reference Marker. The markers are moved as the Reference Marker is moved. This is useful for finding interesting harmonics in the spectrum.

The measurements table expands or collapses depending on how many measurements you have selected.

8. To maximize the grid area, uncheck Show Table. To remove the frequency readout from the markers, uncheck Show Freq.

Display Spectrogram
This procedure explains how to display a spectrogram of a spectrum trace. The spectrogram is a 2D or 3D rendering of the historical data, up-to-256 spectra displayed in a vertically stacked display. The spectrogram can be shifted/rotated on any of its two or three axes and can be generated in colorized or monochrome versions to more easily visualize high-occurrence samples.

1. Set up the spectrum trace.
2. Choose Type 2D or 3D and check View.

The spectrogram is drawn in a new grid above the spectrum trace.
3. Move the Spectrogram slider or touch the Right/Left Arrow buttons to increase or decrease saturation level.

Saturation corresponds to how often a frequency occurs in a spectrum. The greater the saturation, the more variation you will see in the spectrogram.

4. Optionally, uncheck Monochrome to colorize the spectrogram.

Variations in hue correspond to the occurrence of a frequency in the spectrum. Hotter hues indicate more frequent events, cooler hues indicate less frequent events.

5. Grab (touch-and-hold) any point in the spectrogram to move it.

**View Configurations**

All oscilloscope settings can be viewed through the various Status dialogs. These show acquisition, trigger, channel, math function, measurement and parameter configurations, as well as which are currently active.

Access the Status dialogs by choosing the Status option from the Vertical, Timebase, Math, or Analysis menus (e.g. Channel Status, Acquisition Status).
Utilities

Utilities Settings
Utilities settings primarily control the instrument's interaction with other devices/systems. Preferences, on the other hand, tend to control the appearance and performance of the oscilloscope application.

To access the Utilities dialog, choose Utilities → Utilities Setup... from the menu bar.

HardCopy Setup, Date/Time Setup, and System Status buttons open their corresponding dialogs, as do the tabs. There are also tabs linking to Remote Control, Auxiliary Output, and Options settings.

NOTE: Hardcopy Setup controls the behavior of the oscilloscope's Print function. The selected print output device or application is displayed to the right of the HardCopy Setup button for convenience.

Show Windows Desktop minimizes the oscilloscope application window. Maximize the application by touching the oscilloscope display icon located at the lower-right of the desktop.

Touch-Screen Calibration launches a sequence of display calibration screens. You will be prompted through a series of actions to improve the precision and accuracy of the touch screen.

The Service button to the far right of the dialog (not shown) launches a section of the application reserved for qualified Teledyne LeCroy personnel. An access code is required to enter this section.

System Status
The Utilities Status dialog displays information about your instrument including model number, serial number, firmware version, and installed hardware and software options.

To view status, choose Utilities > Utilities Setup from the menu bar, then touch the Status tab, or choose Support > About from the menu bar.

NOTE: The Utilities Status is not the same as the Status feature accessed through various menus. That feature displays the current state of the oscilloscope configurations that affect the analysis functions--such as acquisition, channel, parameter, function, and memory settings.
Add Software Options
Newly purchased software options are enabled on the oscilloscope using a key code supplied by Teledyne LeCroy.

1. From the menu bar, choose Utilities > Utilities Setup.
2. Touch the Options tab.
3. Touch the Add Key button.
4. Enter the key code.
5. Touch Activate Key Now.
6. Restart the oscilloscope.

Remote Control Settings
The Utilities Remote dialog contains settings to configure remote control of the instrument. Supported communication protocols are:

- **TCP/IP (Ethernet)** - Enables remote control across a LAN via an Ethernet port. If you choose this option, you also need to install Teledyne LeCroy's VICP drivers on the controller. These are included in the VICP Passport plug-in, available free from teledynelecroy.com.

  **NOTE**: The instrument uses Dynamic Host Configuration Protocol (DHCP) as its addressing protocol. It is not necessary to set up an IP address if your network supports DHCP. If it does not, you can assign a static address in the standard Windows network setup menu on the oscilloscope.

- **LXI (Ethernet)** - Enables remote control across a LAN via an Ethernet port.
- **USBTMC** - Enables remote control via a device connected to the USBTMC port.
- **GPIB** - Enables remote control using GPIB if you have the GPIB-USB adapter connected to any host USB port.

**Set Up Remote Control**
Contact your Network Administrator to connect the oscilloscope to your LAN. Use a USB cable to connect the oscilloscope directly to a PC.

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. On the Remote dialog, make a Control From selection.
3. If you are using TCPIP or LXI, touch the Net Connections button. The Windows Network Connections window opens for you to select a network.
4. If you are using TCPIP and wish to restrict control of the oscilloscope to specific network clients, touch Yes. Enter the IP addresses or DNS names of the authorized controllers in a comma-delimited list.
Configure the Remote Control Assistant Event Log

The Remote Control Assistant monitors communication between the controller and oscilloscope when you are operating the instrument remotely. You can log all events or errors only. The log can be output to an ASCII file and is invaluable when you are creating and debugging remote control programs.

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. Under Remote Control Assistant, touch Log Mode and choose Off, Errors Only, or Full Dialog.
3. To always clear the log at startup, check Reset to Errors Only and clear at startup.

Export Contents of the Event Log

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. Touch the Show Remote Control Log button. The Event Logs pop-up is shown.
3. Enter a log file name in DestFilename, or touch Browse and navigate to a file.
   
   **NOTE:** New contents will overwrite the existing content; it is not appended.
4. Touch Export to Text File.

Print (Hardcopy) Settings

Hardcopy settings control how the oscilloscope Print function behaves. Print captures an image of the oscilloscope display, but there are several options as to what it does with the image next:

- Send to a hardcopy printer
- "Print" to a file that can be saved to an internal or external drive
- Send to E-Mail
- Copy to the Windows clipboard for you to paste elsewhere

Each option is set up on the Utilities Hardcopy dialog. You can further set up a default print color scheme and capture area. A preview of your hardcopy setup appears to the right of the dialog.

**NOTE:** You can configure the Front Panel Print button to create a new Notebook Entry to be included in a LabNotebook report. This is not done in Utilities Hardcopy, but in LabNotebook itself. See Print to Notebook Entry. However, the File menu Print option will continue to use your Hardcopy setting.
Send to Printer

Follow these procedures to configure output to a printer.

**ADD PRINTER**

**NOTE:** Any printer compatible with Microsoft Windows Embedded Standard 7P operating system is supported by your instrument. Install printer drivers on the instrument outside of the oscilloscope application. Printers can be connected via LAN (Ethernet) or USB.

1. From the menu bar, choose File → Print Setup... or Utilities → Utilities Setup → HardCopy.
2. On the Utilities Hardcopy dialog, choose Printer.
3. Touch the Add Printer button that appears. A Microsoft Windows Devices and Printers window opens where you can configure a new printer.
4. To make the printer the instrument default, select it from the Select Printer list.

**PRINT SETUP**

1. From the menu bar, choose File → Print Setup... or Utilities → Utilities Setup → HardCopy.
2. On the Hardcopy dialog, choose Printer.
3. Touch Select Printer and choose a printer from the list. If you don't see the printer you want, first follow steps to Add Printer.
4. Choose a page Orientation: portrait or landscape.
5. Optionally, choose a color scheme and hardcopy (print) area.
6. Optionally, touch Properties to open the Windows print dialog and adjust printer properties.

**Print to File**

Follow this procedure to print screen captures to a file. The default save directory can be set to any folder on the oscilloscope hard drive, or an external drive connected via USB port.

1. Choose Utilities → Utilities Setup... from the menu bar, then touch the Hardcopy tab.
3. Choose the output File Format.
4. Enter a File Name. This will form the basis of all print filenames, until you change it.
   
   **NOTE:** Numbers at the end of the filename will be truncated, as the instrument appends numbers to this name with each new file. If you wish to add your own identifying numbers, place them at the front of the name.

5. Optionally, enter the path to a new save Directory, or touch the Browse button and navigate to the folder.

   **NOTE:** The default print folder is C:\...\XStream\Hardcopy. Other types of files that may be saved using other oscilloscope functions, such as masks and scripts, have their own XStream subfolders.

6. Optionally, choose a color scheme and hardcopy (print) area.
Copy to Clipboard
Follow this procedure to copy screen captures to the clipboard so you can paste them into another application (like Microsoft Word, for example).

1. Choose **Utilities → Utilities Setup...**, then touch the **Hardcopy** tab.
2. On the Hardcopy dialog, choose **Clipboard**.
3. Optionally, choose a [color scheme](#) and [hardcopy (print) area](#).

Send to E-Mail
Follow this procedure to e-mail capture files to a preset address. The e-mail connection is set up in **Utilities > Preferences Setup > E-Mail**.

1. Choose **Utilities → Utilities Setup...** from the menu bar, then touch **Hardcopy** tab.
2. On the Hardcopy dialog, choose **E-Mail**.
3. Choose the output **File Format**.
4. If you wish to be able to include messages with the files as they are sent, check **Prompt for message to send with mail**.
5. Optionally, choose a [color scheme](#) and [hardcopy (print) area](#).
6. To go on and set up the e-mail connection, touch **Configure E-Mail Server and recipient**.

Choose Print Color Scheme
To change the color of your print output, touch the **Color** button on the Hardcopy dialog and choose:

- **Standard** (default) - prints objects on a black background, as they appear on the display.
- **Print** - prints objects on a white background using your chosen colors. This option saves ink.
- **Black & White** - prints objects in grayscale.

**NOTE:** The colors used to represent channels in Standard and Print schemes are configured on the **Preferences Colors** dialog.

Set Print Area
To limit which part of the touch screen is captured, touch **Hardcopy Area** on the Hardcopy dialog and choose from:

- **Grid Area Only** - omits dialogs and menus and prints only the grids.
- **DSO Window** - prints the dialogs with the grids.
- **Full Screen** - prints the entire touch screen.
Auxiliary Output Settings

Use the Aux Output dialog to configure the output of the Aux Out and Cal Out ports.

Configure Auxiliary Output

Choose one of the following under Use Auxiliary Output For:

- **Trigger Enabled** - can be used as a gating function to trigger another instrument when the oscilloscope is ready.
- **Trigger Out** - can be used to trigger an external oscilloscope off the instrument's state.
- **Pass/Fail** - generates a pulse when Pass/Fail testing is active and conditions are met. With this selection, a Pulse Duration data entry control appears. Provide a value within your instrument’s specified range, which varies by model. Refer to datasheet specifications at teledynelecroy.com.
- **Off** - disables auxiliary input/output.

Configure Calibration Output

A calibration signal can be output from the Cal Out hook on the front of the oscilloscope. Choose one of the following under Use Calibration Output For:

- **Square** - send a square wave signal. Enter the wave Frequency and Amplitude into 1 MΩ. The Set to 1 kHz, 1 V Square Wave button does exactly that.
- **DC Level** - sends a reference level. Enter an Amplitude into 1 MΩ.
- **Off** - disables calibration output.
Date/Time Settings
Date/Time settings control the oscilloscope’s date and timestamp. These numbers appear in the oscilloscope message bar and on tables/records internal to the oscilloscope application, such as History Mode and WaveScan.

**NOTE:** This is not the same as the Timebase reference clock used to synchronize traces.

To access the Date/Time dialog, choose **Utilities > Utilities Setup** from the menu bar, then touch the **Date/Time tab or button.**

![Date/Time dialog](image)

**Manual Method**
Enter the **Hour**, **Minute**, **Second**, **Day**, **Month**, and **Year**, then touch the **Validate Changes** button.

**Internet Method**
This method uses the Simple Network Time Protocol (SNTP) to read the time from time-a.nist.gov. The oscilloscope must be connected to an internet access device through the LAN (Ethernet) port on your instrument's I/O panel.

If your connection is active, touch the **Set from Internet** button.

**Windows Method**
To set date and time using the internal Windows system clock, touch the **Windows Date/Time** button. This displays the standard Windows **DateTime Properties** pop-up dialog, where you can further configure these settings. If you are satisfied with the setup, just touch OK.
Disk Utilities

Use the Disk Utilities dialog to arrange the file/folder structure on your instrument's hard drive. You can delete files, folders, or create new folders.

**NOTE:** All Disk Utilities can also be accomplished using the standard Microsoft Windows file management tools.

Access the Disk Utilities dialog by selecting Utilities → Disk Utilities from the menu bar.

### Delete a Single File

1. Touch the Delete button.
2. Touch Current folder and provide the path to the folder containing the file, or touch Browse and navigate to the folder.
3. Touch File to be deleted and provide a file name.
   
   **NOTE:** You can also use the up down arrows to move through the files contained in the Current folder selected.
4. With the desired file selected, touch Delete File.

### Delete All Files in a Folder

1. Touch the Delete button.
2. Touch Current folder and provide the path to the folder, or touch Browse and navigate to the folder.
3. With the desired folder selected, touch Empty Folder.

### Create a New Folder

1. Touch Create.
2. Touch Current folder and provide the full path to the new folder, including the folder name.
3. Touch Create Folder.

**NOTE:** Disk Space data for Size, Free, and File(s) is available on the far right of the dialog for convenience.
Preferences Settings
Preference settings have mostly to do with the appearance and performance of the oscilloscope itself, rather than the oscilloscope's interaction with other devices/systems.

Access the Preferences dialog by choosing Utilities → Preference Setup... from the menu bar.

Audible Feedback controls the instrument's audio output. Select this box to hear a beep each time you touch a screen or front panel control.

Automatic Calibration enables or disables the temperature dependent calibration feature. When enabled, the instrument will offer you a choice of calibrations to perform whenever there is a significant change in ambient temperature.

**NOTE:** If you do not enable this option, the oscilloscope re-calibrates only at startup and whenever you make a change to certain operating conditions.

Language sets the language used on the display.

Performance settings let you optimize oscilloscope performance for either Analysis (speed of acquisition and calculation) or Display (speed of update/refresh). For example, if you are concerned with persistence or averaging, you might optimize for Analysis, giving higher priority to waveform acquisition at the expense of display update rate. Choices are presented as a spectrum.

There are also tabs linking to Calibration, Acquisition, E-Mail, Color, and Miscellaneous settings.
Calibration Settings
To ensure the instrument maintains specified performance, it is factory set to perform a calibration during warm-up. We recommend that you warm up the oscilloscope for at least 20 minutes prior to use to give the instrument time to complete calibration procedures.

Manually calibrate the oscilloscope when:

- It is used in temperatures that differ from the previous calibration temperature by more than 5° C.
- It has been more than one month since the previous calibration.

Go to Utilities > Calibration Setup.

The Calibration dialog shows the oscilloscope's calibration status and recommended actions.

There are two options for this calibration: Calibrate All or Calibrate Current Setting.

- **Calibrate All**—All possible combinations of vertical and horizontal settings are calibrated at the current temperature. This calibration is valid for the current temperature ± 5° C and takes about 50 minutes.
- **Calibrate Current Setting**—The oscilloscope is calibrated at the current vertical and horizontal setting. This calibration is valid for this setting for the current temperature ± 5° C and takes under 30 seconds.

**CAUTION.** It is required that all inputs be removed from the oscilloscope prior to performing calibration.
Acquisition Settings
The Preferences Acquisition settings determine how traces behave on screen as gain or timebase changes. Make a selection in each area.

Offset Setting constant in:
- **Volts** moves the vertical offset level indicator with the actual voltage level.
- **Div(isions)** keeps the vertical offset level indicator stationary. The waveform remains on the grid as you increase the gain; whereas, if Volts is selected, the waveform could move off the grid.

Delay Setting constant in:
- **Time** moves the horizontal offset level indicator with the trigger point.
- **Div(isions)** keeps the horizontal offset indicator stationary. The trigger point remains on the grid as you increase the timebase; whereas, if Time is selected, the trigger point could move off the grid.

**NOTE**: The Offset is always in volts, and the Delay is always in time. However, whenever Div is selected, these are scaled proportional to the change in gain or timebase, thereby keeping the division of the grid constant.

Trigger Counter Setting:
Checking **Reset trigger counter before starting a new acquisition** clears the trigger counter each time the oscilloscope issues an acquisition command. It is only available when you have a trigger Holdoff condition set.

Color Settings
Preferences Color settings assign the colors used for channel, math, and memory traces. All dialogs, tables, and trace descriptor boxes will match the color of the trace assigned here. You can choose different colors to be used on the instrument and in print.

For convenience, you can **Preview print colors** to see how the settings will appear in print output.

**NOTE**: Print colors are used only when the Colors control is set to Print on the Hardcopy dialog in Utilities → Utilities Setup... Otherwise, the Screen colors are used for print output as well as on screen.

To make any setting, just touch the color swatch for either Screen or Print next to the trace number, and make a selection from the Color pop-up menu.

Touch **Factory default colors** to recall the original color settings for your instrument.
E-Mail
Use the E-mail dialog to set up e-mail on the oscilloscope.

E-Mail Server- Choose a server protocol from the following options:

- **MAPI** (Messaging Application Programming Interface) is the Microsoft interface specification that allows different messaging and workgroup applications (including e-mail, voice mail, and fax) to work through a single client, such as the Exchange client. MAPI uses the default Windows e-mail application.

- **SMTP** (Simple Mail Transfer Protocol) is a TCP/IP protocol for sending messages from one computer to another through a network. This protocol is used on the Internet to route e-mail. In many cases no account is needed.

**Configuration** - Provide values based on your selected server protocol:

- **If you chose MAPI**, touch inside the **Originator Address (From:)** data entry field and provide the instrument's e-mail address. Then touch inside the **Default Recipient Address (To:)** data entry field and provide the recipient's e-mail address.

- **If you chose SMTP**, touch inside the **SMTP Server** data entry field and provide the name of your server. Touch inside the **Originator Address (From:)** data entry field and provide the instrument's e-mail address. Then touch inside the **Default Recipient Address (To:)** data entry field and provide the recipient's e-mail address.

**Send Test Mail** - Click this button to send a confirmation message to ensure proper e-mail configuration.

Miscellaneous Settings
These other Preference settings are located on the **Miscellaneous** dialog.

**Hardcopy:** You can add the Teledyne LeCroy logo to print output by checking **Print LeCroy Logo When Printing Grid Area Only.** This identifies the instrument as the source of the image.

**Zoom:** You can adjust zoom behavior as follows:

- **Dimming** darkens/shades those areas of the source waveform that are not part of the Zoom trace.

- **Control Sensitivity** adjusts the sensitivity of the Front Panel knobs. **Optimized** applies an acceleration algorithm to the knobs. **Legacy** detects rotation of the front panel knobs in a manner similar to our legacy oscilloscopes.
Serial Decode Annotation Position: If you have Serial Trigger or Decode options installed on your oscilloscope, this control determines the placement of annotation labels relative to the trace line. **On Trace** places the label close to the line; **On Noisy Trace** sets the label further from the line to accommodate potential noise spikes in the trace.

Security: Check **Enable HTTP Screen Capture** to enable remote capture of the oscilloscope display over the Internet.

### Save/Recall (File Functions)

The Save/Recall features allow for storage and retrieval of Waveforms, Table Data, and Instrument Setups. There are also Disk Utilities for arranging the file/folder structure on your instrument's hard drive.

Directly access the **Save Waveform**, **Save Table**, **Save Setups**, and **Disk Utilities** dialogs from the **File** menu.

A main Save/Recall dialog is shown providing buttons to access the aforementioned dialogs for specific Save/Recall functions.

### Save/Recall Setups

The Save/Recall Setup dialogs allow for quick saving and recalling of up to six oscilloscope panel settings internally on your instrument. If desired, you can also save and recall your oscilloscope panel settings as an .lss file to a specific hard disk location, a network location, or USB drive.

**Save Oscilloscope Setup(s)**

Access the **Save Setup...** dialog by either selecting **File → Save Setup...** from the menu bar or clicking the **Save Instrument Setup** button on the main Save/Recall dialog.

**SAVE TO MEMORY**

1. Touch one of the **SetupX** data entry controls and enter a name for the memory.

2. Touch the corresponding **Save** button directly to the left of the **SetupX** field.

Settings are saved to the D:\Internal Setups location on your instrument. The save date/time is displayed above the **SetupX** data entry control.
## SAVE TO FILE
1. Touch **Save Panel to File** and enter the full path to the file, or touch **Browse** to navigate to the file folder.
2. Enter a filename, or choose an existing file to overwrite.
3. Touch **Save Now!**

## Recall Oscilloscope Setup(s)
Access the **Recall Setup...** dialog by either selecting **File → Recall Setup...** from the menu bar or clicking the **Recall Instrument Setup** button on the main Save/Recall dialog.

### Recall Setup(s) From Memory
Touch one of the six **Recall** buttons under **Recall From Internal Setup...**.

**NOTE:** If a setup has been stored to a location, it is labeled with the name and save date/time. Otherwise, the slot is labeled **Empty**.

### Recall Setup(s) From File
1. Touch **Recall panel from file** and provide the path to the destination file, or touch **Browse** to navigate to the file.
2. Touch **Recall Now!**

## Save/Recall Waveforms

### Save Waveform
The Save Waveform dialog is used to save traces to either an internal memory location, or to a text or binary format file. The source waveform can be any trace; for example, a channel, math function, or a waveform stored in memory.

Access the **Save Waveform** dialog by either selecting **File → Save Waveform** from the menu bar or clicking the **Save Waveform** button on the main Save/Recall dialog.
SAVE TO MEMORY
1. Touch Memory.

   **NOTE:** When Memory is selected, only Source and Destination controls are shown on the Save Waveform dialog. When File is selected, many more controls are available.

2. Choose the Source trace you are saving.

3. Choose the Destination location.

4. Optionally, touch Trace Title to change the default name of your waveforms.

   **NOTE:** You can change the name but not the sequence number.

5. Touch Save Now!

   **CAUTION.** If you use a name ending with a number instead of a letter, the instrument may truncate the number. This is because, by design, the first waveform is automatically numbered 0, the second 1, and onward. For example, if you want to use waveform name XYZ32 but it is not preceded by waveforms XYZ0 through XYZ31, the waveform is renumbered with the next in sequence. If you need to use a number in your waveform's name, append an alpha character at the end of the number: XYZ32a, for example.

SAVE TO FILE
1. Touch File.

2. Choose the Source waveform.

3. Touch Data Format and select a file format.

   - **Binary** - saves the file to Teledyne LeCroy's binary file format. This format is documented in various Remote Control manuals for Teledyne LeCroy oscilloscopes. Binary results in the smallest possible file size, and is recommended when recalling waveforms to Teledyne LeCroy instruments.

   **NOTE:** Binary files can be converted to ASCII using Teledyne LeCroy utilities such as ScopeExplorer or WaveStudio.

   - **ASCII** - text output file (.txt extension).

   - **MATLAB** - text output file compatible with MATLAB (.dat extension).

   - **Excel** - text output file compatible with Excel (.csv extension).

   - **MathCad** - text output file compatible with Excel (.prn extension).

   - **Audio** - .wav file.

   - **WaveML** - .xml file, used for persistence traces.

4. Depending on your file format selection, you may also need to specify a SubFormat.

   - **Word** - For Binary files, samples in the output file are represented with 16 bits. Always use this option unless Byte mode is "pre".

   - **Byte** - For Binary files, samples in the output file are represented with 8 bits. This option can result in a loss of output file resolution.

   - **Auto** - For Binary files, looks at the data and automatically selects either Word or Byte subformat.

   - **Amplitude only** - output file includes amplitude data for each sample, but not sample time information.

   - **Time and Amplitude** - output file includes both time and amplitude data for each sample.

   - **With Header** - includes a header with scaling information.
5. If you selected ASCII file format, also touch the **Delimiter** control and select a delimiter character from the pop-up menu. Choose from **comma**, **space**, **semicolon**, or **tab** delimiters.

6. Touch **Save Now!**

**AUTO SAVE**

The **Auto Save** feature automatically saves a waveform to disk after each new trigger.

Enable Auto Save from the **Save Waveform** dialog by selecting one of the **Auto Save** buttons: **Wrap** (old files overwritten) or **Fill** (no files overwritten).

Choosing **Off** disables AutoSave.

Touch the **Browse** button next to the **Save file in directory** control and navigate to the location where you want the file saved. The file name is assigned automatically and is shown under the control.

**Recall Waveform**

Access the **Recall Waveform** dialog by either choosing **File → Recall Waveform** from the menu bar or clicking the **Recall Waveform** button on the main Save/Recall dialog.

**NOTE:** Only .trc files saved in binary format can be recalled into the oscilloscope.

**FROM MEMORY**

1. Touch **Memory**.

2. Touch **Source** and choose a memory location from the **Select Source** pop-up.

3. Touch **Destination** and select a location into which to open the recalled memory.

4. Mark **Show on Recall** to display the trace on the grid.

5. Touch **Recall Now!**

**FROM FILE**

1. Select **File**.

2. Touch **Recall files from directory** and enter the path to the waveform folder, or touch **Browse** and navigate to the folder.

3. Use the **Up /Down Arrows** to cycle through the available files until the desired file is selected.

   Optionally, touch **Show only files** to apply a search filter (**channels**, **math functions**, or **memory**) to the list of available files.

4. Mark **Show on Recall** to display the trace on the grid.

5. Touch **Recall Now!**
Save Table Data
The Save Table function saves tabular measurement data displayed on screen to an Excel or ASCII file.

Access the Save Table dialog by choosing File → Save Table from the menu bar.

1. Leave the default Source selection All Displayed.
2. Optionally touch Trace Title and enter a new base filename. This name with a sequence number appended to it will be used for all filenames until you change it.
   
   **CAUTION:** Any numbers placed at the end of this name are truncated because the instrument automatically appends the next number in sequence to each file. If you want to use your own identifying number, place it at the beginning of the name, or append an alpha character at the end of the number: XYZ32a, for example.

3. Touch Data Format and choose from:
   
   **ASCII** - .txt extension.
   
   **Excel** - .csv extension.

4. If you selected ASCII format, also touch Delimiter and choose a character.

5. Optionally, to automatically save data to this file type after each new trigger, choose an Auto Save option: Wrap overwrites old files in the order created; Fill stops before overwriting files.

   **CAUTION:** Because the hard disk is partitioned, if you have frequent triggers, it is possible you will eventually run out of storage space on the D: drive. Choose Wrap only if you’re not concerned about files persisting on the instrument. On the other hand, if you choose Fill, plan to periodically move files out of the waveform directory.

6. Optionally, to change the save directory, touch the Browse button and navigate to the folder.

7. Touch Save Now!
LabNotebook

Teledyne LeCroy's LabNotebook feature extends the documentation capabilities of your oscilloscope. It allows you to create and save Notebook Entries containing all displayed waveforms, the oscilloscope setup under which they were taken, and custom annotations. Notebook Entries can then be output to a hardcopy report format—.pdf, .rtf, or .html—and printed or e-mailed. You can also configure your own report layout if you prefer not to use the default.

Notebook Entries are stored in an internal database and are available for recall at any time. Besides storing the waveform data, LabNotebook also stores your panel setups and parameter measurements. You can back up this database to external media for indefinite storage of waveform data.

The Flashback Recall feature instantly recalls the setups stored with individual Notebook Entries, enabling you to restore the exact state of the oscilloscope at a later date to perform additional analysis. A keyword filter makes it easy to find and recall a specific Notebook Entry.

Entries can be collected into separate Notebooks by project or user, especially useful if the oscilloscope is shared. Similarly, you can customize the folder structure into which Notebooks are stored to facilitate backup and sharing.

Create Notebook Entry

A Notebook Entry is a snapshot of the oscilloscope at the moment it is taken: it captures the waveforms, their setups, and any measurements in process. As each new entry is created, it is added to the database of Notebook Entries accessible from the LabNotebook dialog, where they can be collected into LabNotebook Reports, or recalled to the screen through Flashback Recall.

By default, you will be prompted to title and annotate new Notebook Entries as they are created. You can configure LabNotebook preferences so that these steps are skipped in order to streamline the creation process. In that case, you can select the entry from the list of Notebook Entries to manage them at a later time.

1. Choose File > Create Notebook Entry.

   OR

   Press the Front Panel Print button if you have configured it for LabNotebook.

2. Optionally, Enter Report Title and Description.

   The default title is the date and time stamp. You can leave this as is, append some descriptive text to it, or completely remove it from your title.

3. Touch Save.

4. Use the Drawing toolbar to markup the Notebook Entry. Click Done when finished.
LabNotebook Drawing Toolbar

The basic Notebook Entry is a screen capture of the display showing the grids as they were at the time it was taken. When an entry is first captured, it is immediately displayed in the Drawing window for you to annotate.

A variety of markup tools are available from the toolbar along the top of the window. To use any tool, touch the icon, then touch the point on the image where you wish to draw or add text.

From left to right, the tools are:

**Pen Tool** enables you to draw in freehand. Maintain contact with the screen to make a continuous mark. Once you release, you can touch-and-drag the object to any point on the image.

**Circle Tool** draws a circle around a waveform feature that you want to emphasize. Touch-and-drag across the diameter of the circle. When you release, the circle is placed. You can drag the circle to any location on the image.

**Arrow Tool** draws lines with arrowheads for placing callouts. You can rotate these lines through 360 degrees or drag them to any location on the image.

**Text Tool** opens a textbox for placing labels/annotations on the image. Touch the point on the image to place the label, then enter the text in the pop-up dialog. Once placed, you can resize the textbox or drag it to any location on the image.

**Red, Green, and Blue Color Selectors** let you quickly change the markup color. Just touch the icon, then choose the next drawing tool.

To use additional colors, touch the **More Button**. This activates a **Custom** color field. The default custom color is Yellow. To choose another, touch the color swatch, then select from the Color dialog (the standard Windows Palette dialog). You can enter RGB values, or choose from the spectrum. After saving, the new color appears in the Custom field. This remains the markup color until you choose another.

**Erase Buttons** allow you to remove all or selected drawing objects. Erase All will also undo any Custom color selection.

**Undo Button** cancels the last action. Use it to restore any objects you inadvertently erased.

**Move Toolbar Button** undocks the drawing toolbar so you can move it anywhere on the display. This helps to keep tools handy when working on a particular area of a waveform. Touch the button again to restore the toolbar to the top of the Drawing window.

**Done Button** saves the annotations with the image and closes the Drawing window.
Print to NoteBook Entry
The Front Panel Print button can be configured to capture the display and create a new Notebook Entry. This is a convenient way to quickly create new Notebook Entries as you work.

**NOTE:** The File menu Print option will continue to use whatever method you have set on the Utilities Hardcopy tab when invoked. Go to Utilities > Utilities Preferences > Hardcopy to make that selection.

To configure the Print button for Notebook Entries, go to File > LabNotebook > Preferences tab and check Create Entry when Hardcopy Pressed.

Manage Notebook Entries
The LabNotebook dialog is the principal notebook management tool where you can filter, select, view, edit, print, email, save, export/import, or recall Notebook Entries created in the course of your work.

To access the LabNotebook dialog, choose File → LabNotebook from the menu bar.

**NOTE:** If an external monitor is connected, LabNotebook automatically opens on the external monitor.

Select Notebook Entries
You must select Notebook Entries before any further action can be performed.

**SELECT SINGLE ENTRY**
Use the Up and Down arrows to scroll the My Notebook Entries list one row at a time, or filter the entries if there are a large number. The selected entry is highlighted in blue.

**SELECT MULTIPLE ENTRIES**
1. Check the Multi-selection box.
   
   Four Select/Clear option buttons appear.
2. Touch Select All to select the entire list of entries for action.
   
   OR
   
   Use the Up/Down arrow buttons to scroll the list, then touch Select as the entry is highlighted. You can also filter before selecting individual entries.
   
   A white arrow appears next to each selected entry.
3. To remove selections from the list, highlight them again and touch Clear, or just touch Clear All.

Filter Notebook Entries
1. Touch the Filter button.
2. On the Filter Entries pop-up, enter the filter criteria. You can use Day/Month/Year, a Keyword, or a combination.
3. Touch Find Now to filter.
4. To restore the full list, touch Clear Filter.
**View Notebook Entries**
View allows you to preview the selected entries in the report format before printing/saving.

Select the desired entries and touch the View button. Use the scrollbar that appears on the LabNotebook window to navigate the report.

**Edit Notebook Entries**
1. Select the Notebook Entry from the list.
2. Go to the second tab labeled with the entry name.
3. Modify the Title or Description.
4. To add markup to the entry, touch the Scribble button and use the Drawing Toolbar.

**Email Notebook Entries**
Choose E-Mail to send selected Notebook Entries to the default address specified in the oscilloscope Preferences. To use the E-Mail button, the instrument must have an active network connection and you must first configure the email address and server.

If you have not yet configured email, or if you wish to change the recipient address before sending, open the LabNotebook Preferences tab, then touch the Configure E-Mail button.

Also select whether or not to Attach Setup & Waveform files to the email with the LabNotebook files.

**Print Notebook Entries**
To print multiple entries, select them from the main LabNotebook dialog, then touch the Print button on the same dialog.

To print a single entry, select it from the main LabNotebook dialog, then go to the second tab and touch the Print button.

**Delete Notebook Entries**
Use the Delete button to remove selected Notebook Entries, or Delete All to clear the entire My Notebook Entries. Be aware that unless you have previously exported the Notebook database, the deleted entries cannot be restored.

**Create Report**
Create Reports collates the selected Notebook Entries into a single .RTF/.PDF document or HTML archive using the report template selected on the LabNotebook Preferences tab. This can be one of the preformatted templates or a custom format. It is not necessary to first create a report document to view, email, or print selected Notebook Entries.

1. Select the entries from the My Notebook Entries list.
2. Choose the output Format.
3. Touch Create Report.
4. On the Create Report window, select the folder in which to save the report.
   
   **TIP:** Touch Open Explorer Here and use Windows Explorer to create a new folder. After closing Explorer, touch the Refresh button to display the folder in the Create Report window. Now select it.

5. Enter a File name for the report.
6. Click OK to create the report.
Manage Notebooks
LabNotebook stores Notebook Entries in a .zip archive on the instrument hard drive. Each .zip file is essentially one Notebook comprised of everything shown in the My Notebook Entries list on the LabNotebook dialog. New Notebooks can be created for different individuals or projects, or the existing Notebook backed up for storage, on the LabNotebook Advanced tab.

**NOTE**: The default Notebook is D:\Xport\MyLabNotebook.zip. If you’ve already created Notebook Entries that you wish to keep, you can use the backup feature to save them under a new file name or location before starting a new Notebook.

**Create New Notebook**
1. Choose File > LabNotebook, then touch Advanced.
2. Under Storage, touch the Start New button below the Database field.
3. Enter a File Name for the new Notebook (optionally, choose a new storage folder, as well). Touch OK.

   The new Notebook now appears in the Database field. New Notebook Entries will be added to this Notebook. The old Notebook Entries are saved in the previous Notebook archive.

**Back Up Notebook**
1. Choose File > LabNotebook, then touch Advanced.
2. Under Storage, touch the Backup button below the Database field.
3. Enter a File Name for the backup file. Optionally, choose a new storage Folder.
4. Choose to Backup to Removable Disk (this option is active if you have a USB drive attached to the oscilloscope) or Backup to Folder on hard drive.

   **NOTE**: By default, backup files have the extension *.bak.zip appended to them. You can change this to anything you like.

**Import Notebook**
Stored Notebooks can be imported into the working Notebook archive. The imported Notebook Entries are appended to the current set.
1. Choose File > LabNotebook, then touch Advanced.
2. Under Storage, touch the Import From button below the Database field.
3. Navigate to the desired Notebook archive and select it. Touch OK.
Flashback Recall

Once a Notebook Entry is made, you can recall it at any time using Flashback Recall. The recall includes waveforms and oscilloscope settings, so you can analyze the inputs that resulted in that capture.

1. Choose File > LabNotebook to open the LabNotebook dialog.
2. Select the Notebook Entry from the list.
3. Touch the Flashback Recall button.
4. To exit Flashback Recall, touch the Undo button at the far right of the menu bar.

Some result data not included in Flashback Recall are:

- **Persistence data** - While it is saved in hardcopy and is printed on the report, it is not recalled during Flashback.
- **Histogram data** - Histograms internally have a 32-bit resolution, but when stored into a trace file and recalled during flashback they are clipped to 16-bits.
- **Floating point waveforms** - Certain math operations result in the creation of floating point waveforms with much higher resolution than can be stored in a 16-bit waveform file. This extra resolution is not preserved when traces are recalled using flashback.
- **Cumulative Measurements** - Any measurements on when the Lab Notebook entry is created are not saved individually in the database (other than being embedded in the hardcopy image). This means that when flashback is used, the measurements are recomputed using the recalled waveform data. Normally, doesn’t pose a problem; however, if cumulative measurements were on when the entry was stored and the cumulative measurements accumulated data from multiple acquired waveforms, they lose their history and show instead only the results from the stored waveforms.

Configure LabNotebook Preferences

To configure the behavior of the LabNotebook tool, on the menu bar, choose File → Lab Notebook, then touch the Preferences tab.

Select/deselect the following options:

- **Prompt for Report Title Before Saving** opens the LabNotebook dialog when a new entry is created. You can elect to name notebook entries using only the date/timestamp by leaving this box unchecked.
- **Annotate Report Before Saving** opens the Drawing Toolbar to annotate a notebook entry as soon as it is created.
- **Save Report When Hardcopy Pressed** configures the Front Panel print button to create a new notebook entry whenever it is pressed.
- **Use Print Colors** outputs waveforms on a white background. The print colors used for each trace are set in Utilities > Preferences Setup > Colors. This option helps save ink/toner when printing reports.
Hardcopy Area determines how much of the screen image is included in the report: grid area only, grid area plus dialog, whole screen. Touch the field and choose from the pop-up menu.

Attach Setup & Waveforms attaches these files for each trace in the report: waveform data (.trc), a screen dump (.png), oscilloscope setup file (.lss), report template file (.xsl), and export record (.htm).

Optionally, touch the Configure E-Mail button to set the recipient address and server information on the Preferences E-mail dialog.

Maintenance

Safety Instructions
Observe these instructions to keep the instrument operating in a correct and safe condition. You are required to follow generally accepted safety procedures in addition to the precautions specified in this section. The overall safety of any system incorporating this instrument is the responsibility of the assembler of the system.

Symbols
These symbols may appear on the instrument's front or rear panels and in its documentation to alert you to important safety considerations.

⚠️ CAUTION of potential damage to instrument, or WARNING of potential bodily injury. Do not proceed until the information is fully understood and conditions are met.

⚠️ High voltage. Risk of electric shock or burn.

接地 (Measurement ground connection)

接地 (Safety (protective) ground connection)

交流 (Alternating Current)

待机电源 (Standby Power (front of instrument))

Precautions
Use proper power cord. Use only the power cord shipped with this instrument and certified for the country of use.

Maintain ground. This product is grounded through the power cord grounding conductor. To avoid electric shock, connect only to a grounded mating outlet.

Connect and disconnect properly. Do not connect/disconnect probes or test leads while they are connected to a voltage source.

Observe all terminal ratings. Do not apply a voltage to any input (C1, C2, C3, C4 or EXT) that exceeds the maximum rating of that input. Refer to the front of the oscilloscope for maximum input ratings.

Use only within operational environment listed. Do not use in wet or explosive atmospheres.

Use indoors only.
Keep product surfaces clean and dry.

**Do not block the cooling vents.** Leave a minimum six-inch (15 cm) gap between the instrument and the nearest object. Keep the underside clear of papers and other objects.

**Do not remove the covers or inside parts.** Refer all maintenance to qualified service personnel.

**Do not operate with suspected failures.** Do not use the product if any part is damaged. Obviously incorrect measurement behaviors (such as failure to calibrate) might indicate impairment due to hazardous live electrical quantities. Cease operation immediately and sequester the instrument from inadvertent use.

**Operating Environment**

**Temperature:** 5 to 40° C.

**Humidity:** Maximum relative humidity 90% for temperatures up to 31° C, decreasing linearly to 50% relative humidity at 40° C.

**Altitude:** Up to 3,048 m (10,000 ft) at or below 30° C.

**Cooling**
The instrument relies on forced air cooling with internal fans and vents. Take care to avoid restricting the airflow to any part of the oscilloscope. Around the sides and rear, leave a minimum of 15 cm (6 inches) between the instrument and the nearest object. At the bottom, the oscilloscope feet (up or down) provide adequate clearance.

⚠️ **CAUTION.** Do not block oscilloscope vents. Always keep the area beneath the oscilloscope clear of paper and other items.

The instrument also has internal fan control circuitry that regulates the fan speed based on the ambient temperature. This is performed automatically after start-up.

**Cleaning**
Clean only the exterior of the oscilloscope using a soft cloth moistened with water or an alcohol solution. Do not use harsh chemicals or abrasive elements. Under no circumstances submerge the instrument or allow moisture to penetrate it. Avoid electric shock by unplugging the power cord from the AC outlet before cleaning.

⚠️ **CAUTION.** Do not attempt to clean internal parts. Refer to qualified service personnel.

**Power**

**AC POWER**
The instrument operates from a single-phase, 100 to 240 Vrms (± 10%) AC power source at 50/60/400 Hz (± 10%). Manual voltage selection is not required because the instrument automatically adapts to the line voltage.

Installation Category: 300V CAT II

**POWER CONSUMPTION**
Maximum power consumption (with all accessories plugged-in): 350 W (350 VA).

Power consumption in Standby mode: 4 W
POWER AND GROUND CONNECTIONS
The instrument is provided with a 10A/250V 18AWG rated grounded cord set containing a molded three-terminal polarized plug and a standard IEC-60320 (Type C13) connector for making line voltage and safety ground connections.

The AC inlet ground is connected directly to the frame of the instrument. For adequate protection against electric shock, connect to a mating outlet with a safety ground contact.

WARNING. Only use the power cord provided with your instrument. Interrupting the protective conductor inside or outside the oscilloscope, or disconnecting the safety ground terminal, creates a hazardous situation. Intentional interruption is prohibited.

STANDBY POWER
The Standby Power button controls the operational state of the oscilloscope. Press the button to switch the instrument On or into Standby mode (Off).

Always use the Standby button or the File > Shutdown menu option to execute a proper shut down process and preserve settings before powering down.

Powering off does not disconnect the oscilloscope from the AC power supply. The only way to fully power down the instrument is to shut down then unplug the AC power cord from the outlet.

We recommend unplugging the instrument if it will be unused for a long period of time.

Calibration
The oscilloscope is calibrated at the factory prior to being shipped. This calibration is run at 23°C (± 2°C) and is valid for temperatures ± 5°C of the original calibration temperature. Within this temperature range the oscilloscope will meet all of the specifications.

See Calibration Settings for an explanation of the manual calibration options.

Schedule an annual factory calibration as part of your regular maintenance. Extended warranty, calibration, and upgrade plans are available for purchase. Contact your Teledyne LeCroy sales representative or customersupport@teledynelecroy.com to purchase a service plan.

Touch Screen Calibration
Periodically calibrate the touch screen to maintain its accuracy and responsiveness. We recommend that you use the stylus (or a capped pen) rather than your finger for this procedure.

1. From the menu bar, choose Utilities > Utilities Setup.
2. On the Utilities main dialog, touch Touchscreen Calibration.
3. Following the prompts, touch as close as possible to the center of each red cross that appears on the screen until the calibration sequence is complete.
Oscilloscope Application Software

**Language Selection**
To change the language that appears on the display, go to Utilities > Preference Setup > Preferences and make your Language selection. Reboot the oscilloscope after changing the language.

To also change the language of the Windows operating system:

1. Choose File > Minimize to hide the oscilloscope display and show the Windows Desktop.
2. From the Windows task bar, choose Start > Control Panel > Clock, Language and Region.
3. Under Region and Language select Change Display Language.
4. Touch the Install/Uninstall Languages button.
5. Select Install Language and Browse Computer or Network.
6. Touch the Browse button, navigate to D:\Lang Packs\ and select the language you want to install. The available languages are: German, Spanish, French, Italian, and Japanese. Follow the installer prompts.

   **NOTE:** Other language packs are available from Microsoft’s website.

7. After exiting the Control Panel, touch the oscilloscope display icon in the lower-right corner of the desktop to maximize the oscilloscope display.

**Restore Default Setup**
Restore the oscilloscope to its factory default state by pressing the Front Panel Default Setup button.

You can also restore default settings by choosing File > Recall Setup > Recall Default.

Default settings for your oscilloscope include the following:

<table>
<thead>
<tr>
<th>Channel/Vertical</th>
<th>C1-C4 on at 50 mV/div Scale, 0 V Offset, Linear Interpolation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timebase</td>
<td>Real Time Sampling at 50 ns/div, 0 Delay, 1.25 kS at 2.5 GS/s, 1.0 MS Memory</td>
</tr>
<tr>
<td>Trigger</td>
<td>C1 with an Auto Positive Edge, DC Coupling, 0 V Level</td>
</tr>
<tr>
<td>Display</td>
<td>Auto Grid</td>
</tr>
<tr>
<td>Cursors</td>
<td>Off</td>
</tr>
<tr>
<td>Measurements</td>
<td>Cleared</td>
</tr>
<tr>
<td>Math</td>
<td>Cleared</td>
</tr>
</tbody>
</table>
Add Software Option

Many optional software packages are available to extend the Analysis functions of the oscilloscope. See the product page at teledynelecroy.com for a list of options compatible with your model.

Contact your local Teledyne LeCroy representative or national distributor to purchase an option. You will receive a Key Code by email that enables the new functionality.

To install the key and activate the software:

1. From the menu bar, choose **Utilities > Utilities Setup**, then touch the **Options tab**.
2. Touch **Add Key**.

   The Virtual Keyboard appears onscreen

3. Use the Virtual Keyboard to type the Key Code in the **Enter Option Key** field, then touch **O.K.** on the keyboard to enter the information.

   The Key Code is added to the list of Installed Option Keys. You can use the Up/Down buttons to scroll the list. The software option that each key activates is displayed below the list.

4. Restart the oscilloscope application:

   Choose **File > Shutdown**.

   Wait 10 seconds, then press the **Power button** on the front of the oscilloscope.

Restoring Software Using the Acronis Application

Your oscilloscope is designed to operate reliably for many years. The application software operating the instrument runs on a Windows XP platform. The loading of additional applications or incomplete removal of applications can cause problems in the stability of the operating system. Severe cases may require that you restore the base operating system and oscilloscope application.

For this purpose, Teledyne LeCroy provides you with an **Acronis** recovery application and a backup image in an extra partition on the instrument's hard drive. The recovery process is easy to perform, using the Recovery Wizard.

Instructions for running the recovery application are stored on the oscilloscope Windows Desktop. They are also available from our support page at teledynelecroy.com. Since third-party recovery software is used, our instructions may not be the most definitive or current. We encourage you to take advantage of resources available on the Acronis website at www.acronis.com.

After the recovery procedure is done, you must re-activate Windows, either by internet connection to Microsoft's website or by telephone. Have your Windows Product Key number (shown on a sticker on your oscilloscope) handy during Windows reactivation.

The recovery process produces a replica of the operating system and oscilloscope application software at the revision levels current when the oscilloscope was manufactured. Any further revisions of the application software, Windows operating system, or virus scan definition files are not automatically
upgraded. Therefore, after completion of the disk image recovery, it is highly recommended to search vendor websites and upgrade the individual components to current revision levels.

The latest oscilloscope application software can be downloaded directly from the Teledyne LeCroy website at teledynelecroy.com.

Since the calibration data for the oscilloscope is stored in the D: drive, current calibration constants are not overwritten during the recovery process.

**Technical Support**

**Phone**
Registered users can contact their local Teledyne LeCroy service center at the number listed in this manual to make Technical Support requests by phone or email.

**Web**
You can also submit Technical Support requests via the website at:
teledynelecroy.com/support/techhelp.

Teledyne LeCroy publishes a free Technical Library on its website. Manuals, tutorials, application notes, white papers, and videos are available to help you get the most out of your Teledyne LeCroy products.

The Datasheet published on the product page contains the detailed product specifications.

You can also download Oscilloscope System Recovery Tools and Procedures, which contains instructions for using Acronis® True Image® Home included with the oscilloscope.

**Returning a Product for Service**
Contact your local Teledyne LeCroy service center for calibration or other service.

**Returning a Product**
If the product cannot be serviced on location, the service center will give you a Return Material Authorization (RMA) code and instruct you where to ship the product. All products returned to the factory must have an RMA.

**Return shipments must be prepaid.** Teledyne LeCroy cannot accept COD or Collect shipments. We recommend air-freighting. Insure the item you’re returning for at least the replacement cost.

Follow these steps for a smooth product return.

1. Remove all accessories from the device. Do not include the manual.
2. Pack the product in its case, surrounded by the original packing material (or equivalent).
3. Label the case with a tag containing:
   - The RMA
   - Name and address of the owner
   - Product model and serial number
   - Description of failure or requisite service
4. Pack the product case in a cardboard shipping box with adequate padding to avoid damage in transit.
5. Mark the outside of the box with the shipping address given to you by Teledyne LeCroy; be sure to add the following:
   
   - ATTN: <RMA code assigned by Teledyne LeCroy>
   - FRAGILE

6. If returning a product to a different country:
   
   - Mark the shipment as a "Return of US manufactured goods for warranty repair/recalibration."
   - If there is a cost for the service, list the cost in the Value column and the original purchase price "For insurance purposes only."
   - Be very specific about the reason for shipment. Duties may have to be paid on the value of the service.

**Service Plans**

Extended warranty, calibration, and upgrade plans are available for purchase. Contact your Teledyne LeCroy sales representative or customersupport@teledynelecroy.com to purchase a service plan.
Teledyne LeCroy Service Centers

United States and Canada - World Wide Corporate Office
Teledyne LeCroy Corporation
700 Chestnut Ridge Road
Chestnut Ridge, NY, 10977-6499, USA
FAX: 845-578-5985
teledynelecroy.com
Support:
contact.corp@teledynelecroy.com
Sales:
customersupport@teledynelecroy.com

United States - Protocol Solutions Group
Teledyne LeCroy Corporation
3385 Scott Boulevard
Santa Clara, CA, 95054, USA
FAX: 408-727-0800
teledynelecroy.com
Sales and Service:
Ph: 800-909-7211 / 408-727-6600
contact.corp@teledynelecroy.com
Support:
Ph: 800-909-7112 / 408-653-1260
psgsupport@teledynelecroy.com

European Headquarters
Teledyne LeCroy SA
4, Rue Moïse Marcinhes
Case postale 341
1217 Meyrin 1
Geneva, Switzerland
Ph: + 41 22 719 2228 / + 41 22 719 2323 / + 41 22 719 2277
FAX: +41 22 719 2233
contact.sa@teledynelecroy.com
applications.indirect@teledynelecroy.com
teledynelecroy.com/europe
Protocol Analyzers:
Ph: +44 12 765 03971

Singapore, Oscilloscopes
Teledyne LeCroy Singapore Pte Ltd.
Blk 750C Chai Chee Road #02-08
Technopark @ Chai Chee
Singapore 469003
Ph: ++ 65 64424880
FAX: ++ 65 64427811
HDO6000 High Definition Oscilloscope

Singapore, Protocol Analyzers
Genetron Singapore Pte Ltd.
37 Kallang Pudding Road, #08-08
Tong Lee Building Block B
Singapore 349315
Ph: ++65 9760-4682

China
Teledyne LeCroy Corporation Beijing
Rm. 2001
Unit A, Horizon Plaza
No. 6, Zhichun Road, Haidian District
Beijing 100088, China
Ph: ++86 10 8280 0318 / ++86 10 8280 0319 / ++86 10 8280 0320
FAX: ++86 10 8280 0316
Service:
Rm. 2002
Ph: ++86 10 8280 0245

Taiwan
LeColn Technology Co Ltd.
Far East Century Park, C3, 9F
No. 2, Chien-8th Road,
Chung-Ho Dist., New Taipei City, Taiwan
Ph: ++ 886 2 8226 1366
FAX: ++ 886 2 8226 1368

Korea
Teledyne LeCroy Korea
10th fl. Ildong Bldg.
968-5 Daechi-dong, Gangnam-gu
Seoul 135-280, Korea
Ph: ++ 82 2 3452 0400
FAX: ++ 82 2 3452 0490

Japan
Teledyne LeCroy Japan
Hobunsha Funchu Bldg, 3F
3-11-5, Midori-cho, Fuchu-Shi
Tokyo 183-0006, Japan
Ph: ++ 81 4 2402 9400
FAX: ++ 81 4 2402 9586
teledynelecroy.com/japan
Certifications and Licenses

Certifications
This section certifies the instrument’s Electromagnetic Compatibility (EMC), Safety and Environmental compliances.

EMC Compliance

EC DECLARATION OF CONFORMITY- EMC
The oscilloscope meets intent of EC Directive 2004/108/EC for Electromagnetic Compatibility. Compliance was demonstrated to the following specifications as listed in the Official Journal of the European Communities:

EN 61326-1:2006, EN 61326-2-1:2006 EMC requirements for electrical equipment for measurement, control, and laboratory use. ¹

Electromagnetic Emissions:
CISPR 11:2003, Radiated and Conducted Emissions Group 1, Class A ² ³
EN 61000-3-2:2006 Harmonic Current Emissions, Class A
EN 61000-3-3/A2:2005 Voltage Fluctuations and Flickers, Pst = 1

Electromagnetic Immunity:
EN 61000-4-2:2001 Electrostatic Discharge, 4 kV contact, 8 kV air, 4 kV vertical/horizontal coupling planes ⁴
EN 61000-4-3:2006 RF Radiated Electromagnetic Field, 3 V/m, 80-1000 MHz; 3 V/m, 1400 MHz - 2 GHz; 1 V/m, 2 GHz - 2.7 GHz ⁴
EN 61000-4-4:2004 Electrical Fast Transient/Burst, 1 kV on power supply lines, 0.5 kV on I/O signal data and control lines ⁴
EN 61000-4-5:2006 Power line Surge, 1 kV AC Mains, L-N, L-PE, N-PE ⁴
EN 61000-4-6:2007 RF Conducted Electromagnetic Field, 3 Vrms, 0.15 MHz - 80 MHz ⁴
EN 61000-4-11:2004 Mains Dips and Interruptions, 0%/1 cycle, 70%/25 cycles, 0%/250 cycles ⁴ ⁵

¹ To ensure compliance with all applicable EMC standards, high quality shielded interface cables should be used.
² Emissions which exceed the levels required by this standard may occur when the oscilloscope is connected to a test object.
³ This product is intended for use in nonresidential areas only. Use in residential areas may cause electromagnetic interference.
⁴ Meets Performance Criteria “B” limits of the respective standard: during the disturbance, product undergoes a temporary degradation or loss of function or performance which is self-recoverable.
⁵ Performance Criteria “C” applied for 70%/25 cycle voltage dips and for 0%/250 cycle voltage interruption test levels per EN61000-4-11.

European Contact:
Teledyne LeCroy Europe GmbH
Waldhofer Str 104
D-69123 Heidelberg
Germany
Tel: (49) 6221 82700
AUSTRALIA & NEW ZEALAND DECLARATION OF CONFORMITY– EMC
Oscilloscope complies with the EMC provision of the Radio Communications Act per the following standards, in accordance with requirements imposed by Australian Communication and Media Authority (ACMA):


Australia / New Zealand Contacts:
Vicom Australia Ltd.  
1064 Centre Road  
Oakleigh, South Victoria 3167  
Australia

Vicom New Zealand Ltd.  
60 Grafton Road  
Auckland  
New Zealand

Safety Compliance

EC DECLARATION OF CONFORMITY– LOW VOLTAGE
The oscilloscope meets intent of EC Directive 2006/95/EC for Product Safety. Compliance was demonstrated to the following specifications as listed in the Official Journal of the European Communities:

EN 61010-1:2010 Safety requirements for electrical equipment for measurement, control, and laboratory use – Part 1: General requirements

EN 61010-2-030:2010 Safety requirements for electrical equipment for measurement, control, and laboratory use – Part 2-030: Particular requirements for testing and measuring circuits

The design of the instrument has been verified to conform to the following limits put forth by these standards:

- Overvoltage Category II: equipment intended to be supplied from the building wiring with a nominal supply voltage up to 300V.
- Measurement Category 0: oscilloscope measurement terminals that are not intended to be directly connected to the MAINS supply.
- Pollution Degree 2: operating environment where normally only dry, non-conductive pollution occurs. Occasionally a temporary conductivity that is caused by condensation must be expected. This location is a typical office/home environment.
- Protection Class I: grounded equipment in which protection against electric shock is achieved by basic insulation and a connection to the protective ground conductor in the building wiring.

U.S. NATIONALLY RECOGNIZED AGENCY CERTIFICATION
The oscilloscope has been certified by Underwriters Laboratories (UL) to conform to the following safety standard and bears UL Listing Mark:

UL 61010-1 Third Edition – Safety standard for electrical measuring and test equipment.

CANADIAN CERTIFICATION
The oscilloscope has been certified by Underwriters Laboratories (UL) to conform to the following safety standard and bears cUL Listing Mark:

CAN/CSA-C22.2 No. 61010-1-12. Safety requirements for electrical equipment for measurement, control and laboratory use.
Environmental Compliance

End-of-Life Handling

The instrument is marked with this symbol to indicate that it complies with the applicable European Union requirements to Directives 2002/96/EC and 2006/66/EC on Waste Electrical and Electronic Equipment (WEEE) and Batteries.

The instrument is subject to disposal and recycling regulations that vary by country and region. Many countries prohibit the disposal of waste electronic equipment in standard waste receptacles. For more information about proper disposal and recycling of your Teledyne LeCroy product, please visit teledynelecroy.com/recycle.

Restriction of Hazardous Substances (RoHS)

This instrument has been classified as Industrial Monitoring and Control Equipment, and is outside the scope of the 2011/65/EU RoHS Directive until 22 July 2017 (per Article IV, Paragraph 3).

ISO Certification

Manufactured under an ISO 9000 Registered Quality Management System. Visit teledynelecroy.com to view the certificate.

Windows License Agreement

The HDO6000Oscilloscope software runs on a Windows® operating system. Teledyne LeCroy’s agreement with Microsoft® prohibits users from running software that is not relevant to measuring, analyzing, or documenting waveforms on Teledyne LeCroy oscilloscopes.